Bug 5489 - Boot fails with BIOS memory remapping enabled on an Adaptec SCSI system with Asus A8V and 4GB of RAM
Summary: Boot fails with BIOS memory remapping enabled on an Adaptec SCSI system with ...
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Andrew Morton
URL:
Keywords:
: 5487 5488 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-10-24 09:38 UTC by Siegbert Baude
Modified: 2005-10-26 00:52 UTC (History)
0 users

See Also:
Kernel Version: 2.6.13.4
Tree: Mainline
Regression: ---


Attachments
Boot log of vanilla 2.6.13.4 without BIOS memory remapping enabled (9.59 KB, text/plain)
2005-10-24 09:39 UTC, Siegbert Baude
Details
Boot log of vanilla 2.6.13.4 with BIOS memory remapping enabled (223.76 KB, text/plain)
2005-10-24 09:41 UTC, Siegbert Baude
Details
Kernel config of vanilla 2.6.13.4 (17.39 KB, text/plain)
2005-10-24 09:41 UTC, Siegbert Baude
Details
Boot log of SUSE 10.0 without BIOS memory remapping enabled (11.81 KB, text/plain)
2005-10-24 09:43 UTC, Siegbert Baude
Details
Boot log of SUSE 10.0 with BIOS memory remapping enabled (150.33 KB, text/plain)
2005-10-24 09:43 UTC, Siegbert Baude
Details

Description Siegbert Baude 2005-10-24 09:38:13 UTC
Most recent kernel where this bug did not occur: unknown
Distribution: SUSE 9.2
Hardware Environment: Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
                      <Adaptec 19160B Ultra160 SCSI adapter>
                      Asus A8V (newest BIOS) with 4GB of Crucial RAM
                      MAXTOR    Model: ATLAS10K4_36WLS   Rev: DFV0
                      Radeon 7000
Software Environment: Kernel build done on Suse 9.2:
Linux albatross 2.6.8-24.18-default #1 Fri Aug 19 11:56:28 UTC 2005 x86_64
x86_64 x86_64 GNU/Linux
 
Gnu C                  3.3.4
Gnu make               3.80
binutils               2.15.91.0.2
util-linux             2.12c
mount                  2.12c
module-init-tools      3.1-pre5
e2fsprogs              1.35
jfsutils               1.1.7
reiserfsprogs          3.6.18
reiser4progs           line
xfsprogs               2.6.13
quota-tools            3.11.
nfs-utils              1.0.6
Linux C Library        02 04:13 /lib64/tls/libc.so.6
Dynamic linker (ldd)   2.3.3
Linux C++ Library      5.0.7
Procps                 3.2.3
Net-tools              1.60
Kbd                    1.12
Sh-utils               5.2.1
udev                   030

Problem Description:

The above system boots fine with the BIOS memory remapping option disabled. The
boot log of this case is attached as "2.6.13.4_without_remapping.txt".
If I however enable BIOS memory remapping to make full use of the 4GB RAM, the
boot fails within the scsi driver routines. This boot log is attached as
"2.6.13.4_with_remapping.txt".

The kernel I used for this test is a quite minimalistic, static (i.e. without
modules) vanilla kernel; its config file is attached as "config-2.6.13.4".

I also tried to boot with the newest SUSE 10.0 CD in rescue mode, which uses a
kernel with modules. The result is mostly the same. I attached the boot log with
disabled BIOS memory remapping as "SUSE-10.0-RESCUE-2.6.13-15_without_remapping.txt"
the log with enabled BIOS memory remapping as
"SUSE-10.0-RESCUE-2.6.13-15_with_remapping.txt".

The last one was caught in a loop, so I rebooted by SysRq.

On the SUSE AMD64 mailing list there was a report of a success with the A8V
(same BIOS), 4GB of RAM and BIOS memory remapping enabled, where the only
apparent difference seemed to be, that this was an IDE system, whereas mine is a
SCSI one. As booting always fails in the scsi part, I suspect an error in the
aic7xxx driver.

Steps to reproduce: Boot any recent kernel on a machine with an Adaptec 19160B,
Asus A8V and 4GB of RAM.
Comment 1 Siegbert Baude 2005-10-24 09:39:58 UTC
Created attachment 6372 [details]
Boot log of vanilla 2.6.13.4 without BIOS memory remapping enabled
Comment 2 Siegbert Baude 2005-10-24 09:41:09 UTC
Created attachment 6373 [details]
Boot log of vanilla 2.6.13.4 with BIOS memory remapping enabled
Comment 3 Siegbert Baude 2005-10-24 09:41:54 UTC
Created attachment 6374 [details]
Kernel config of vanilla 2.6.13.4
Comment 4 Siegbert Baude 2005-10-24 09:43:03 UTC
Created attachment 6375 [details]
Boot log of SUSE 10.0 without BIOS memory remapping enabled
Comment 5 Siegbert Baude 2005-10-24 09:43:41 UTC
Created attachment 6376 [details]
Boot log of SUSE 10.0 with BIOS memory remapping enabled
Comment 6 Diego Calleja 2005-10-24 10:10:00 UTC
*** Bug 5488 has been marked as a duplicate of this bug. ***
Comment 7 Diego Calleja 2005-10-24 10:10:05 UTC
*** Bug 5487 has been marked as a duplicate of this bug. ***
Comment 8 Andrew Morton 2005-10-24 11:56:19 UTC

Begin forwarded message:

Date: Mon, 24 Oct 2005 09:41:29 -0700
From: bugme-daemon@kernel-bugs.osdl.org
To: akpm@osdl.org
Subject: [Bug 5489] New: Boot fails with BIOS memory remapping enabled on an Adaptec SCSI system with Asus A8V and 4GB of RAM


http://bugzilla.kernel.org/show_bug.cgi?id=5489

           Summary: Boot fails with BIOS memory remapping enabled on an
                    Adaptec SCSI system with Asus A8V and 4GB of RAM
    Kernel Version: 2.6.13.4
            Status: NEW
          Severity: high
             Owner: akpm@osdl.org
         Submitter: siegbert.baude@gmx.de


Most recent kernel where this bug did not occur: unknown
Distribution: SUSE 9.2
Hardware Environment: Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
                      <Adaptec 19160B Ultra160 SCSI adapter>
                      Asus A8V (newest BIOS) with 4GB of Crucial RAM
                      MAXTOR    Model: ATLAS10K4_36WLS   Rev: DFV0
                      Radeon 7000
Software Environment: Kernel build done on Suse 9.2:
Linux albatross 2.6.8-24.18-default #1 Fri Aug 19 11:56:28 UTC 2005 x86_64
x86_64 x86_64 GNU/Linux
 
Gnu C                  3.3.4
Gnu make               3.80
binutils               2.15.91.0.2
util-linux             2.12c
mount                  2.12c
module-init-tools      3.1-pre5
e2fsprogs              1.35
jfsutils               1.1.7
reiserfsprogs          3.6.18
reiser4progs           line
xfsprogs               2.6.13
quota-tools            3.11.
nfs-utils              1.0.6
Linux C Library        02 04:13 /lib64/tls/libc.so.6
Dynamic linker (ldd)   2.3.3
Linux C++ Library      5.0.7
Procps                 3.2.3
Net-tools              1.60
Kbd                    1.12
Sh-utils               5.2.1
udev                   030

Problem Description:

The above system boots fine with the BIOS memory remapping option disabled. The
boot log of this case is attached as "2.6.13.4_without_remapping.txt".
If I however enable BIOS memory remapping to make full use of the 4GB RAM, the
boot fails within the scsi driver routines. This boot log is attached as
"2.6.13.4_with_remapping.txt".

The kernel I used for this test is a quite minimalistic, static (i.e. without
modules) vanilla kernel; its config file is attached as "config-2.6.13.4".

I also tried to boot with the newest SUSE 10.0 CD in rescue mode, which uses a
kernel with modules. The result is mostly the same. I attached the boot log with
disabled BIOS memory remapping as "SUSE-10.0-RESCUE-2.6.13-15_without_remapping.txt"
the log with enabled BIOS memory remapping as
"SUSE-10.0-RESCUE-2.6.13-15_with_remapping.txt".

The last one was caught in a loop, so I rebooted by SysRq.

On the SUSE AMD64 mailing list there was a report of a success with the A8V
(same BIOS), 4GB of RAM and BIOS memory remapping enabled, where the only
apparent difference seemed to be, that this was an IDE system, whereas mine is a
SCSI one. As booting always fails in the scsi part, I suspect an error in the
aic7xxx driver.

Steps to reproduce: Boot any recent kernel on a machine with an Adaptec 19160B,
Asus A8V and 4GB of RAM.

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

Comment 9 Anonymous Emailer 2005-10-24 13:43:14 UTC
Reply-To: James.Bottomley@SteelEye.com

On Mon, 2005-10-24 at 11:58 -0700, Andrew Morton wrote:
> Subject: [Bug 5489] New: Boot fails with BIOS memory remapping enabled on an Adaptec SCSI system with Asus A8V and 4GB of RAM
> 
> 
> http://bugzilla.kernel.org/show_bug.cgi?id=5489
> 
>            Summary: Boot fails with BIOS memory remapping enabled on an
>                     Adaptec SCSI system with Asus A8V and 4GB of RAM

This sounds very similar to this problem (at least in terms of cause):

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167049

If it is, then the problem should be fixed in the latest vanilla or -mm
kernel (could you verify).

Thanks,

James




Comment 10 Siegbert Baude 2005-10-26 00:52:19 UTC
I didn't manage to compile the latest mm-kernel, but 2.6.14-rc5-git5 indeed
solves the problem, I cleanly enter init even with BIOS memory remaping enabled. :-)

Note You need to log in before you can comment on or make changes to this bug.