Bug 54751 - Screen stays black after trying to wake up from suspend
Screen stays black after trying to wake up from suspend
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: intel-gfx-bugs@lists.freedesktop.org
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2013-03-04 13:04 UTC by clime
Modified: 2013-04-09 15:03 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.8.1
Tree: Mainline
Regression: Yes


Attachments
Messages from the point when resume event occurred (30.61 KB, text/plain)
2013-03-07 18:09 UTC, clime
Details

Description clime 2013-03-04 13:04:26 UTC
If I suspend my computer, I can't wake it up again. There is some activity going on because I can see that my led icons for wifi and hdd light up. But screen stays black and I can only switch the computer off and on at this point. This does not happen with kernel 3.7.9. My computer is Toshiba Portege 11M. Please, let me know if you further information.
Comment 1 Aaron Lu 2013-03-05 03:00:37 UTC
Hi,

Please let me know what kernel version has this problem, v3.8?
And if possible, can you please ssh to your system after resume and attach the dmesg here? Thanks.
Comment 2 clime 2013-03-07 18:09:09 UTC
Created attachment 94741 [details]
Messages from the point when resume event occurred
Comment 3 clime 2013-03-07 18:10:54 UTC
It happens for 3.8.1. I don't know about 3.8.0 because my distribution (fedora) jumped from 3.7.9 to 3.8.1. Hopefully it will be possible to fix somehow.
Comment 4 Aaron Lu 2013-03-08 01:07:37 UTC
System resumed fine, looks like a drm graphics driver issue to me. Move it for graphics guys.

3.7.9 no problem, 3.8.1 has this problem: after resume, screen is blank.
Comment 5 Daniel Vetter 2013-03-11 17:28:28 UTC
Can you please retest with 3.9-rc2, just to exclude that it's not a duplicate with one of the recently fixed bugs?

Also please boot a broken kernel with drm.debug=0xe added to your kernel cmdline, reproduce the resume failure and attach the kernel log.

Finally a kernel bisect of this issue is always really helpful, my favourite guide is

http://www.reactivated.net/weblog/archives/2006/01/using-git-bisect-to-find-buggy-kernel-patches/
Comment 6 clime 2013-04-09 10:15:58 UTC
It works already under kernel 3.8.3.
Comment 7 Daniel Vetter 2013-04-09 15:03:36 UTC
Thanks for reporting back and please reopen this bug if it breaks again.

Note You need to log in before you can comment on or make changes to this bug.