Bug 5436 - module scanner is missing from /drivers/usb/image folder
module scanner is missing from /drivers/usb/image folder
Status: REJECTED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-10-14 01:44 UTC by Nadav Kavalerchik
Modified: 2005-10-14 10:25 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.12
Tree: Mainline
Regression: ---


Attachments

Description Nadav Kavalerchik 2005-10-14 01:44:45 UTC
Most recent kernel where this bug did not occur: 2.6.9 (i think)  
Distribution: Fedora Devel  
Hardware Environment: Intel PIII 450 , UMAX 3450U (scanner)  
Software Environment: xsane 1.0.16  
Problem Description:  
missing scanner.o module in kernel tree (from folder /drivers/usb/image) 
  
Steps to reproduce:  
plugin the scanner (turn it on) or trying modprobe scanner.
Comment 1 Nishanth Aravamudan 2005-10-14 06:46:51 UTC
I don't think there *is* a kernel scanner driver anymore. Since 2.6.4 maybe?

"With Linux 2.4.* you could either use the kernel scanner module or libusb to
access USB scanners.  In Linux 2.6.4 the kernel scanner module was removed.
Therefore with this and later kernels libusb must be used."

From: http://www.sane-project.org/README.linux

Greg, can this bug be closed?

Thanks,
Nish
Comment 2 Greg Kroah-Hartman 2005-10-14 10:25:07 UTC
A kernel driver is not needed for the usb scanner, use xscane, it works just fine
using libusb.

Note You need to log in before you can comment on or make changes to this bug.