Bug 5413 - usbserial generic device poweroff; host hangs shortly after
usbserial generic device poweroff; host hangs shortly after
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-10-10 13:45 UTC by Ilya Konstantinov
Modified: 2005-10-10 14:15 UTC (History)
0 users

See Also:
Kernel Version: 2.6.12
Tree: Mainline
Regression: ---


Attachments

Description Ilya Konstantinov 2005-10-10 13:45:42 UTC
I'm connecting a Nokia 6230i phone with a USB cable. After telling the phone not
to behave as a USB Storage device, it appears as a USB Serial device. The
nokia_dku2 module (source attached) makes sure the right endpoint is used, but
otherwise the 'generic' usbserial is used.

When the device resets, either when it spontaneously reboots due to an invalid
command I send it (with gnokii) or when I intentionally press its Power button
and shut it down (in an ordely fashion), the kernel hangs shortly after.

This doesn't appear to be affected by usbserial being operational (performing
reads/writes) at that point. When I perform writes which cause the device to
spontaneously reboot, the hang comes few seconds after it reports the device's
ETIMEOUT (-110) and then disconnection; I even managed to enter a few characters
on the console before it hung tight (magic-sysrq was on and alt-sysrq-p had no
effect).
Comment 1 Greg Kroah-Hartman 2005-10-10 13:53:07 UTC
I don't see the source attached.
Comment 2 Ilya Konstantinov 2005-10-10 14:15:52 UTC
Actually, I figured out:
1. I don't need usbserial loaded to reproduce the problem.
2. I don't need ohci-hcd loaded to reproduce the problem.
so that pretty much makes it a hardware problem of mine, thus INVALID.

BTW, There's some wicked stuff happening when the phone shuts down, ranging from
system hangs to my SATA hard-drive suddenly stopping operations, sata_nv
complaining one of the ports returns unexpected data (and resuming operating
just fine after a reboot).

Note You need to log in before you can comment on or make changes to this bug.