Bug 5396 - reboot hang - HP/Compaq tc4200
reboot hang - HP/Compaq tc4200
Status: CLOSED DUPLICATE of bug 6655
Product: ACPI
Classification: Unclassified
Component: Power-Off
i386 Linux
: P2 normal
Assigned To: Alexey Starikovskiy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 11:39 UTC by Anthony Mattas
Modified: 2007-03-08 23:06 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.12
Tree: Mainline
Regression: ---


Attachments
dmesg, lspci, find /proc (19.22 KB, application/octet-stream)
2005-10-07 11:40 UTC, Anthony Mattas
Details

Description Anthony Mattas 2005-10-07 11:39:58 UTC
Hardware Environment: HP/Compaq tc4200
Problem Description: This computer will not reboot even enabling X86_REBOOTFIXUPS=Y

Steps to reproduce:
Comment 1 Anthony Mattas 2005-10-07 11:40:44 UTC
Created attachment 6258 [details]
dmesg, lspci, find /proc
Comment 2 rudolph 2005-10-12 20:38:22 UTC
I have an nc6220, exhibiting the same problem on (attempted) reboot.
X86_REBOOTFIXUPS=Y does not help either.
Comment 3 rudolph 2005-10-12 20:39:44 UTC
Apologies for not including this in my previous report, but I'm seeing the
problem on 2.6.14-rc4
Comment 4 Luming Yu 2005-10-12 23:28:22 UTC
try acpi=off to see if reboot works?
Comment 5 Pavel Alexeev 2005-10-13 01:35:40 UTC
The same problem on my Compaq nx8220, see also the bug 5221. Now, with the
2.6.14-rc4 kernel:
acpi=off:    does NOT reboot, hangs with the blank black screen after
"Rebooting." line appears (i don't see any line, even "Restarting system.\n.",
after this "Rebooting.").
acpi=noirg:  does NOT reboot, hangs after "Restarting system.\n."
pci=noacpi:  does NOT reboot, hangs after "Restarting system.\n."
pnpacpi=off: does NOT reboot, hangs after "Restarting system.\n."
Note: The kernel is patched with the patch from
https://bugzilla.novell.com/show_bug.cgi?id=116763 . The kernel DOES NOT BOOT on
my laptop without this patch applied.
Comment 6 Shaohua 2005-10-13 01:41:24 UTC
Could you please try the patch at http://lkml.org/lkml/2005/8/23/16?
Also does reboot ever work in the system before?
Comment 7 Shaohua 2005-10-13 01:44:45 UTC
Also, could please try different reboot options?
Such as reboot=c,b or w,b?
Comment 8 rudolph 2005-10-16 21:13:21 UTC
mach_reboot.h patch appears to be in 2.6.14-rc4, which I am running on my nc6220
that still has reboot problem
Comment 9 rudolph 2005-10-16 21:15:43 UTC
both reboot=c,b and w,b work for me. The system (2.6.14-rc4 with the ACPI patch
pavel mentions) now boots and reboots successfully.

Thanks for the suggestion.
Comment 10 Shaohua 2005-10-17 19:04:40 UTC
So the system needs to jump to BIOS for BIOS. We can add a quirk to make the 
it automically (doesn't need boot option anymore) for your system.
Did reboot ever work in the system before?
Comment 11 rudolph 2005-10-17 19:22:03 UTC
previous kernel I tried, 2.6.12.6, worked fine wrt reboot and all other ACPI issues.
Comment 12 Len Brown 2005-12-01 19:30:37 UTC
Shaohua - perhaps this machine would work better if it
were using the FADT reset_register instead of the
keyboard controller -- can you build a test patch to try that?
Comment 13 rudolph 2005-12-22 10:29:48 UTC
just wondering when the mentioned patch will be available (or if an alternate
patch is in the kernel already)?
Comment 14 Shaohua 2006-01-17 18:54:19 UTC
The patch Len mentioned just adds a new boot option just like reboot=c,b and 
w,b. So you still need boot option, it can't make your system automically work.

One another option is blacklist your laptop, let it always enter bios for 
reboot. This way you don't need boot option.
Comment 15 rudolph 2006-02-03 03:30:02 UTC
On Tue, Jan 17, 2006 at 07:05:56PM -0800, bugme-daemon@bugzilla.kernel.org wrote:
> ------- Additional Comments From shaohua.li@intel.com  2006-01-17 18:54 -------
> The patch Len mentioned just adds a new boot option just like reboot=c,b and 
> w,b. So you still need boot option, it can't make your system automically work.
> 
> One another option is blacklist your laptop, let it always enter bios for 
> reboot. This way you don't need boot option.
I'm happy with either option; unless there are other reports of it being
an issue perhaps blacklisting it is too much effort.

Thanks

Comment 16 Len Brown 2006-02-15 18:50:11 UTC
Windows didn't get confused by this laptop, so Linux shouldn't either.
It should reset/reboot without any manual workaround.

We need to see if the FADT reset scheme works on this laptop.
If it does, then perhaps we need to look into using that reset
scheme as default for all systems.
Comment 17 Alexey Starikovskiy 2006-04-19 07:57:03 UTC
Could you please check if 2.6.16 resolved problem?
Comment 18 Luming Yu 2006-06-12 00:03:41 UTC
Please reopen is patch at Bug 6655 cannot help.

*** This bug has been marked as a duplicate of 6655 ***
Comment 19 rudolph 2006-09-02 21:56:58 UTC
(Sorry about the lateness of my reply) I can confirm that a 2.6.18-rc5 kernel
reboots fine without any reboot flags on my nc6220.

Note You need to log in before you can comment on or make changes to this bug.