Bug 5381 - nokia phone usb connection bug
nokia phone usb connection bug
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: HotPlug
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-10-06 09:38 UTC by Imre Péntek
Modified: 2005-10-11 09:04 UTC (History)
0 users

See Also:
Kernel Version: 2.6.14-rc2-3
Tree: Mainline
Regression: ---


Attachments

Description Imre Péntek 2005-10-06 09:38:30 UTC
Most recent kernel where this bug did not occur: I don't know
Distribution: UHU-Linux dev (2.6.14-rc2-3)
Hardware Environment: amd athlon xp 64 3000+ laptop
Software Environment: hal 0.4.7
Problem Description: my nokia phone usb connection cable dooesn't works.
Steps to reproduce:
just plug it, then see dmesg:

[17182878.188000] usb 3-1: new full speed USB device using uhci_hcd and address 2
[17182878.964000] usbcore: registered new driver usbserial
[17182878.968000] drivers/usb/serial/usb-serial.c: USB Serial support registered
for Generic
[17182878.972000] usbcore: registered new driver usbserial_generic
[17182878.972000] drivers/usb/serial/usb-serial.c: USB Serial Driver core v2.0
[17182878.992000] drivers/usb/serial/usb-serial.c: USB Serial support registered
for TI USB 3410 1 port adapter
[17182878.996000] drivers/usb/serial/usb-serial.c: USB Serial support registered
for TI USB 5052 2 port adapter
[17182879.000000] ti_usb_3410_5052 3-1:1.0: TI USB 3410 1 port adapter converter
detected
[17182879.652000] usb 3-1: reset full speed USB device using uhci_hcd and address 2
[17182879.800000] usb 3-1: device firmware changed
[17182879.800000] ti_usb_3410_5052: probe of 3-1:1.0 failed with error -5
[17182879.800000] usbcore: registered new driver ti_usb_3410_5052
[17182879.800000] drivers/usb/serial/ti_usb_3410_5052.c: TI USB 3410/5052 Serial
Driver v0.9
[17182879.800000] usb 3-1: USB disconnect, address 2
[17182879.916000] usb 3-1: new full speed USB device using uhci_hcd and address 3
[17182880.108000] usb 3-1: configuration #1 chosen from 2 choices
[17182880.112000] ti_usb_3410_5052 3-1:1.0: TI USB 3410 1 port adapter converter
detected
[17182880.112000] ti_usb_3410_5052: probe of 3-1:1.0 failed with error -5
[17182958.588000] usb 3-1: USB disconnect, address 3
Comment 1 Greg Kroah-Hartman 2005-10-06 09:57:45 UTC
Can you attach the file /proc/bus/usb/devices when the device is plugged in?
Comment 2 Imre Péntek 2005-10-09 13:47:19 UTC
now some weird thing happened, so after plugging this device /var/log/syslog
contains some
Oct  9 22:45:56 localhost kernel: [17179859.580000] hub 3-0:1.0:
connect-debounce failed, port 1 disabled
messages, ti_usb_3410_5052 module doesn't loads into the memory, but anyways my
/proc/bus/usb/devices file after attaching this device:

T:  Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.14-rc2-3 uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:10.2
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.14-rc2-3 uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:10.1
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.14-rc2-3 uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:10.0
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms
Comment 3 Greg Kroah-Hartman 2005-10-10 17:07:08 UTC
The device is not being found by the kernel in that file.

Can you post the whole log from when you plug the device in?  (as a attachment
please, not in the bug report itself.)

And if you reboot, does the device get found?  And if so, can you attach
the /proc/bus/usb/devices file from that?
Comment 4 Imre Péntek 2005-10-11 08:05:50 UTC
I can't reproduce it, sorry.
Comment 5 Greg Kroah-Hartman 2005-10-11 09:04:57 UTC
So the problem doesn't happen anymore?  great.  If it does, please reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.