Bug 53571 - [fdo:54226] stale bcs->rcs semaphore
[fdo:54226] stale bcs->rcs semaphore
Status: CLOSED MOVED
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: intel-gfx-bugs@lists.freedesktop.org
https://bugs.freedesktop.org/show_bug...
:
: 57561 58501 60681 60825 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-10 15:16 UTC by Toralf Förster
Modified: 2013-11-18 15:41 UTC (History)
7 users (show)

See Also:
Kernel Version: 3.7.6
Tree: Mainline
Regression: No


Attachments
i 915 error state (321.96 KB, application/octet-stream)
2013-02-10 15:16 UTC, Toralf Förster
Details

Description Toralf Förster 2013-02-10 15:16:10 UTC
Created attachment 92941 [details]
i 915 error state

Since a longer time now it happened again an almost stable Gentoo Linux with x11-drivers/xf86-video-intel 2.20.13
Comment 1 Chris Wilson 2013-02-10 15:22:14 UTC
w/a: echo 0 > /sys/modules/i915/parameters/semaphores or i915.semaphores=0
Comment 2 Toralf Förster 2013-02-15 17:53:01 UTC
(In reply to comment #1)
> w/a: echo 0 > /sys/modules/i915/parameters/semaphores or i915.semaphores=0

issue didn't occurred (however it was rare before too)
Comment 3 Daniel Vetter 2013-05-06 08:28:11 UTC
*** Bug 57561 has been marked as a duplicate of this bug. ***
Comment 4 Chris Wilson 2013-05-20 10:57:28 UTC
*** Bug 58501 has been marked as a duplicate of this bug. ***
Comment 5 Chris Wilson 2013-08-02 19:52:50 UTC
*** Bug 60681 has been marked as a duplicate of this bug. ***
Comment 6 Chris Wilson 2013-09-01 11:10:03 UTC
*** Bug 60825 has been marked as a duplicate of this bug. ***
Comment 7 Shuhao 2013-10-17 21:27:24 UTC
I tried the work around but it did not resolve the issue.

This issue only happens when I'm playing games (very heavily if I started something like Kerbal Space Program).
Comment 8 Daniel Vetter 2013-10-17 22:08:37 UTC
(In reply to Shuhao from comment #7)
> I tried the work around but it did not resolve the issue.
> 
> This issue only happens when I'm playing games (very heavily if I started
> something like Kerbal Space Program).

Very likely a different bug, or at least we need to triage it first. Please file a bug report against dri -> drm(intel) on bugs.freedesktop.org and attach the error state from a gpu hang.
Comment 9 Shuhao 2013-10-18 02:15:32 UTC
Done: https://bugs.freedesktop.org/show_bug.cgi?id=70594

Note You need to log in before you can comment on or make changes to this bug.