Bug 5350 - oops in ohci_hcd with kernel 2.6.12 - 2.6.14-rc3-git2
Summary: oops in ohci_hcd with kernel 2.6.12 - 2.6.14-rc3-git2
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: David Brownell
URL:
Keywords:
Depends on:
Blocks: USB
  Show dependency tree
 
Reported: 2005-10-02 15:51 UTC by Frieder B
Modified: 2005-10-06 12:29 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.14-rc3-git2
Tree: Mainline
Regression: ---


Attachments
dmesg-2.6.14-rc3-git2-oops (12.15 KB, text/plain)
2005-10-02 15:51 UTC, Frieder B
Details
dmesg-2.6.14-rc2-mm2-oops (15.31 KB, text/plain)
2005-10-05 13:07 UTC, Frieder B
Details
kernel-config-2.6.14-rc2-mm2 (36.88 KB, text/plain)
2005-10-05 13:12 UTC, Frieder B
Details

Description Frieder B 2005-10-02 15:51:05 UTC
Most recent kernel where this bug did not occur: ---

Distribution: Gentoo Base System version 1.6.13

Hardware Environment: Asus A7N266-C with nforce chipset, AMD Athlon(TM) XP 2000+

Software Environment:
System uname: 2.6.14-rc3-git2 i686
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2


Problem Description:
since kernel version ~2.6.12 I occasionally get oopes with the ohci_hcd modul
during boot.

snippet of kernelmessage (complete dmesg attached -->dmesg-2.6.14-rc3-git2-oops)
Call Trace:
  [<d0c067db>] ohci_rh_resume+0xb/0x20 [ohci_hcd]
  [<c012ab8e>] worker_thread+0x1ae/0x280
  [<d0c067d0>] ohci_rh_resume+0x0/0x20 [ohci_hcd]
  [<c01178d0>] default_wake_function+0x0/0x10
  [<c01178d0>] default_wake_function+0x0/0x10
  [<c012a9e0>] worker_thread+0x0/0x280
  [<c012ec35>] kthread+0x95/0xd0
  [<c012eba0>] kthread+0x0/0xd0
  [<c0101375>] kernel_thread_helper+0x5/0x10

I need to reboot 5 times or more until the machine works.

Steps to reproduce: ---

so do you need any other informations?

thx
Comment 1 Frieder B 2005-10-02 15:51:42 UTC
Created attachment 6213 [details]
dmesg-2.6.14-rc3-git2-oops
Comment 2 David Brownell 2005-10-02 21:30:33 UTC
There are a bunch of PM related patches pending for 2.6.15,
and so far as I know they're all in the current MM patches.

Given that some usbcore changes (sometime after 2.6.11)
broke quite a few other things, I'll want to see results
of testing this with all those bugfixes.
Comment 3 Frieder B 2005-10-04 14:55:30 UTC
I
Comment 4 Greg Kroah-Hartman 2005-10-05 10:35:41 UTC
Please let us know, and then change the status of the bug.
Comment 5 Frieder B 2005-10-05 13:07:07 UTC
Created attachment 6234 [details]
dmesg-2.6.14-rc2-mm2-oops

it also fails with 2.6.14-rc2-mm2
Comment 6 Frieder B 2005-10-05 13:12:58 UTC
Created attachment 6235 [details]
kernel-config-2.6.14-rc2-mm2
Comment 7 David Brownell 2005-10-05 14:11:19 UTC
Actually it turns out that the relevant patches are NOT in 
the 2.6.14-rc2-mm2 tree.  They are however in 
 
http://www.kernel.org/pub/linux/kernel/people/gregkh/gregkh-2.6/gregkh-04-usb/ 
 
Comment 8 Frieder B 2005-10-06 12:29:45 UTC
with this patches applied it still works after 15 reboots
so these patches fix it
Thx

Note You need to log in before you can comment on or make changes to this bug.