Bug 53491 - 'xset dpms force off' breaks backlight
'xset dpms force off' breaks backlight
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: intel-gfx-bugs@lists.freedesktop.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 06:20 UTC by emailgrant
Modified: 2013-07-20 15:02 UTC (History)
2 users (show)

See Also:
Kernel Version: latest from git
Tree: Mainline
Regression: No


Attachments

Description emailgrant 2013-02-08 06:20:09 UTC
The backlight on my Dell XPS13 ultrabook works if I use this patch:

https://patchwork.kernel.org/patch/2102971/

Whether or not I use the patch, the backlight stops working if I issue 'xset dpms force off'.  Issuing 'echo 0 > /sys/class/backlight/intel_backlight/brightness' makes it work again.
Comment 1 Jani Nikula 2013-04-10 11:42:15 UTC
Hmm, this bug seems to have been neglected for a bit, sorry about that. The patch you refer to has been both committed as:

commit cf0a6584aa6d382f802f2c3cacac23ccbccde0cd
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Wed Feb 6 11:24:41 2013 +0100

    drm/i915: write backlight harder

and since been reverted in 3.9-rc5 due to regressions as:

commit b1289371fcd580b4c412e6d05c4cb8ac8d277239
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Fri Mar 22 15:44:46 2013 +0100

    Revert "drm/i915: write backlight harder"

Please try 3.9-rc5 or later, and describe how the backlight does not work for you. Does the echo you mention fix it? It might prove helpful if you provided dmesg with drm.debug=0xe showing the problems. Thanks.
Comment 2 emailgrant 2013-04-20 06:44:23 UTC
I'm on 3.9-rc7 now and backlight control does not work at all unless I issue 'echo 0 >
/sys/class/backlight/intel_backlight/brightness'.  If I issue 'xset
dpms force off', it breaks again and issuing 'echo 0 >
/sys/class/backlight/intel_backlight/brightness' fixes it again.  Would it still be helpful for me to turn up debugging?
Comment 3 emailgrant 2013-04-20 07:54:24 UTC
Attachment ID 97751 from bug 47941 fixes this bug as well!
Comment 4 Jani Nikula 2013-04-30 06:51:58 UTC
We have added locking and some other fixes in the backlight code. Please try the drm-intel-nightly branch of git://people.freedesktop.org/~danvet/drm-intel to see if that helps your problem.
Comment 5 emailgrant 2013-05-01 03:57:36 UTC
I'm sorry to say that with drm-intel-nightly this bug is not fixed on my Dell XPS 13.
Comment 6 Chris Wilson 2013-07-20 15:02:45 UTC
commit e85843bec6c2ea7c10ec61238396891cc2b753a9
Author: Kamal Mostafa <kamal@canonical.com>
Date:   Fri Jul 19 15:02:01 2013 -0700

    drm/i915: quirk no PCH_PWM_ENABLE for Dell XPS13 backlight
    
    BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=47941
    BugLink: https://bugs.launchpad.net/bugs/1163720
    BugLink: https://bugs.launchpad.net/bugs/1162026
    
    Some machines suffer from non-functional backlight controls if
    BLM_PCH_PWM_ENABLE is set, so provide a quirk to avoid doing so.
    Apply this quirk to Dell XPS 13 models.
    
    Tested-by: Eric Griffith <EGriffith92@gmail.com>
    Tested-by: Kent Baxley <kent.baxley@canonical.com>
    Cc: <stable@vger.kernel.org> # v3.8+
    Signed-off-by: Kamal Mostafa <kamal@canonical.com>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>

Note You need to log in before you can comment on or make changes to this bug.