Bug 5337 - S4 regression: suspend sometimes hangs - Dell Dimension 5100
S4 regression: suspend sometimes hangs - Dell Dimension 5100
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Pavel Machek
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 07:17 UTC by Martin Steigerwald
Modified: 2006-02-01 06:42 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.13.2
Tree: Mainline
Regression: ---


Attachments
configuration for the kernel that showed the bug (55.49 KB, text/plain)
2005-09-30 07:20 UTC, Martin Steigerwald
Details
simple lspci output (1.16 KB, text/plain)
2005-09-30 07:23 UTC, Martin Steigerwald
Details
lspci -n -vv output (7.10 KB, text/plain)
2005-09-30 07:24 UTC, Martin Steigerwald
Details
lshal output (59.72 KB, text/plain)
2005-09-30 07:24 UTC, Martin Steigerwald
Details

Description Martin Steigerwald 2005-09-30 07:17:25 UTC
Most recent kernel where this bug did not occur: none tested after 2.6.13.2  
Distribution: Debian Sarge  
  
Hardware Environment:   
Dell Dimension 5100, P4 2.8 GHz, Intel 945G, ICH7, SATA hardddrive  
ATI Radeon X300 SE (RV 370) PCI express graphic card  
  
Software Environment:   
Debian Sarge with KDE 3.3.2 and X.org backport (6.8.2.dfsg.1-5 from  
www.backports.org), or just gdm or a simple vesa framebuffer console.   
  
Some custom made ACPI shutdown script, but Also tried with  
  
echo platform > /sys/power/disk ; echo disk > /sys/power/state  
  
as well as  
  
echo shutdown > /sys/power/disk ; echo disk > /sys/power/state  
  
I used GRUB bootloader with following configuration:  
title           Debian GNU/Linux, kernel 2.6.13.2-dell-dimension  
root            (hd0,5)  
kernel          /boot/vmlinuz-2.6.13.2-dell-dimension root=/dev/sda6  
resume=/dev/sda5 vga=791 ro  
savedefault  
boot  
  
Problem Description:   
Out of about 10-15 tries with different circumstances (KDE, gdm, X.org with  
"radeon" and with "vesa" driver, framebuffer console without running X server,  
ACPI script, just above command sequences) the system only went into suspend  
correctly once. This was with framebuffer console and the platform command  
sequence - resume worked okay on this one case I could not reproduce 
afterwards. 
  
All the other times it hung after  
  
Writing data to swap (xxxxx pages)  
  
Giving messages like:  
ata1: command 0x35 timeout, stat 0x50, host stat 0x24  
ata1: command 0x35 timeout, stat 0x50, host stat 0x24  
ata1: command 0x25 timeout, stat 0x50, host stat 0x24  
ata1: command 0x25 timeout, stat 0x50, host stat 0x24  
  
It takes about half a minute or minute for each message to appear. It then went  
on with "command 0x25 timeout" message, I waited about 5 minutes or so.  
 
When rebooting the system starts as if didn't suspended, so it doesn't seem 
that the memory image was written to disk. 
  
Steps to reproduce:   
  
1) compile plain vanilla 2.6.13.2 with the config file I will attach  
2) have a similar hardware (see above and attached lshal and lspci outputs for  
details)  
3) boot up Debian Sarge with said kernel (I think any other Linux distribution  
will do)   
4) go into a console (I didn't test without the vga=791 parameter, if you need  
that test, please let me know)  
5) type "echo platform > /sys/power/disk ; echo disk > /sys/power/state" or  
"echo shutdown > /sys/power/disk ; echo disk > /sys/power/state"
Comment 1 Martin Steigerwald 2005-09-30 07:20:04 UTC
Created attachment 6196 [details]
configuration for the kernel that showed the bug
Comment 2 Martin Steigerwald 2005-09-30 07:23:27 UTC
Created attachment 6197 [details]
simple lspci output
Comment 3 Martin Steigerwald 2005-09-30 07:24:07 UTC
Created attachment 6198 [details]
lspci -n -vv output
Comment 4 Martin Steigerwald 2005-09-30 07:24:57 UTC
Created attachment 6199 [details]
lshal output
Comment 5 Pavel Machek 2005-10-07 00:15:09 UTC
Okay, SATA problems, we have seen those before. There are some patches floating
on the list (linux-kernel)... can you try them?
Comment 6 Pavel Machek 2005-10-07 00:16:28 UTC
Oh and you should really try with latest kernel (that means 2.6.14-rc3-something).
Comment 7 Martin Steigerwald 2005-10-07 02:37:56 UTC
Hello, I tried with 2.6.14-rc3. It gives same timeout during suspend. I might 
be able to take some time to look after patches next week. Regards, Martin 
Comment 8 Martin Steigerwald 2005-11-24 06:49:27 UTC
Hello, I now tested with 2.6.14.2. Still doesn't work. Are there any kernel 
patches I should try? Regards, Martin 
Comment 9 Pavel Machek 2005-11-25 11:42:30 UTC
2.6.14.2 is "old" -- its stable branch after all. Could you try 2.6.15-rc2 or
whatever is current "head"?
Comment 10 Pavel Machek 2006-01-18 05:27:31 UTC
Please try again with 2.6.16-rc1, some sata patches were merged. Reopen if it is
still there.
Comment 11 Martin Steigerwald 2006-02-01 06:42:44 UTC
Hello, thanks, it works with 2.6.16-rc1. Regards, Martin   

Note You need to log in before you can comment on or make changes to this bug.