Bug 5331 - Can't boot SMP kernel >=2.6.13
Can't boot SMP kernel >=2.6.13
Status: REJECTED INSUFFICIENT_DATA
Product: ACPI
Classification: Unclassified
Component: Config-Processors
i386 Linux
: P2 blocking
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 11:00 UTC by George Billios
Modified: 2006-09-06 09:01 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.13 and later
Tree: Mainline
Regression: ---


Attachments
Dmesg of 2.6.12.1 kernel (16.35 KB, text/plain)
2005-09-29 11:02 UTC, George Billios
Details

Description George Billios 2005-09-29 11:00:06 UTC
Most recent kernel where this bug did not occur: 2.6.12.1 (haven't tried any
other from 2.6.12 series)
Distribution: Fedora Core 4
Hardware Environment: P4 3.06GHz HT revision 09
Software Environment:
Problem Description: If I boot an SMP version of >=2.6.13 kernel, depending on
the boot options it either hangs or boots up to a certain point very very slowly.

Steps to reproduce: 
1. Build an SMP vanilla kernel >=2.6.13 
2. Boot it


I have also posted here http://bugzilla.kernel.org/show_bug.cgi?id=5171 but it
seems to be another bug.

-If I boot the kernel with the noapic option as I do with the 2.6.12.1 kernel,
it hangs hard at:
'isapnp:Scanning for PnP cards...'
-If I boot the kernel with no option, it boot very very slowly up to 'Starting
udev...' where it just stays (waited at least 10 minutes) until I press CTRL+C
and then continues still very slowly but everything fails because the root
device is mounted read-only up to a point where it stops but doesn't hang.
Comment 1 George Billios 2005-09-29 11:02:03 UTC
Created attachment 6188 [details]
Dmesg of 2.6.12.1 kernel

This is the dmesg of the working kernel. Unfortunately I can't post the dmesg
of the non-working kernel but while booting I don't see any oops or another
error.
Comment 2 Len Brown 2005-10-06 21:55:30 UTC
please test the patch in bug 5165

if that doesn't work, does booting with "idle=poll" help,
or how about disabling acpi/processor.ko altogether?
Comment 3 George Billios 2005-10-07 05:29:23 UTC
The patch in the other bug didn't work (kernel 2.6.13.3) but the idle=poll
option worked!
Unfortunately I had another problem with some irq (?) but that was sorted out
with irqpoll boot option. I don't know if this was related to the first option I
added.
Comment 4 George Billios 2005-10-08 01:14:11 UTC
Just to note here that after using idle=poll my cpu is heating more which I
guess is because it doesn't go into a lower state. 
Hope you guys fix this bug quickly. Cheers
Comment 5 Venkatesh Pallipadi 2005-10-08 07:25:44 UTC
When does the slowness start?

Is it from the beginning of the boot or it goes at normal speed until some point
and then starts to slow down?
Does "processor.max_cstate=1" boot parameter help?
Comment 6 George Billios 2005-10-09 03:10:40 UTC
The "processor.max_cstate=1" option works fine and doesn't cause the cpu to
overheat. 
The slowness seems to start from the beginning. 
Comment 7 Len Brown 2006-08-10 01:59:35 UTC
> If I boot the kernel with the noapic option as I do with the 2.6.12.1

Why were you using "noapic" on 2.6.12?

Does the system work properly if booted with just "maxcpus=1"?

Comment 8 Adrian Bunk 2006-09-06 09:01:19 UTC
Please reopen the bug if you can provide the requested information.

Note You need to log in before you can comment on or make changes to this bug.