Bug 5319 - Overlapping mtrr regions
Overlapping mtrr regions
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
i386 Linux
: P2 normal
Assigned To: platform_i386
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 11:44 UTC by Erik Andr
Modified: 2007-09-09 08:45 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.15-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Erik Andr 2005-09-27 11:44:01 UTC
Most recent kernel where this bug did not occur: 2.6.13
Distribution: Slackware-current
Hardware Environment: Dell c640, Pentium4m 2 GHz, 512 MB DDR
Problem Description: I frequently get the following messages when checking the
kernel log:

mtrr: 0xe0000000,0x8000000 overlaps existing 0xe0000000,0x2000000
mtrr: 0xe0000000,0x8000000 overlaps existing 0xe0000000,0x2000000
mtrr: 0xe0000000,0x8000000 overlaps existing 0xe0000000,0x2000000

I don't know if it makes any performance difference or not though. 

Steps to reproduce: Just boot the kernel.
Comment 1 Tiernan Hubble 2005-09-30 14:25:37 UTC
I believe this is related to a problem I'm having with the nvidia drivers and
the 2.6.14-rc2-mm series. (Tried both 2.6.14-rc2-mm1 and mm2).

Here are the relevant lines from dmesg:
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-7676  Fri Jul 29
12:58:54 PDT 2005
NVRM: PAT index 2 already configured for Write-Combining!
NVRM: Aborting, due to PAT already being configured

And /proc/mtrr:
reg00: base=0x00000000 (   0MB), size=1024MB: write-back, count=1
reg02: base=0xe0000000 (3584MB), size= 128MB: write-combining, count=1

By contrast, here's the /proc/mtrr from 2.6.14-rc1-mm1, which works fine:
reg00: base=0x00000000 (   0MB), size=984064MB: write-back, count=1

Strangely enough, the -rc2 version looks to be the correct one, but doesn't work
(X fails to initialize).

Gentoo, Pentium 4 2.8Ghz, 1024MB DDR, SMT enabled.

If this problem seems to be unrelated to this bug, let me know and I'll open a
separate one.
Comment 2 Erik Andr 2005-10-10 23:44:41 UTC
They are problably unrelated as I don't have any nvidiahardware in my machine.
Comment 3 Sebastian Kemper 2005-10-28 11:11:55 UTC
Hi!  
  
I got the same issue now. I updated from 2.6.13.4 to 2.6.14 this morning.  
  
I have a radeon 9250 and use the opensource xorg/kernel driver combination.  
  
Oct 28 09:46:12 section_eight mtrr: 0xd0000000,0x10000000 overlaps existing  
0xd0000000,0x8000000  
Oct 28 09:46:12 section_eight mtrr: 0xd0000000,0x10000000 overlaps existing  
0xd0000000,0x8000000  
Oct 28 09:46:12 section_eight mtrr: 0xd0000000,0x10000000 overlaps existing  
0xd0000000,0x8000000  
Oct 28 09:46:12 section_eight agpgart: Found an AGP 3.0 compliant device at  
0000:00:00.0.  
Oct 28 09:46:12 section_eight agpgart: reserved bits set in mode 0x1f00420f.  
Fixed.  
Oct 28 09:46:12 section_eight agpgart: X tried to set rate=x12. Setting to AGP3  
x8 mode.  
  
  
This is on a nforce2 shuttle an35n mobo with a sempron socket 462 (A) 2400+. 
 
Cheers 
 
Sebastian 
Comment 4 Sebastian Kemper 2005-10-28 11:14:06 UTC
/proc/mtrr: 
 
reg00: base=0x00000000 (   0MB), size= 512MB: write-back, count=1 
reg01: base=0xe0000000 (3584MB), size=  32MB: write-combining, count=2 
reg02: base=0xd0000000 (3328MB), size= 128MB: write-combining, count=2 
 
The 128MB is the cards RAM, the 32MB is the Aperture Size in my BIOS and the 
512MB is presumably my main RAM. 
Comment 5 Daniel Drake 2005-11-25 03:28:22 UTC
Downstream bug report:
http://bugs.gentoo.org/112238
Comment 6 Erik Andr 2005-12-19 04:51:20 UTC
Trying out 2.6.14.3 resolved this issue for me. 
Should the bug be closed or are others still affected?
Comment 7 Daniel Drake 2005-12-19 09:54:11 UTC
In the Gentoo bug, Sebastian reproduced the problem on 2.6.15-rc2
Comment 8 Erik Andr 2005-12-19 12:55:14 UTC
Strike my last comment. I only get this error with post 6.8.2 of the X.org server. 
Comment 9 Erik Andr 2006-10-14 22:53:51 UTC
Nowadays I'm using Ubuntu Edgy with Xorg 7.1.1 on the same machine, still
experiencing the same bug. 
Comment 10 Daniel Drake 2007-04-30 06:45:12 UTC
Sebastian's issue is solved on newer kernels (2.6.20 is fixed).
Comment 11 Erik Andr 2007-09-09 08:45:09 UTC
This is not an issue any more using Ubuntu Gutsy (2.6.22)

Note You need to log in before you can comment on or make changes to this bug.