Bug 53161 - inotify support for NFS
inotify support for NFS
Status: CLOSED WILL_NOT_FIX
Product: File System
Classification: Unclassified
Component: NFS
All Linux
: P1 enhancement
Assigned To: Trond Myklebust
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 05:33 UTC by hrjet
Modified: 2013-01-29 17:36 UTC (History)
0 users

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description hrjet 2013-01-29 05:33:22 UTC
This is a feature request. I am not a kernel hacker, so my description might not be very accurate.

"Please support inotify on NFS."

From what I understand, NFS server can't advertise file system changes to client, but the client can eventually discover when files are changed.

Can this information be eventually transmitted to inotify clients? 

My use-case:

I have a virtual box which mounts a filesystem from the host via NFS. The virtual box is running a continuous compilation job which needs to get triggered whenever a file on the NFS filesystem is modified.

For my use-case, deferred notification is better than polling, because the virtual box takes up a lot of CPU resources when polling.
Comment 1 Trond Myklebust 2013-01-29 17:18:08 UTC
No...
Comment 2 Trond Myklebust 2013-01-29 17:36:00 UTC
Firstly, feature requests should go the linux-nfs mailing list, not bugzilla.

Secondly, this issue has been discussed to death on said mailing list
and others already. inotify doesn't scale, and particularly not over a
network.

Thirdly, there are already utilities such as gamin and FAM that implement
inotify-like functionality as a sideband protocol for the purposes of the
most common applications.

Note You need to log in before you can comment on or make changes to this bug.