Bug 5308 - Extremely slow UMS write speed under >=2.6.12 kernels on Compaq nx8220 laptop
Extremely slow UMS write speed under >=2.6.12 kernels on Compaq nx8220 laptop
Status: REJECTED DUPLICATE of bug 5258
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-09-25 03:44 UTC by Pavel Alexeev
Modified: 2005-09-26 02:19 UTC (History)
0 users

See Also:
Kernel Version: 2.6.12.6, 2.6.14-rc2-git3
Tree: Mainline
Regression: ---


Attachments
My kernel .config for 2.6.12.6 (37.99 KB, text/plain)
2005-09-25 03:46 UTC, Pavel Alexeev
Details
/var/log/debug file, 2.6.12.6 (6.16 KB, application/octet-stream)
2005-09-25 03:49 UTC, Pavel Alexeev
Details
dmesg output, 2.6.12.6 (15.00 KB, text/plain)
2005-09-25 03:50 UTC, Pavel Alexeev
Details

Description Pavel Alexeev 2005-09-25 03:44:56 UTC
Most recent kernel where this bug did not occur: 2.6.8.1 (not sure: 2.6.9..2.6.11)

Distribution: Slackware 10.2, but i configure and build the kernel with my options

Hardware Environment: Notebook Compaq nx8220 (model )

Software Environment: Slackware 10.2, with my kernel, without third-party patches

Problem Description: Very slow (ca. 50 kbytes/s writing speed when copying files
to my USB Flash) under 2.6.12.6 (and under 2.6.14-rc2-git3). The read speed is
about 8 Mbytes/s. Under 2.6.8.1 is the writing speed ca. 3 Mbytes/s.
The kernels > 2.6.12.6 run unstable on my laptop (see
http://bugzilla.kernel.org/show_bug.cgi?id=5221 ) => i attach here the
2.6.12.6-related logs and config.
I use ehci and uhci modules. With uhci (without ehci) the writing speed is about
25 kbytes/s.
The related line in my fstab:
/dev/sda1        /mnt/flash       vfat        rw,noauto,sync,nosuid,user,noatime
,umask=0,uid=99,gid=99 0 0

Steps to reproduce:
1) Insert usb flash drive under kernel >= 2.6.12.
2) Mount it.
3) Try to copy a large file onto it.
Comment 1 Pavel Alexeev 2005-09-25 03:46:51 UTC
Created attachment 6136 [details]
My kernel .config for 2.6.12.6

The .configs for 2.6.8.1 and 2.6.14-rc2-git3 are based on this config.
Comment 2 Pavel Alexeev 2005-09-25 03:49:49 UTC
Created attachment 6137 [details]
/var/log/debug file, 2.6.12.6

How is it created:
1) Delete an old file
2) Restart system
3) Insert USB Flash
4) Mount it
5) Copy a 45 kb large file on it in mc
6) Unmount it
7) Remove it
Comment 3 Pavel Alexeev 2005-09-25 03:50:53 UTC
Created attachment 6138 [details]
dmesg output, 2.6.12.6
Comment 4 Pavel Alexeev 2005-09-25 04:22:12 UTC
Just compiled the kernel 2.6.11.12. The USB writing speed is OK (about 3 MBytes/s).
Comment 5 Pavel Alexeev 2005-09-25 04:47:09 UTC
Just detected: the writing speed is OK under 2.6.12.6 if no "sync" option in
fstab used for USB flash.
Comment 6 Diego Calleja 2005-09-25 04:54:57 UTC
This is a know problem. The problem is that until now, FAT had NEVER cared about
"sync", ie: it didn't work as "sync" even if you passed that option

However, this has been fixed, so when you use sync it really means "sync", so it
gets much slower. You can remove the "sync" option to get more speed
Comment 7 Pavel Alexeev 2005-09-25 05:57:48 UTC
OK, thank you. I will not use "sync" for FAT-volumes more.
Comment 8 Greg Kroah-Hartman 2005-09-26 02:19:50 UTC

*** This bug has been marked as a duplicate of 5258 ***

Note You need to log in before you can comment on or make changes to this bug.