Bug 5276 - USB hub doesn't power down
USB hub doesn't power down
Status: REJECTED INVALID
Product: ACPI
Classification: Unclassified
Component: Power-Off
i386 Linux
: P2 normal
Assigned To: Len Brown
:
: 6701 (view as bug list)
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-09-18 13:51 UTC by Jan Outhuis
Modified: 2006-06-20 17:52 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.13
Tree: Mainline
Regression: ---


Attachments
output of cat /proc/acpi/wakup (226 bytes, text/plain)
2005-10-16 04:17 UTC, Jan Outhuis
Details
output of lsusb -v with hub plugged in (18.75 KB, text/plain)
2005-12-15 06:08 UTC, Jan Outhuis
Details

Description Jan Outhuis 2005-09-18 13:51:14 UTC
Most recent kernel where this bug did not occur:2.6.11.5
Distribution:debian testing
Hardware Environment:intel p4
Software Environment:libc 2.3.5, kernel 2.6.13
Problem Description:after stepping up to kernel 2.6.13 the system won't power
down  my USB-hub connection points anymore at shutting down the pc (the little
green lights keep burning).

Steps to reproduce:
Comment 1 Alan Stern 2005-09-29 09:14:13 UTC
This doesn't sound like a USB problem at all.  More like a problem with the code
responsible for shutting down the computer.  It should turn off all the power,
not leave some power available for USB.

Do the lights on the hub go out if you unplug everything from the wall socket?
Comment 2 Jan Outhuis 2005-10-01 09:31:05 UTC
Well, some strange things happen. I have 5 LED's on my hub: 4 green and one red.
It so appears that my hub can do without it's separate power supply; once I plug
off this power the red LED is out and stays out.

In this new situation the green one's still keep burning after shutdown, but
once I plug off the main power supply of the computer, after a few seconds they
fade away. At replugging mains they start burning again. When I unplug the main
USB signal cable from the hub however (i.e after shutdown), the lights go out
and stay out at replugging the signal cable.

Comment 3 Peter Ganzhorn 2005-10-03 12:52:30 UTC
Similar problem here:

Kernel 2.6.13.2 on AMD Athlon XP-M

My optical mouse stays powered on after shutting the computer down with
"shutdown -h now", but stays powered on after re-plugging it while computer is
turned off.
Replugging the main power supply makes my USB power down.

Everything worked perfectly on 2.6.12.X.

And it seems I am not alone:
http://www.linuxquestions.org/questions/showthread.php?threadid=365652

I am pretty sure the problem is located somewhere in the kernel...
Comment 4 Alan Stern 2005-10-03 13:03:30 UTC
I'm adding the ACPI mailing list to this bug, because it appears that this
really is a problem with ACPI and has nothing to do with USB.
Comment 5 David Brownell 2005-10-05 13:41:46 UTC
It'll also be interesting to see how the 2.6.15.early patches 
behave here; there have been a bunch of USB (and other) PM updates. 
The latest MM patches should have them all too. 
 
 
Comment 6 David Brownell 2005-10-05 14:12:01 UTC
whoops, 2.6.14-rc2-mm2 does not have the patches; 
http://www.kernel.org/pub/linux/kernel/people/gregkh/gregkh-2.6/gregkh-04-usb/ 
does though 
 
Comment 7 Len Brown 2005-10-13 11:48:48 UTC
does this problem go away when booted with "acpi=off",

if no, please # cat /proc/acpi/wakeup
and if there are any devices that are "enabled",
echo their names into that file to make them "disabled"
and see if that makes a different.  Note that strings
that appear to identify USB devices may or may not be
on the list.  Note also that there may be dependencies
between the entries such that changing one changes
others, and some you may not be able to change.


Comment 8 Jan Outhuis 2005-10-16 04:17:24 UTC
Created attachment 6310 [details]
output of cat /proc/acpi/wakup
Comment 9 Jan Outhuis 2005-10-16 04:19:09 UTC
I have to correct my latest input on this bug: the green LED's on the hub also
stay out after replugging mains.

Further, I have tested with acpi=off; doesn't make any difference.

For your information I attach /proc/acpi/wakup.
Comment 10 Alexey Starikovskiy 2005-11-25 05:32:16 UTC
If there is no difference for both ACPI and no-ACPI cases, then this problem is
not an ACPI issue... 
Comment 11 Peter Ganzhorn 2005-12-11 12:16:47 UTC
Any solutions yet???
Comment 12 Alan Stern 2005-12-12 07:13:00 UTC
Maybe this has to do with whether or not the USB controller driver turns off the
USB ports during shutdown.  Can you please post the output from "lsusb -v"?
Comment 13 Jan Outhuis 2005-12-15 06:08:51 UTC
Created attachment 6832 [details]
output of lsusb -v with hub plugged in
Comment 14 Jan Outhuis 2005-12-15 06:10:30 UTC
After getting messages from my USB subsystem about a 'slow connection' and
'cables that might be too old', referencing to my USB2.0 scanner that was
plugged in via the hub, I removed the hub and plugged my USB-devices directly
into the sockets of my pc.

That of course solved my problem with the powering down of the hub. I guess the
thing simply was too old and slow to react properly to the powerdown process.

For completeness I attach the requested 'lsusb -v'
Comment 15 Alan Stern 2005-12-16 12:38:36 UTC
Peter or Jan:

Do you see the same problem occur if you do "rmmod ehci-hcd" before shutting
down?  What if you do "rmmod uhci-hcd" also?

If you do, try this experiment.  Go into the directory

  /lib/modules/<kernel-version>/kernel/drivers/usb/host

and rename uhci-hcd.ko, ohci-hcd.ko, and ehci-hcd.ko to something else (like
uhci-hcd.ko-save, etc.).  Then reboot.  You won't be able to use any of your USB
devices because the system won't be able to locate and load those modules.  But
then when you shut down, does the USB power still remain on?

If it does, it proves that the USB drivers don't cause the problem, because they
never got loaded.  (Don't forget to set those files back to their original names
when you want to start using your USB devices again!)
Comment 16 Jan Outhuis 2005-12-18 04:08:59 UTC
Did some testing with the *-hcd modules as you suggested. This didn't make any
difference for the hub at shutting down: the lights kept burning.

But then again, I have 6 USB sockets on my pc, 4 at the back and 2 up front.
When I plug in the hub at the front, it does get powered off like it should, no
matter the state of the USB-modules.
Comment 17 Alan Stern 2005-12-18 07:55:56 UTC
Well, that pretty much proves this isn't caused by anything in the USB drivers.

In fact, it might not be caused by Linux at all.  Try this: When you turn on the
computer, stop the boot-up process at the LILO or Grub menu, and then turn the
computer off without loading the OS at all.

Of course, that means using the power button.  It's quite possible that the
power-off sequence used by Linux is different from the sequence used when you
hit the power button.  This might be related to APM (rather than ACPI).
Comment 18 Jan Outhuis 2005-12-19 06:16:00 UTC
Did the experiment with the power button too. Got the same result: hub powers
down when plugged into the front socket, but stays alive when plugged into the
back socket.

Guess I'll have to start shuffling some jumpers on my main board...
Comment 19 Alan Stern 2005-12-19 06:33:09 UTC
You can go ahead and mark this bug report Rejected, since it clearly isn't a
problem in Linux.
Comment 20 Valentin Zagura 2006-03-24 02:23:29 UTC
I am experiencing kind of the same problem. I have a device (iMon VFD) that is
supposed to
power on my computer by remote. However it fails to do this if it does not
detect that the computer is in off state (by monitoring USB).
I have the following cases:
1) I switch the PSU OFF then ON, the USB is OFF (power on by remote works)
2) I boot Windows XP, then shut it down, USB is OFF (power on by remote works)
3) I boot an older Knoppix Live CD (Kernel 2.4) then I issue poweroff command,
USB is OFF (power on by remote works)
4) I boot Gentoo (2.6.15-r7) then I issue poweroff command, USB remains ON
(power on by remote does not work)
Using ACPI=off and modprobe apm power-off will not make any difference.

When I get into this state, only booting and shuting down Windows XP or Knoppix
(kernel 2.4) will shut down USB. Even If I do softoff by using the case button,
will leave USB on.

I have Asus A7N8X motherboard with the latest bios update (1010).

Regarding comments #15, #16, are you sure that the usb modules will not load
before mounting the root partition, from initrd image?

If you need additional details or tests that I should make I am happy to help. I
just want this thing to work :D
Comment 21 Alan Stern 2006-03-24 07:54:05 UTC
It's true that the USB drivers could be loaded by an initrd image.  Of course,
you can always check to see if they are present in the running kernel.

There's nothing in the USB stack that turns power on or off to the USB
controllers when the system starts up or shuts down.  If it's controlled by
software at all, then it must be somewhere else in the system.  Possibly the PCI
core.
Comment 22 Stefan Brandner 2006-05-11 04:41:13 UTC
I can duplicate everything Valentin Zagura wrote.
In my opinion it is not a ACPI problem. I did check the
dtst settings as descibed at
http://forums.gentoo.org/viewtopic.php?t=122145

I wonder if the problem appears on motherboards with
nVIDIA NFORCE4 chipset only.

It seems the problem showed up with kernel 2.6.13.
Does it make sense to analyse the changes from 2.6.12?
Comment 23 Jan Falkowski 2006-06-20 14:05:20 UTC
nForce2 motherboard here. Same problem, on 2.6.12 everything works well, since
2.6.13 - the LED on my 4-in-1 flash card reader shines after shutdown...
Comment 24 Greg Kroah-Hartman 2006-06-20 17:52:56 UTC
*** Bug 6701 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.