Bug 5250 - Cannot find USB devices on 2.6.13.1, on ICH4m chipset
Cannot find USB devices on 2.6.13.1, on ICH4m chipset
Status: REJECTED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: PCI
i386 Linux
: P2 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-09-14 07:13 UTC by Sam Freed
Modified: 2005-10-05 10:34 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.13.1
Tree: Mainline
Regression: ---


Attachments
The .config file (45.72 KB, text/plain)
2005-09-14 07:15 UTC, Sam Freed
Details
the dmesg output (27.07 KB, text/plain)
2005-09-14 07:16 UTC, Sam Freed
Details
lspci -v (5.46 KB, text/plain)
2005-09-14 07:16 UTC, Sam Freed
Details
lspci (1.57 KB, text/plain)
2005-09-14 07:17 UTC, Sam Freed
Details
2.6.11.5 messsages (115.98 KB, text/plain)
2005-09-14 13:49 UTC, Sam Freed
Details
2.6.11.5 lspci -v (5.10 KB, text/plain)
2005-09-14 13:51 UTC, Sam Freed
Details

Description Sam Freed 2005-09-14 07:13:52 UTC
Most recent kernel where this bug did not occur: 2.6.11.5
Distribution: Debian unstable
Hardware Environment: Toshiba R100 laptop, see
http://www.freed.net/opensource/R100.html
Software Environment: Vanilla 2.6.13.1 from kernel.org
Problem Description:
Geting the message "ehci_hcd 0000:00:1d.7: Unlink after no-IRQ?  Controller is
probably using the wrong IRQ" when trying to get at USB, following some bad PCI
stuff above, see dmesg.

Steps to reproduce:
Boot the machine into 2.6.13.1
Comment 1 Sam Freed 2005-09-14 07:15:19 UTC
Created attachment 6013 [details]
The .config file
Comment 2 Sam Freed 2005-09-14 07:16:20 UTC
Created attachment 6014 [details]
the dmesg output
Comment 3 Sam Freed 2005-09-14 07:16:56 UTC
Created attachment 6015 [details]
lspci -v
Comment 4 Sam Freed 2005-09-14 07:17:28 UTC
Created attachment 6016 [details]
lspci
Comment 5 David Brownell 2005-09-14 12:05:04 UTC
Please report whether (and how!) the IRQ assignments are different
between 2.6.11.5 and 2.6.13.1 ... if they're different (like EHCI
not being on irq11) that suggests the issue is ACPI IRQ setup again.

Also, that "UHCI irq happens too early" thing seems likely to be
related to BIOS issues.  Try the "usb-handoff" kernel command line
parameter, and disabling USB keyboard/mouse support in the BIOS.
Comment 6 Sam Freed 2005-09-14 13:49:16 UTC
Created attachment 6025 [details]
2.6.11.5 messsages
Comment 7 Sam Freed 2005-09-14 13:51:10 UTC
This is my first Kernel Bug, so bear with me --- I am attachning the
/var/log/messages and lspci -v from the 2.6.11.5. I will try later to boot with
the option you mentioned. and dig into the BIOS to play with the USB keyboard
stuff. 
Comment 8 Sam Freed 2005-09-14 13:51:58 UTC
Created attachment 6026 [details]
2.6.11.5 lspci -v
Comment 9 Sam Freed 2005-09-15 05:15:37 UTC
"usb-handoff" worked. Oddly, it did not work as an "append=" in lilo.conf. I
suppose now it becomes a doc issue.
Comment 10 Greg Kroah-Hartman 2005-10-05 10:34:43 UTC
Ok, closing then.

Note You need to log in before you can comment on or make changes to this bug.