Bug 5221 - Regression: 2.6.13 boot hang unless acpi=noirq -- 2.6.12.6 worked - Compaq nx8220
Regression: 2.6.13 boot hang unless acpi=noirq -- 2.6.12.6 worked - Compaq n...
Status: REJECTED INVALID
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 normal
Assigned To: Len Brown
:
: 5216 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-10 16:18 UTC by Pavel Alexeev
Modified: 2006-09-02 21:57 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.13.1, 2.6.14-rc1
Tree: Mainline
Regression: ---


Attachments
acpidump, 2.6.12.6 (152.05 KB, text/plain)
2005-09-23 11:46 UTC, Pavel Alexeev
Details
dmesg -s64000 output, 2.6.12.6 (14.56 KB, text/plain)
2005-09-23 11:47 UTC, Pavel Alexeev
Details
dmesg -s64000 output, 2.6.14-rc2-git3 (15.00 KB, text/plain)
2005-09-23 11:47 UTC, Pavel Alexeev
Details
lspci -vv output, 2.6.12.6 (14.24 KB, text/plain)
2005-09-23 11:47 UTC, Pavel Alexeev
Details
lspci -vv output, 2.6.14-rc2-git3 (14.19 KB, text/plain)
2005-09-23 11:48 UTC, Pavel Alexeev
Details
/proc/interrupts, 2.6.12.6 (512 bytes, text/plain)
2005-09-23 11:48 UTC, Pavel Alexeev
Details
/proc/interrupts, 2.6.14-rc2-git3 (473 bytes, text/plain)
2005-09-23 11:49 UTC, Pavel Alexeev
Details
dmesg through serial console of failed boot (3.91 KB, text/plain)
2005-09-29 18:47 UTC, rudolph
Details
dmesg on 2.6.14-rc4 (15.05 KB, text/plain)
2005-10-11 04:11 UTC, Pavel Alexeev
Details
copy of DMESG file (38.56 KB, text/plain)
2006-04-06 02:17 UTC, Paul
Details
lspci.txt from same machine (1.48 KB, text/plain)
2006-04-06 07:23 UTC, Paul
Details

Description Pavel Alexeev 2005-09-10 16:18:39 UTC
Most recent kernel where this bug did not occur: 2.6.13.1
Distribution: Slackware 10.1, but i configure and build the kernel with my options
Hardware Environment: Notebook Compaq nx8220 (model )
Software Environment: Slackware 10.1, with my kernel, without third-party patches
Problem Description: The kernels cannot boot and hangs with following text on
the screen (no entries in the logs):
...
ACPI: Subsystem Revision: 20050408
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI root bridge [C003] (0000:00)
PCI: Probing PCI Hardware (bus 00)
ACPI: Assume root bridge [\_SB_.C003] segment is 0
ACPI: Assume root bridge [\_SB_.C003] bus is 0
PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f:1
PCI: Transparent bridge - 0000:00:1e.0
ACPI: Power Resource [C1C8] (on)
ACPI: Embedded Controller [C005] (gpe 16)
ACPI: Power Resource [C1AA] (on)
ACPI: Power Resource [C1B1] (on)
ACPI: Power Resource [C1C1] (on)
ACPI: PCI interrupt Link [C0D9] (IRQs *10 11)
ACPI: PCI interrupt Link [C0DA] (IRQs 10 *11)
ACPI: PCI interrupt Link [C0DB] (IRQs 10 *11)
ACPI: PCI interrupt Link [C0DC] (IRQs *10 11)
ACPI: PCI interrupt Link [C0EF] (IRQs *10 11)
ACPI: PCI interrupt Link [C0F0] (IRQs 10 *11)
ACPI: PCI interrupt Link [C0F1] (IRQs *10 11)
ACPI: Power Resource [C25A] off
ACPI: Power Resource [C25B] off
ACPI: Power Resource [C25C] off
ACPI: Power Resource [C25D] off
Linux Plug and Play Support v0.97 (c) Adam Belay
SCSI System Initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
PCI: If a device does not work, try "pci=routeirq". If it helps, post a report
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1

The kernel 2.6.12.6 with the same .config works. ACPI enabled.
I have tried "pci=routeirq", but it does not help. The same message "Cannot
allocate". Some messages on the top of screen seem to be different in this case.

Steps to reproduce: Just compile and try to boot :)
Comment 1 Pavel Alexeev 2005-09-10 16:21:18 UTC
Notebook: nx 8220, model PY518ET.
Comment 2 Pavel Alexeev 2005-09-10 16:45:02 UTC
The kernel 2.6.13.1 boots successfully if ACPI is not compiled in.
Comment 3 Len Brown 2005-09-14 19:23:02 UTC
if you boot the CONFIG_ACPI=y kernel with "acpi=off" then it works?
if yes, how about with just "pci=noacpi"?
if yes, how about with just "acpi=noirq"?

how about with "pnpacpi=off"?

When you build the 2.6.13 kernel, you first run "make oldconfig" on the 
working 2.6.12 .config?
Comment 4 Pavel Alexeev 2005-09-15 03:27:00 UTC
> if you boot the CONFIG_ACPI=y kernel with "acpi=off" then it works?

Yes, it works

> if yes, how about with just "pci=noacpi"?

Yes, it works (but hangs while rebooting:
Remounting rootfilesystem read-only.
Rebooting.
Restarting system.
.
)

> if yes, how about with just "acpi=noirq"?

Yes, it works, but hangs while rebooting.

> how about with "pnpacpi=off"?

It hangs.

> When you build the 2.6.13 kernel, you first run "make oldconfig" on the
working 2.6.12 .config?

make oldconfig on the working 2.6.12 ".config".

P.S. I can attach dmesg output and my .config, when you need it (which kernel
with which option?).
Comment 5 Pavel Alexeev 2005-09-15 12:14:04 UTC
The same problem on 2.6.14-rc1-git1 (14.09.2005, 09:01:00)
Comment 6 Len Brown 2005-09-21 23:25:40 UTC
please attach the dmesg -s64000 output from 2.6.12.working,
along with the /proc/interrupts and the output from lspci -vv

Please attach the output from acpidump, available in pmtools here:
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/

Please attach the dmesg and /proc/interrupts resulting from
the latest kernel with the "acpi=noirq" cmdline workaround.

Any chance you can also capture the "debug" console output
from the failing 2.6.>12 boot, say with a serial console?
Comment 7 Pavel Alexeev 2005-09-23 11:46:20 UTC
Created attachment 6116 [details]
acpidump, 2.6.12.6
Comment 8 Pavel Alexeev 2005-09-23 11:47:05 UTC
Created attachment 6117 [details]
dmesg -s64000 output, 2.6.12.6
Comment 9 Pavel Alexeev 2005-09-23 11:47:29 UTC
Created attachment 6118 [details]
dmesg -s64000 output, 2.6.14-rc2-git3
Comment 10 Pavel Alexeev 2005-09-23 11:47:57 UTC
Created attachment 6119 [details]
lspci -vv output, 2.6.12.6
Comment 11 Pavel Alexeev 2005-09-23 11:48:18 UTC
Created attachment 6120 [details]
lspci -vv output, 2.6.14-rc2-git3
Comment 12 Pavel Alexeev 2005-09-23 11:48:57 UTC
Created attachment 6121 [details]
/proc/interrupts, 2.6.12.6
Comment 13 Pavel Alexeev 2005-09-23 11:49:42 UTC
Created attachment 6122 [details]
/proc/interrupts, 2.6.14-rc2-git3
Comment 14 Pavel Alexeev 2005-09-23 11:51:38 UTC
> Any chance you can also capture the "debug" console output
from the failing 2.6.>12 boot, say with a serial console?

mmm... At first, i must learn what it is and how i can do it :) Where can i 
read it? :)
Comment 15 Pavel Alexeev 2005-09-24 02:40:48 UTC
This notebook does not have any COM-ports.
Comment 16 Shaohua 2005-09-28 19:46:40 UTC
*** Bug 5216 has been marked as a duplicate of this bug. ***
Comment 17 rudolph 2005-09-29 17:42:28 UTC
I am also having the same problem described, on similar hardware. In my case,
the laptop is an nc6220 which does have a serial port. What diagnostics can I
provide?
Comment 18 Shaohua 2005-09-29 18:07:48 UTC
Could you please capature the dmesg though the serial port in the failure 
case? This will help us compare the dmesg unser working/unworking cases, so we 
can find clues. You can find the document about how to use serial console at 
kernel source/Documentation/serial-console.txt
Comment 19 rudolph 2005-09-29 18:47:30 UTC
Created attachment 6192 [details]
dmesg through serial console of failed boot

As requested, serial console output of 2.6.14-rc2-git6 on nc6220 that fails to
boot with acpi turned on
Comment 20 Shaohua 2005-09-29 19:25:41 UTC
This is really quick! Does the system work with lapic with acpi=on?
Comment 21 Shaohua 2005-09-29 19:27:15 UTC
Oops, I mean does the system work with noapic but with acpi=on?
Comment 22 rudolph 2005-09-29 19:49:32 UTC
booting with noapic made no difference, boot failed in exactly the same place.

I've also noticed that I have the kacpid 100% CPU problem when booting with
options that do result in a successful boot, that is

acpi=off -> ok
pci=noacpi -> 100% kacpid
acpi=noirq -> 100% kacpid

on the above kernel.
Comment 23 rudolph 2005-10-02 15:52:32 UTC
I've realised that my previous observations about kacpid are not properly a
regression - they occur with 2.6.12 as well, so don't really belong in this bug
report (more likely, they belong in something like #3686). Sorry.
Comment 24 Pavel Alexeev 2005-10-03 04:37:17 UTC
I don't have this kacpid-related problem (100% CPU usage) on my nx8220, under
neither 2.6.12.6 nor 2.6.14-rc3-git3.
Comment 25 Shaohua 2005-10-10 18:39:51 UTC
Does the patch at https://bugzilla.novell.com/show_bug.cgi?id=116763
work?
Comment 26 Pavel Alexeev 2005-10-11 02:14:36 UTC
Yes, this patch works for me. The kernel 2.6.14-rc4 boots successfully (but
hangs when rebooting).
Comment 27 Pavel Alexeev 2005-10-11 04:11:58 UTC
Created attachment 6277 [details]
dmesg on 2.6.14-rc4

dmesg on 2.6.14-rc4
Comment 28 rudolph 2005-10-11 17:32:48 UTC
patch also works for me. I am also seeing the same issue with reboots (i.e, the
system displays "restarting system" and then hangs) as Pavel.
Comment 29 rudolph 2005-10-12 20:37:35 UTC
looks like the reboot issue is logged as a separate bug, 5396.
Comment 30 Markus schaber 2005-10-13 01:56:26 UTC
For me the same. 2.6.14-rc4 with patch applied boots fine on my HP Compaq nx 
8220. (I did not try 2.6.14-rc4 without the patch yet.)

The reboot problems on my machine are "sometimes", and also with 2.6.12.6.

Markus
Comment 31 Pavel Alexeev 2005-10-13 02:18:41 UTC
I have never any reboot-related problems with 2.6.12.6. This is the kernel i use
every day since at least 03.09.05. The full model number of my laptop is: Compaq
nx8220 PY518ET#ABD, BIOS: 68DTV Ver. F.0A, 04/28/2005
Comment 32 Markus schaber 2005-10-24 10:14:50 UTC
So, how do we get this patch into the official kernels now?

As I can see from the 2.6.14-rc5 changelog, it is not included yet.
Comment 33 Christian Kalkhoff 2005-10-30 13:18:25 UTC
The reboot issue can be handled with kernel option reboot=bios. I checked all
reboot= options and this one is the only one working.
Comment 34 Markus schaber 2005-11-21 09:11:43 UTC
2.6.15-rc2 also does not include the ACPI fix from https://bugzilla.novell.com/
show_bug.cgi?id=116763 - now I ask again: What shall we do to get this patch 
into mainstream kernel?
Comment 35 Daniel Drake 2005-11-27 05:27:05 UTC
Downstream bug:
http://bugs.gentoo.org/112601
Comment 36 Len Brown 2005-11-30 19:55:43 UTC
applied to acpi-test
Comment 37 Len Brown 2005-12-05 13:59:11 UTC
shipped in linux-2.6.15-rc5 -- closing.
Comment 38 Paul 2006-04-06 02:17:02 UTC
Created attachment 7785 [details]
copy of DMESG file

Copy of DMESG file
Comment 39 Paul 2006-04-06 02:22:58 UTC
Kernel 2.6.16-1.2080_FC5 showing same symptoms as this bug.

IBM Thinkpad A30P with docking station attached.

from DMESG (attached)

PCI: Cannot allocate resource region 7 of bridge 0000:02:03.0
PCI: Cannot allocate resource region 8 of bridge 0000:02:03.0
PCI: Cannot allocate resource region 9 of bridge 0000:02:03.0

System won't boot properly about 50% of the time (locks during boot)
System won't restart properly about 50% of the time (requires power cycle to 
reset)

If you want any other files or for me to try anything please let me know.

Paul
Comment 40 Paul 2006-04-06 07:23:46 UTC
Created attachment 7787 [details]
lspci.txt from same machine

This is the lspci output from the same machine
Comment 41 Paul 2006-04-06 07:28:59 UTC
Having read extensively on this since posting it looks like a 'sort of' known 
bug.

http://marc.theaimsgroup.com/?l=linux-acpi&m=114073385031547&w=2

I can't yet tell if these patches were included in the version I'm currently 
using so will read further to see if they have been.

The thought occured to me as well that the build was done while the docking 
station was attached, I'll do another build on the same machine without the 
docking station is attached and report back.

Paul

Comment 42 Pavel Machek 2006-05-19 03:04:56 UTC
If the problem is still present in 2.6.17-rc4, please reopen.
Comment 43 rudolph 2006-09-02 21:57:46 UTC
2.6.18-rc5 works fine on my hardware (hp nc6220 laptop)

Note You need to log in before you can comment on or make changes to this bug.