Bug 52061 - [snb dp] intel_wait_for_pipe_off timed out
Summary: [snb dp] intel_wait_for_pipe_off timed out
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-28 05:40 UTC by Kalin KOZHUHAROV
Modified: 2014-11-26 08:19 UTC (History)
9 users (show)

See Also:
Kernel Version: 3.7.1
Tree: Mainline
Regression: Yes


Attachments
full dmesg attached (with drm.debug=0xe) (99.28 KB, text/plain)
2012-12-28 05:40 UTC, Kalin KOZHUHAROV
Details
full dmesg attached (with drm.debug=0xe), no external monitor attached (74.20 KB, text/plain)
2013-01-08 03:40 UTC, Kalin KOZHUHAROV
Details
dmesg from 3.6.0 with drm debug (81.20 KB, text/plain)
2013-01-08 07:36 UTC, Meelis Roos
Details
dmesg from 3.7.0 with drm debug (103.23 KB, text/plain)
2013-01-08 07:37 UTC, Meelis Roos
Details
full 3.8.0-r1 dmesg attached (with drm.debug=0xe), external monitor attached (88.49 KB, text/plain)
2013-04-10 15:55 UTC, Kalin KOZHUHAROV
Details
dmesg for 3.16.1 vanilla, dock HDMI connected (65.17 KB, text/plain)
2014-08-18 06:04 UTC, Kalin KOZHUHAROV
Details
dmesg for 3.16.1 patched, dock HDMI connected (61.12 KB, text/plain)
2014-08-18 06:06 UTC, Kalin KOZHUHAROV
Details

Description Kalin KOZHUHAROV 2012-12-28 05:40:03 UTC
Created attachment 89741 [details]
full dmesg attached (with drm.debug=0xe)

Very similar to https://lkml.org/lkml/2012/11/12/343, so adding its author (Melis ROOS) in Cc.

I upgraded from 3.6.3 to 3.7.1 with minimal change in config and started getting this:
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/i915/intel_display.c:1009 intel_wait_for_pipe_off+0x12e/0x13a [i915]()
Hardware name: dynabook R731/W2UB
pipe_off wait timed out
Modules linked in: btusb bluetooth arc4 iwldvm mac80211 snd_hda_intel(+) coretemp iwlwifi i915(+) snd_hda_codec snd_usb_audio crc32c_intel cfg80211 snd_hwdep snd_usbmidi_lib snd_rawmidi i2400m_usb(+) i2400m pl2303 drm_kms_helper drm snd_pcm snd_seq_device wimax iTCO_wdt usbserial i2c_algo_bit i2c_core iTCO_vendor_support snd_timer snd sdhci_pci soundcore joydev e1000e rfkill microcode video xhci_hcd sdhci lpc_ich snd_page_alloc toshiba_bluetooth mfd_core mmc_core sr_mod cdrom sg
Pid: 280, comm: modprobe Not tainted 3.7.1-r2 #2
Call Trace:
 [<ffffffff81057d20>] warn_slowpath_common+0x80/0x98
 [<ffffffff81057dcc>] warn_slowpath_fmt+0x41/0x43
 [<ffffffffa0288f25>] intel_wait_for_pipe_off+0x12e/0x13a [i915]
 [<ffffffffa0289066>] intel_disable_pipe+0x135/0x13e [i915]
 [<ffffffffa02896a7>] ironlake_crtc_disable+0xc5/0x7a0 [i915]
 [<ffffffff8105a52e>] ? vprintk+0x18/0x1a
 [<ffffffffa028ee85>] intel_set_mode+0x3e3/0x80b [i915]
 [<ffffffff81083e88>] ? sched_clock_cpu+0x42/0xc6
 [<ffffffffa028f852>] intel_crtc_set_config+0x5a5/0x70a [i915]
 [<ffffffff8132fed4>] ? set_inverse_transl+0x61/0xc0
 [<ffffffffa009a7a1>] drm_fb_helper_set_par+0x69/0xb2 [drm_kms_helper]
 [<ffffffff812cfbe8>] fbcon_init+0x3e2/0x504
 [<ffffffff8133103c>] visual_init+0xba/0x111
 [<ffffffff81331efc>] bind_con_driver+0x1a9/0x2c5
 [<ffffffff81332050>] take_over_console+0x38/0x45
 [<ffffffff812cc829>] fbcon_takeover+0x57/0x91
 [<ffffffff812d032e>] fbcon_event_notify+0x2d2/0x61c
 [<ffffffff810789f0>] notifier_call_chain+0x32/0x5e
 [<ffffffff81078c1b>] __blocking_notifier_call_chain+0x46/0x5b
 [<ffffffff81078c3f>] blocking_notifier_call_chain+0xf/0x11
 [<ffffffff812c2dca>] fb_notifier_call_chain+0x16/0x18
 [<ffffffff812c3fd5>] register_framebuffer+0x272/0x296
 [<ffffffffa009a9bd>] drm_fb_helper_single_fb_probe+0x1d3/0x286 [drm_kms_helper]
 [<ffffffffa009ac37>] drm_fb_helper_initial_config+0x1c7/0x1de [drm_kms_helper]
 [<ffffffffa0099e11>] ? kzalloc.clone.7+0xe/0x10 [drm_kms_helper]
 [<ffffffff811283ce>] ? __kmalloc+0xed/0x100
 [<ffffffffa02a4704>] intel_fbdev_init+0x79/0x85 [i915]
 [<ffffffffa026ca81>] i915_driver_load+0xb5f/0xd11 [i915]
 [<ffffffffa015c98c>] drm_get_pci_dev+0x15d/0x268 [drm]
 [<ffffffffa02af521>] i915_pci_probe+0x7d/0x85 [i915]
 [<ffffffff812b2805>] local_pci_probe+0x5b/0xa2
 [<ffffffff812b3637>] pci_device_probe+0xcd/0xff
 [<ffffffff8118eca2>] ? sysfs_create_link+0xe/0x10
 [<ffffffff813565ff>] driver_probe_device+0x12a/0x2f4
 [<ffffffff814eb570>] ? mutex_lock+0x11/0x32
 [<ffffffff81356821>] __driver_attach+0x58/0x7c
 [<ffffffff813567c9>] ? driver_probe_device+0x2f4/0x2f4
 [<ffffffff81354c9e>] bus_for_each_dev+0x54/0x81
 [<ffffffff8135616e>] driver_attach+0x19/0x1b
 [<ffffffff81355c02>] bus_add_driver+0xcc/0x21b
 [<ffffffff81356d35>] driver_register+0x8e/0x108
 [<ffffffff812b372f>] __pci_register_driver+0x44/0x46
 [<ffffffffa015cb1f>] drm_pci_init+0x88/0xed [drm]
 [<ffffffffa02e2000>] ? 0xffffffffa02e1fff
 [<ffffffffa02e2066>] i915_init+0x66/0x68 [i915]
 [<ffffffff810020d8>] do_one_initcall+0x7a/0x132
 [<ffffffff810a6fd5>] sys_init_module+0x7f/0x1c1
 [<ffffffff814edaa9>] system_call_fastpath+0x16/0x1b
---[ end trace 174652c676824093 ]---

Machine is Toshiba Laptop, Dynabook R731/W2UB sold in Japan.

# lspci -vv -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Toshiba America Info Systems Device 0005
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 55
	Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
	Region 2: Memory at b0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at 3000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
		Address: fee0f00c  Data: 41d2
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [a4] PCI Advanced Features
		AFCap: TP+ FLR+
		AFCtrl: FLR-
		AFStatus: TP-
	Kernel driver in use: i915
	Kernel modules: i915

Full dmesg attached.

So far the system is working OK in X, but console seems strange (not full screen) on external monitor (attached via HDMI3 on laptop docking station).

This is not production machine, can test patches/configs. Distro is Gentoo, but kernel is vanilla, no patches applied.
Comment 1 Daniel Vetter 2013-01-07 15:38:28 UTC
For comparison, can you please attach a debug dmesg from 3.6? Also, please test what happens on 3.8-rc kernels, we've changed around things a bit ...
Comment 2 Kalin KOZHUHAROV 2013-01-08 03:39:01 UTC
(In reply to comment #1)
> For comparison, can you please attach a debug dmesg from 3.6? Also, please
> test
> what happens on 3.8-rc kernels, we've changed around things a bit ...

Hi again,

I did some testing and couldn't reproduce the above...
Looking at the above (attachment id=89741), it was produced when an external monitor was connected via the docking station of the laptop. The docking station is not by me now, will retest in a day or two.
Comment 3 Kalin KOZHUHAROV 2013-01-08 03:40:54 UTC
Created attachment 90671 [details]
full dmesg attached (with drm.debug=0xe), no external monitor attached

In this state the bug does not show itself...

(will test with different kernels and external monitor attached in a day or two)
Comment 4 Meelis Roos 2013-01-08 07:36:49 UTC
Created attachment 90691 [details]
dmesg from 3.6.0 with drm debug

This is from another test system (see LKML link to my report).
Comment 5 Meelis Roos 2013-01-08 07:37:12 UTC
Created attachment 90701 [details]
dmesg from 3.7.0 with drm debug

This is from another test system (see LKML link to my report).
Comment 6 Daniel Vetter 2013-02-06 09:51:35 UTC
Meelis Roos it looks like you have a different system (ironlake vs. the sandybridge of the original reporter), so rather likely that you also have a different bug. The WARN is simply a paranoid check whether the hw works as it should, which can (but not necessarily must) lead to display issues.

Kalin, the wait_pipe_off timed out WARN on ilk is typical for external DP monitors (when disabling the screen, i.e. dpms, xrandr --off or unplugging the cable). Would this match up with when you can reproduce these WARNs and when not?
Comment 7 Jani Nikula 2013-04-10 11:49:10 UTC
Ping. Kalin, please provide the info requested in comment #6.
Comment 8 Kalin KOZHUHAROV 2013-04-10 15:11:36 UTC
Hello and sorry for being unresponsive on a bug I filed :-|

At the moment I am running 3.8.0 and the bug is still present (2d ago) when I booted on my docking station with an external (via HDMI) monitor.

The trace is a bit different this time, at least to my eyes:

[    0.000000] Linux version 3.8.0-r1 (root@ss3) (gcc version 4.6.3 (Gentoo 4.6.3 p1.9, pie-0.5.2) ) #1 SMP Mon Feb 25 00:02:26 JST 2013
[    0.000000] Command line: root=/dev/sda4

....

[    3.789001] ------------[ cut here ]------------
[    3.789049] WARNING: at drivers/gpu/drm/i915/intel_display.c:1028 intel_wait_for_pipe_off+0x14c/0x169 [i915]()
[    3.789051] Hardware name: dynabook R731/W2UB
[    3.789052] pipe_off wait timed out
[    3.789106] Modules linked in: fbcon(+) bitblit softcursor font i2400m_usb(+) i2400m wimax btusb bluetooth snd_hda_codec_hdmi snd_hda_codec_realtek arc4 iwldvm mac80211 i915 snd_hda_intel snd_hda_codec i2c_algo_bit snd_hwdep intel_agp snd_pcm intel_gtt snd_page_alloc iwlwifi drm_kms_helper snd_timer cfg80211 snd drm toshiba_acpi agpgart sparse_keymap ehci_pci crc32c_intel wmi rfkill ehci_hcd sdhci_pci sr_mod sdhci xhci_hcd mmc_core cdrom led_class pata_jmicron usbcore toshiba_bluetooth e1000e joydev video usb_common
[    3.789112] Pid: 1331, comm: modprobe Tainted: G        W    3.8.0-r1 #1
[    3.789113] Call Trace:
[    3.789130]  [<ffffffff8105528f>] warn_slowpath_common+0x7e/0x96
[    3.789137]  [<ffffffff8105533b>] warn_slowpath_fmt+0x41/0x43
[    3.789166]  [<ffffffffa02619e3>] intel_wait_for_pipe_off+0x14c/0x169 [i915]
[    3.789191]  [<ffffffffa0261b46>] intel_disable_pipe+0x146/0x14e [i915]
[    3.789214]  [<ffffffffa02621bd>] ironlake_crtc_disable+0xc6/0x769 [i915]
[    3.789242]  [<ffffffffa026c898>] ? intel_lvds_mode_fixup+0xb8/0x2e8 [i915]
[    3.789269]  [<ffffffffa0268922>] intel_set_mode+0x3d5/0x7fc [i915]
[    3.789297]  [<ffffffffa026934b>] intel_crtc_set_config+0x602/0x733 [i915]
[    3.789308]  [<ffffffffa020c81a>] drm_fb_helper_set_par+0x69/0xb2 [drm_kms_helper]
[    3.789317]  [<ffffffffa0497e31>] fbcon_init+0x30e/0x409 [fbcon]
[    3.789324]  [<ffffffff812e5293>] visual_init+0xb8/0x10e
[    3.789329]  [<ffffffff812e6484>] bind_con_driver+0x1af/0x2af
[    3.789336]  [<ffffffffa049f000>] ? 0xffffffffa049efff
[    3.789342]  [<ffffffff812e65bc>] take_over_console+0x38/0x45
[    3.789349]  [<ffffffffa04962ed>] fbcon_takeover+0x4f/0x7d [fbcon]
[    3.789356]  [<ffffffffa049f118>] fb_console_init+0x118/0x11f [fbcon]
[    3.789360]  [<ffffffffa049f000>] ? 0xffffffffa049efff
[    3.789366]  [<ffffffff8100209a>] do_one_initcall+0x7a/0x134
[    3.789373]  [<ffffffff810a0684>] load_module+0x1641/0x193d
[    3.789379]  [<ffffffff8109c4ac>] ? sys_getegid16+0x44/0x44
[    3.789386]  [<ffffffff8144d658>] ? page_fault+0x28/0x30
[    3.789391]  [<ffffffff810a0a29>] sys_init_module+0xa9/0xab
[    3.789399]  [<ffffffff8144dc29>] system_call_fastpath+0x16/0x1b
[    3.789402] ---[ end trace 780565dd4a0d8eb7 ]---

Judging from the time in prink, it only occurs on boot with the dockstation/monitor plugged in around 3.7s from boot on 3.8.0 and 4.7s from boot on 3.7.1...

Today I booted and later plugged the machine to the dock (followed by at least 1-2 more plug/unplugs), but the bug hasn't shown up. Every replug includes xrandr --off (actually arandr) since I need to switch my displays.

I just unplugged, waited 5s and re-plugged the HDMI, nothing was reported in dmesg.

I know it is a WARN only, but are you saying we should just ignore it?
Is there any other test I can be helpful with?
In a bout a week I'll have another revision of the same hardware to test (dynabook R732), in case it is hardware specific to these laptops.
Comment 9 Daniel Vetter 2013-04-10 15:20:17 UTC
I think we have a bug somewhere in our failure handling of DP link training - if that failed the pipe gets stuck and we can't properly turn it off again.

If there's no other issue for you we can handle it as a low-prio bug, but generally this warning has caught some real issues.

If you can observe things a bit it'd be useful to know whether the warning is always preceeded by a DP link train failure like this:

[    0.699109] [drm:intel_dp_complete_link_train] *ERROR* failed to train DP, aborting
[    0.699110] [drm:intel_dp_link_down],
Comment 10 Kalin KOZHUHAROV 2013-04-10 15:55:26 UTC
Created attachment 97991 [details]
full 3.8.0-r1 dmesg attached (with drm.debug=0xe), external monitor attached

OK, I rebooted with the display plugged in and sure it showed itself.

I also noticed another WARNING early on:
WARNING: at drivers/pci/search.c:46 pci_find_upstream_pcie_bridge+0x56/0x70()
Searching around it seems bug #44881.

I am attaching a full dmesg with drm.debug=0xe.

In my case, I don't have any drm:intel_dp_complete_link_train messages, I saw Meelis indeed has those.

I am not bothered by the current behaviour, just wanted to let others know.
Comment 11 Daniel Vetter 2013-04-10 16:38:19 UTC
Ok, bugzilla confusion, you two don't have the same bug since it's not the same platform (and otherwise also a bit different). Or at least we need to treat them as different bugs until this is resolved.

Melis, can you please file a new bug report for your issue?

Kalin, does this only happen on boot-up when you have an external monitor connected? Or have you seen this WARN at different places, too?
Comment 12 Kalin KOZHUHAROV 2013-04-10 18:13:32 UTC
Only at boot-up with docking station/monitor plugged. I wasn't been able to reproduce it in any other way (just grep confirmed in my logs). I can say it is 100% reproducible.

This was fine:
Linux version 3.6.3 (root@ss3) (gcc version 4.5.3 (Gentoo 4.5.3-r2 p1.1, pie-0.4.7) ) #1 SMP Tue Oct 23 00:46:51 JST 2012

It started from here:
Linux version 3.7.1-r1 (root@ss3) (gcc version 4.5.4 (Gentoo 4.5.4 p1.0, pie-0.4.7) ) #1 SMP Fri Dec 28 10:07:27 JST 2012

Currently still present in:
Linux version 3.8.0-r1 (root@ss3) (gcc version 4.6.3 (Gentoo 4.6.3 p1.9, pie-0.5.2) ) #1 SMP Mon Feb 25 00:02:26 JST 2013

All kernels are vanilla, config is generally the same.
I have upgraded userland (udev-200, etc.) so not sure if I can test older kernels easily, but 3.8.x + patches I can test.
Comment 13 Matthias Blaicher 2013-05-19 06:45:12 UTC
Hi all,

I also see this when booting my docked Thinkpad X220 with two external monitors connected via DVI (outputs HDMI2/3).

I'm running KDE with the new kscreen daemon. Interestingly it always fails on KDE start with setting the second monitor (on HDMI2). Xrender claims the everything is fine, but the screen just remains dark. When I redock everything is fine again. I could imagine this issue is related. 

[33903.006698] ------------[ cut here ]------------
[33903.006766] WARNING: at drivers/gpu/drm/i915/intel_display.c:979 intel_wait_for_pipe_off+0xe6/0x1b0 [i915]()
[33903.006770] pipe_off wait timed out
[33903.006773] Modules linked in: psmouse serio_raw iTCO_wdt iTCO_vendor_support snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_device uvcvideo videobuf2_vmalloc videobuf2_memops btusb videobuf2_core videodev bluetooth media snd_hda_codec_hdmi snd_hda_codec_conexant arc4 intel_powerclamp coretemp kvm_intel kvm iwldvm mac80211 microcode iwlwifi cfg80211 i2c_i801 snd_hda_intel thermal snd_hda_codec thinkpad_acpi wmi tpm_tis nvram e1000e snd_hwdep snd_pcm battery tpm rfkill ac tpm_bios snd_page_alloc snd_timer mperf snd ptp pps_core soundcore lpc_ich evdev processor nfs lockd sunrpc fscache ext4 crc16 mbcache jbd2 sha256_generic hid_apple dm_crypt sd_mod hid_generic usbhid hid crc32_pclmul crc32c_intel ghash_clmulni_intel aesni_intel aes_x86_64 ahci lrw gf128mul glue_helper ablk_helper cryptd libahci
[33903.006862]  sdhci_pci libata ehci_pci sdhci ehci_hcd xhci_hcd scsi_mod mmc_core usbcore usb_common i915 video button i2c_algo_bit intel_agp intel_gtt drm_kms_helper drm i2c_core dm_mod
[33903.006891] CPU: 0 PID: 1800 Comm: X Not tainted 3.10.0-1-mainline #1
[33903.006895] Hardware name: LENOVO 4291NB6/4291NB6, BIOS 8DET67WW (1.37 ) 12/05/2012
[33903.006900]  0000000000000009 ffff880307f399f0 ffffffff814aa0c4 ffff880307f39a28
[33903.006908]  ffffffff81041501 0000000000071008 ffff880309e70000 00000001009a05dc
[33903.006915]  ffff880307f39fd8 ffff880309e70000 ffff880307f39a88 ffffffff8104156c
[33903.006922] Call Trace:
[33903.006936]  [<ffffffff814aa0c4>] dump_stack+0x19/0x1b
[33903.006948]  [<ffffffff81041501>] warn_slowpath_common+0x61/0x80
[33903.006956]  [<ffffffff8104156c>] warn_slowpath_fmt+0x4c/0x50
[33903.006984]  [<ffffffffa00d53a6>] intel_wait_for_pipe_off+0xe6/0x1b0 [i915]
[33903.007008]  [<ffffffffa00d5604>] intel_disable_pipe+0x194/0x220 [i915]
[33903.007030]  [<ffffffffa00d5f76>] ironlake_crtc_disable+0xc6/0x8c0 [i915]
[33903.007041]  [<ffffffff8115a9c7>] ? kmem_cache_alloc_trace+0x257/0x280
[33903.007050]  [<ffffffff8119c26c>] ? __mark_inode_dirty+0x3c/0x310
[33903.007073]  [<ffffffffa00d7c44>] __intel_set_mode+0x4b4/0xcb0 [i915]
[33903.007080]  [<ffffffff8125de91>] ? vsnprintf+0x411/0x670
[33903.007105]  [<ffffffffa00df2f6>] intel_set_mode+0x16/0x30 [i915]
[33903.007130]  [<ffffffffa00dfa7f>] intel_crtc_set_config+0x66f/0x900 [i915]
[33903.007156]  [<ffffffffa0039d13>] drm_mode_set_config_internal+0x23/0x50 [drm]
[33903.007178]  [<ffffffffa003c7a7>] drm_mode_setcrtc+0xf7/0x650 [drm]
[33903.007198]  [<ffffffffa002d1c9>] drm_ioctl+0x529/0x5e0 [drm]
[33903.007211]  [<ffffffff81185b85>] do_vfs_ioctl+0x2e5/0x4d0
[33903.007219]  [<ffffffff81176131>] ? __sb_end_write+0x31/0x60
[33903.007226]  [<ffffffff81185df1>] SyS_ioctl+0x81/0xa0
[33903.007236]  [<ffffffff814b6e06>] system_call_fastpath+0x1a/0x1f
[33903.007240] ---[ end trace 47ad660a6fdc82ff ]---
Comment 15 Adam Williamson 2014-04-28 20:46:19 UTC
There's a longstanding similar downstream report at https://bugzilla.redhat.com/show_bug.cgi?id=929220 . I have had a similar intel_wait_for_pipe_off timeout on my Sony Vaio Z (2010 version, VPCZ1, graphics adapter an 8086:0046) for many kernel revisions now, and it persists with 3.14 (latest kernel to hit Fedora 20). The 3.14 incarnation looks like this:

WARNING: CPU: 0 PID: 283 at drivers/gpu/drm/i915/intel_display.c:851 intel_wait_for_pipe_off+0x1db/0x1f0 [i915]()
pipe_off wait timed out
Modules linked in: crct10dif_pclmul crc32_pclmul crc32c_intel i915(+) ghash_clmulni_intel e1000e i2c_algo_bit drm_kms_helper ptp drm pps_core i2c_core video
CPU: 0 PID: 283 Comm: systemd-udevd Not tainted 3.13.10-200.fc20.x86_64 #1
Hardware name: Sony Corporation VPCZ112GD/VAIO, BIOS R3031C3 10/04/2011
 0000000000000009 ffff88024ce172e8 ffffffff81687eac ffff88024ce17330
 ffff88024ce17320 ffffffff8106d4dd ffff880036964000 0000000000070008
 00000000fffb7b27 0000000000000000 ffff88024ccdd320 ffff88024ce17380
Call Trace:
 [<ffffffff81687eac>] dump_stack+0x45/0x56
 [<ffffffff8106d4dd>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106d54c>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa015d9c8>] ? gen5_read32+0x48/0xc0 [i915]
 [<ffffffffa011e2ab>] intel_wait_for_pipe_off+0x1db/0x1f0 [i915]
 [<ffffffffa011e360>] intel_disable_pipe+0xa0/0xb0 [i915]
 [<ffffffffa011f434>] ironlake_crtc_disable+0xe4/0x940 [i915]
 [<ffffffffa011b39e>] ? intel_dump_pipe_config.isra.46+0x35e/0x370 [i915]
 [<ffffffffa0126374>] __intel_set_mode+0x7e4/0x14d0 [i915]
 [<ffffffffa0129456>] intel_set_mode+0x16/0x30 [i915]
 [<ffffffffa0129d0b>] intel_crtc_set_config+0x7ab/0x9a0 [i915]
 [<ffffffffa0031a5d>] drm_mode_set_config_internal+0x5d/0xe0 [drm]
 [<ffffffffa0088f41>] drm_fb_helper_set_par+0x71/0xf0 [drm_kms_helper]
 [<ffffffff8137b534>] fbcon_init+0x4f4/0x570
 [<ffffffff813eb3b8>] visual_init+0xb8/0x120
 [<ffffffff813edcd3>] do_bind_con_driver+0x163/0x330
 [<ffffffff813ee484>] do_take_over_console+0x114/0x1c0
 [<ffffffff81376df3>] do_fbcon_takeover+0x63/0xd0
 [<ffffffff8137c09d>] fbcon_event_notify+0x60d/0x720
 [<ffffffff81692a1c>] notifier_call_chain+0x4c/0x70
 [<ffffffff81093a0d>] __blocking_notifier_call_chain+0x4d/0x70
 [<ffffffff81093a46>] blocking_notifier_call_chain+0x16/0x20
 [<ffffffff8136db4b>] fb_notifier_call_chain+0x1b/0x20
 [<ffffffff8136fb2b>] register_framebuffer+0x1db/0x320
 [<ffffffffa0088bef>] drm_fb_helper_initial_config+0x32f/0x500 [drm_kms_helper]
 [<ffffffffa015d9c8>] ? gen5_read32+0x48/0xc0 [i915]
 [<ffffffffa015dbfb>] ? gen5_write32+0x4b/0xb0 [i915]
 [<ffffffffa0163ff1>] intel_fbdev_initial_config+0x21/0x30 [i915]
 [<ffffffffa00ee2ac>] i915_driver_load+0xe0c/0xe40 [i915]
 [<ffffffffa002ba92>] drm_dev_register+0xa2/0x1e0 [drm]
 [<ffffffffa002d962>] drm_get_pci_dev+0x92/0x140 [drm]
 [<ffffffffa00ea67c>] i915_pci_probe+0x3c/0x90 [i915]
 [<ffffffff81352295>] local_pci_probe+0x45/0xa0
 [<ffffffff81093a18>] ? __blocking_notifier_call_chain+0x58/0x70
 [<ffffffff81353611>] pci_device_probe+0xd1/0x130
 [<ffffffff81418305>] driver_probe_device+0x125/0x3a0
 [<ffffffff81418653>] __driver_attach+0x93/0xa0
 [<ffffffff814185c0>] ? __device_attach+0x40/0x40
 [<ffffffff81416293>] bus_for_each_dev+0x63/0xa0
 [<ffffffff81417cbe>] driver_attach+0x1e/0x20
 [<ffffffff814178a0>] bus_add_driver+0x180/0x250
 [<ffffffffa01aa000>] ? 0xffffffffa01a9fff
 [<ffffffff81418c94>] driver_register+0x64/0xf0
 [<ffffffffa01aa000>] ? 0xffffffffa01a9fff
 [<ffffffff81351c3c>] __pci_register_driver+0x4c/0x50
 [<ffffffffa002db2a>] drm_pci_init+0x11a/0x130 [drm]
 [<ffffffffa01aa000>] ? 0xffffffffa01a9fff
 [<ffffffffa01aa066>] i915_init+0x66/0x68 [i915]
 [<ffffffff8100214a>] do_one_initcall+0xfa/0x1b0
 [<ffffffff810548d3>] ? set_memory_nx+0x43/0x50
 [<ffffffff810e07ed>] load_module+0x1e1d/0x25b0
 [<ffffffff810dc500>] ? store_uevent+0x40/0x40
 [<ffffffff810e10f6>] SyS_finit_module+0x86/0xb0
 [<ffffffff81696e69>] system_call_fastpath+0x16/0x1b

I hit this on, I think, every single boot of the affected laptop - it does not happen only when an external display is connected. There doesn't appear to be any phantom display either - xrandr reports only eDP1 (the laptop's internal display) as connected, which is correct.

Let me know if I can provide any further info, or if this too should be filed as a separate bug.
Comment 16 Adam Williamson 2014-04-28 20:47:56 UTC
oh, whoops, now I see from the trace that I'm Ironlake too. It looks like the Ironlake bug is https://bugzilla.kernel.org/show_bug.cgi?id=62251 (for the convenience of other searchers).
Comment 17 rik.theys 2014-04-30 08:38:05 UTC
Hi,

I'm experiencing this bug on 

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

on a Dell Optiplex 990 with a Dell 30" monitor attached. This is a desktop computer, not a laptop.

I get the following WARNING on 3.13.10-200.fc20.x86_64

[    1.648921] WARNING: CPU: 3 PID: 301 at drivers/gpu/drm/i915/intel_display.c:851 intel_wait_for_pipe_off+0x1db/0x1f0 [i915]()
[    1.648922] pipe_off wait timed out
[    1.648925] Modules linked in: i915(+) i2c_algo_bit drm_kms_helper drm i2c_core video
[    1.648927] CPU: 3 PID: 301 Comm: systemd-udevd Not tainted 3.13.10-200.fc20.x86_64 #1
[    1.648928] Hardware name: Dell Inc. OptiPlex 990/06D7TR, BIOS A17 03/14/2013
[    1.648930]  0000000000000009 ffff880036e532e8 ffffffff81687eac ffff880036e53330
[    1.648932]  ffff880036e53320 ffffffff8106d4dd ffff880414374000 0000000000070008
[    1.648933]  00000000fffb727d 0000000000000000 ffff8804147d5320 ffff880036e53380
[    1.648934] Call Trace:
[    1.648939]  [<ffffffff81687eac>] dump_stack+0x45/0x56
[    1.648942]  [<ffffffff8106d4dd>] warn_slowpath_common+0x7d/0xa0
[    1.648944]  [<ffffffff8106d54c>] warn_slowpath_fmt+0x4c/0x50
[    1.648971]  [<ffffffffa00ba2ab>] intel_wait_for_pipe_off+0x1db/0x1f0 [i915]
[    1.648986]  [<ffffffffa00ba360>] intel_disable_pipe+0xa0/0xb0 [i915]
[    1.649000]  [<ffffffffa00bb434>] ironlake_crtc_disable+0xe4/0x940 [i915]
[    1.649014]  [<ffffffffa00b739e>] ? intel_dump_pipe_config.isra.46+0x35e/0x370 [i915]
[    1.649029]  [<ffffffffa00c2374>] __intel_set_mode+0x7e4/0x14d0 [i915]
[    1.649045]  [<ffffffffa00c5456>] intel_set_mode+0x16/0x30 [i915]
[    1.649058]  [<ffffffffa00c5d0b>] intel_crtc_set_config+0x7ab/0x9a0 [i915]
[    1.649071]  [<ffffffffa002ba5d>] drm_mode_set_config_internal+0x5d/0xe0 [drm]
[    1.649075]  [<ffffffffa007cf41>] drm_fb_helper_set_par+0x71/0xf0 [drm_kms_helper]
[    1.649078]  [<ffffffff8137b534>] fbcon_init+0x4f4/0x570
[    1.649081]  [<ffffffff813eb3b8>] visual_init+0xb8/0x120
[    1.649084]  [<ffffffff813edcd3>] do_bind_con_driver+0x163/0x330
[    1.649087]  [<ffffffff813ee484>] do_take_over_console+0x114/0x1c0
[    1.649097]  [<ffffffff81376df3>] do_fbcon_takeover+0x63/0xd0
[    1.649099]  [<ffffffff8137c09d>] fbcon_event_notify+0x60d/0x720
[    1.649109]  [<ffffffff81692a1c>] notifier_call_chain+0x4c/0x70
[    1.649112]  [<ffffffff81093a0d>] __blocking_notifier_call_chain+0x4d/0x70
[    1.649114]  [<ffffffff81093a46>] blocking_notifier_call_chain+0x16/0x20
[    1.649117]  [<ffffffff8136db4b>] fb_notifier_call_chain+0x1b/0x20
[    1.649120]  [<ffffffff8136fb2b>] register_framebuffer+0x1db/0x320
[    1.649123]  [<ffffffffa007cbef>] drm_fb_helper_initial_config+0x32f/0x500 [drm_kms_helper]
[    1.649147]  [<ffffffffa00fa032>] ? gen6_read32+0x52/0x110 [i915]
[    1.649167]  [<ffffffffa00f9f55>] ? gen6_write32+0x55/0xe0 [i915]
[    1.649184]  [<ffffffffa00f9f55>] ? gen6_write32+0x55/0xe0 [i915]
[    1.649204]  [<ffffffffa00ffff1>] intel_fbdev_initial_config+0x21/0x30 [i915]
[    1.649220]  [<ffffffffa008a2ac>] i915_driver_load+0xe0c/0xe40 [i915]
[    1.649230]  [<ffffffffa0025a92>] drm_dev_register+0xa2/0x1e0 [drm]
[    1.649239]  [<ffffffffa0027962>] drm_get_pci_dev+0x92/0x140 [drm]
[    1.649254]  [<ffffffffa008667c>] i915_pci_probe+0x3c/0x90 [i915]
[    1.649265]  [<ffffffff81352295>] local_pci_probe+0x45/0xa0
[    1.649267]  [<ffffffff81093a18>] ? __blocking_notifier_call_chain+0x58/0x70
[    1.649277]  [<ffffffff81353611>] pci_device_probe+0xd1/0x130
[    1.649280]  [<ffffffff81418305>] driver_probe_device+0x125/0x3a0
[    1.649283]  [<ffffffff81418653>] __driver_attach+0x93/0xa0
[    1.649285]  [<ffffffff814185c0>] ? __device_attach+0x40/0x40
[    1.649288]  [<ffffffff81416293>] bus_for_each_dev+0x63/0xa0
[    1.649291]  [<ffffffff81417cbe>] driver_attach+0x1e/0x20
[    1.649293]  [<ffffffff814178a0>] bus_add_driver+0x180/0x250
[    1.649295]  [<ffffffffa0146000>] ? 0xffffffffa0145fff
[    1.649298]  [<ffffffff81418c94>] driver_register+0x64/0xf0
[    1.649299]  [<ffffffffa0146000>] ? 0xffffffffa0145fff
[    1.649301]  [<ffffffff81351c3c>] __pci_register_driver+0x4c/0x50
[    1.649309]  [<ffffffffa0027b2a>] drm_pci_init+0x11a/0x130 [drm]
[    1.649310]  [<ffffffffa0146000>] ? 0xffffffffa0145fff
[    1.649326]  [<ffffffffa0146066>] i915_init+0x66/0x68 [i915]
[    1.649328]  [<ffffffff8100214a>] do_one_initcall+0xfa/0x1b0
[    1.649331]  [<ffffffff810548d3>] ? set_memory_nx+0x43/0x50
[    1.649334]  [<ffffffff810e07ed>] load_module+0x1e1d/0x25b0
[    1.649336]  [<ffffffff810dc500>] ? store_uevent+0x40/0x40
[    1.649339]  [<ffffffff810e10f6>] SyS_finit_module+0x86/0xb0
[    1.649342]  [<ffffffff81696e69>] system_call_fastpath+0x16/0x1b
[    1.649344] ---[ end trace 49c497fc6aabd066 ]---
[    1.697017] usb 2-1.5: new low-speed USB device number 4 using ehci-pci
[    1.701903] [drm:ironlake_disable_pch_transcoder] *ERROR* failed to disable transcoder A

I see this bug has a NEEDINFO status. What more information/feedback is needed?

Regards,

Rik
Comment 18 Adam Williamson 2014-04-30 16:27:52 UTC
From the traceback that looks like Ironlake too - https://bugzilla.kernel.org/show_bug.cgi?id=62251 is the bug for Ironlake, I believe.
Comment 19 Daniel Vetter 2014-05-22 20:27:30 UTC
Please test this patch here, should apply to any recent-ish upstream:

http://patchwork.freedesktop.org/patch/24864/
Comment 20 Jani Nikula 2014-08-14 08:34:52 UTC
(In reply to Daniel Vetter from comment #19)
> Please test this patch here, should apply to any recent-ish upstream:
> 
> http://patchwork.freedesktop.org/patch/24864/

Ping for testing.
Comment 21 Kalin KOZHUHAROV 2014-08-14 14:01:03 UTC
Hello,

I just compiled the latest 3.16.1 and prepared the patch, but my docking station is at the office, so I cannot test it till Tuesday (in 4 days).

I tried to plug/unplug another HDMI monitor (but directly), reboot and switch consoles, but was not able to reproduce the bug at home (neither the "failing" 3.8.0 nor the fresh 3.16.1 with or without patch), sigh...

Will report in 4 days.
Comment 22 Adam Williamson 2014-08-15 06:45:21 UTC
Huh. I *think* I tested this back in May and found it worked, but I've no idea why I didn't update the bug in that case. I can try again, but not till next week as I'm currently not on the same continent as the system that reproduces the bug...
Comment 23 Kalin KOZHUHAROV 2014-08-18 06:04:01 UTC
Created attachment 146981 [details]
dmesg for 3.16.1 vanilla, dock HDMI connected

bug is still here with vanilla 3.16.1 ...
Comment 24 Kalin KOZHUHAROV 2014-08-18 06:06:21 UTC
Created attachment 146991 [details]
dmesg for 3.16.1 patched, dock HDMI connected

3.16.1 patched according to comment #19, but bug is still here, may be the stacktrace is a bit different
Comment 25 Kalin KOZHUHAROV 2014-08-18 07:08:29 UTC
OK, I did some more rebooting, also with another "similar machine"... but it turned out that it uses different chipset. So here is a summary:

Hardware that exhibits this bug (relevant parts from dmesg, lscpi):
===================================================================
DMI: TOSHIBA dynabook R731/W2UB/Portable PC, BIOS Version 3.90   07/31/2012
smpboot: CPU0: Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz (fam: 06, model: 2a, stepping: 07)

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Toshiba America Info Systems Device 0005
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 56
	Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
	Region 2: Memory at b0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at 3000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
		Address: fee0f00c  Data: 4123
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [a4] PCI Advanced Features
		AFCap: TP+ FLR+
		AFCtrl: FLR-
		AFStatus: TP-
	Kernel driver in use: i915
	Kernel modules: i915


Hardware that is fine (relevant parts from dmesg, lscpi):
===================================================================
DMI: TOSHIBA dynabook R732/W3UG/dynabook R732/W3UG, BIOS Version 6.70   04/04/2013
e
smpboot: CPU0: Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz (fam: 06, model: 3a, stepping: 09)

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Toshiba America Info Systems Device 0003
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 52
	Region 0: Memory at e0000000 (64-bit, non-prefetchable) [size=4M]
	Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at 3000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
		Address: fee0f00c  Data: 41b2
	Capabilities: [d0] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [a4] PCI Advanced Features
		AFCap: TP+ FLR+
		AFCtrl: FLR-
		AFStatus: TP-
	Kernel driver in use: i915
	Kernel modules: i915


How to reproduce:

Plug HDMI monitor (SyncMaster SA850) into laptop directly or via docking station (two different models tested, same error). {At home, plugging another monitor via HDMI->DVI cable did not produce error :-|) and boot.

If booted without ext. monitor, then plugging/unplugging is fine and works (after xrandr/arandr invocation); the ext monitor is not enabled automatically on `startx`, but this may be normal (WindowMaker-based bare config).

After a lot of plug/replug I saw the following in dmesg, may be related (but the "--[ cut here ]--" shows ONLY on boot, once, about 3s after power-on.

2014-08-18T15:39:32+09:00 10.81.3.102  {} (kern.warning) [kernel] [  207.025362] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
2014-08-18T15:39:32+09:00 10.81.3.102  {} (kern.info) [kernel] [  207.025384] pci 0000:00:1c.6: PCI bridge to [bus 07]
2014-08-18T15:39:32+09:00 10.81.3.102  {} (kern.warning) [kernel] [  207.025425] pci 0000:00:00.0: no hotplug settings from platform
2014-08-18T15:39:32+09:00 10.81.3.102  {} (kern.info) [kernel] [  207.025430] pci 0000:00:00.0: using default PCI settings
2014-08-18T15:39:32+09:00 10.81.3.102  {} (kern.warning) [kernel] [  207.025443] i915 0000:00:02.0: no hotplug settings from platform
2014-08-18T15:39:32+09:00 10.81.3.102  {} (kern.info) [kernel] [  207.025448] i915 0000:00:02.0: using default PCI settings


Finally, I guess this kind of sheds more light (new in the 3.16.1 dmesg output, see attachment 146991 [details] for full):

[    2.118539] [drm] GMBUS [i915 gmbus panel] timed out, falling back to bit banging on pin 3
[    2.130733] [drm] Wrong MCH_SSKPD value: 0x16040307
[    2.130735] [drm] This can cause pipe underruns and display issues.
[    2.130736] [drm] Please upgrade your BIOS to fix this.

unfortunately current BIOS ("Version 3.90   07/31/2012") is the latest and that model is no longer supported.
Comment 26 Kalin KOZHUHAROV 2014-08-18 07:24:31 UTC
(sorry for the micro updates!)

Forgot to give chipset details (from dmesg):

(failing) R731 is SandyBridge
=================================
smpboot: CPU0: Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz (fam: 06, model: 2a, stepping: 07)
Performance Events: PEBS fmt1+, 16-deep LBR, SandyBridge events, full-width counters, Intel PMU driver.
perf_event_intel: PEBS disabled due to CPU errata, please upgrade microcode

(fine) R732 is IvyBridge
=================================
smpboot: CPU0: Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz (fam: 06, model: 3a, stepping: 09)
TSC deadline timer enabled
Performance Events: PEBS fmt1+, 16-deep LBR, IvyBridge events, full-width counters, Intel PMU driver.

I'll update microcode and see if that makes any difference...
Comment 27 Kalin KOZHUHAROV 2014-08-18 07:55:45 UTC
... it did :-( Microcode update to the latest was not good.

Ethernet broke (Hardware error) and there were a bunch of other error/warnings. Plus, at boot the microcode update is after i915 gets initialized and throws the error, so that is a dead end now.
Comment 28 Ville Syrjala 2014-08-26 13:13:55 UTC
Please test this patch http://patchwork.freedesktop.org/patch/32012/
Comment 29 Kalin KOZHUHAROV 2014-08-27 06:53:22 UTC
I did test the patch from comment #28, but the trace at boot looks similar:

[    2.823851] ------------[ cut here ]------------
[    2.823921] WARNING: CPU: 0 PID: 1353 at drivers/gpu/drm/i915/intel_display.c:953 intel_wait_for_pipe_off+0x172/0x17b [i915]()
[    2.823923] pipe_off wait timed out
[    2.823975] Modules linked in: fbcon(+) bitblit softcursor font snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic arc4 iwldvm mac80211 joydev i915 i2c_algo_bit drm_kms_helper drm intel_gtt iwlwifi sr_mod agpgart snd_hda_intel sdhci_pci e1000e toshiba_acpi xhci_hcd sparse_keymap sdhci cdrom snd_hda_controller ehci_pci cfg80211 ehci_hcd usbcore mmc_core rfkill snd_hda_codec usb_common led_class video snd_hwdep snd_pcm wmi ptp snd_timer toshiba_bluetooth snd pps_core
[    2.823981] CPU: 0 PID: 1353 Comm: modprobe Not tainted 3.16.1-r1 #1
[    2.823984] Hardware name: TOSHIBA dynabook R731/W2UB/Portable PC, BIOS Version 3.90   07/31/2012
[    2.823990]  0000000000000009 ffff8802423e37e8 ffffffff81491f0f 0000000000000d0d
[    2.823994]  ffff8802423e3838 ffff8802423e3828 ffffffff81063fb1 0000000000000000
[    2.823998]  ffffffffa042ce4e ffff880240400000 0000000000070008 00000000fffb771a
[    2.824000] Call Trace:
[    2.824010]  [<ffffffff81491f0f>] dump_stack+0x46/0x58
[    2.824019]  [<ffffffff81063fb1>] warn_slowpath_common+0x7c/0x96
[    2.824067]  [<ffffffffa042ce4e>] ? intel_wait_for_pipe_off+0x172/0x17b [i915]
[    2.824072]  [<ffffffff8106405f>] warn_slowpath_fmt+0x41/0x43
[    2.824111]  [<ffffffffa042ce4e>] intel_wait_for_pipe_off+0x172/0x17b [i915]
[    2.824146]  [<ffffffffa042cef2>] intel_disable_pipe+0x9b/0xa4 [i915]
[    2.824184]  [<ffffffffa0432666>] ironlake_crtc_disable+0x5d/0x83b [i915]
[    2.824217]  [<ffffffffa04271b8>] ? intel_dump_pipe_config+0x181/0x311 [i915]
[    2.824265]  [<ffffffffa04542b8>] ? intel_lvds_compute_config+0xfd/0x122 [i915]
[    2.824305]  [<ffffffffa04348d8>] __intel_set_mode+0xd43/0x11dd [i915]
[    2.824345]  [<ffffffffa0436c19>] intel_set_mode+0x11/0x2a [i915]
[    2.824381]  [<ffffffffa043785d>] intel_crtc_set_config+0x710/0xa0f [i915]
[    2.824415]  [<ffffffffa042777c>] ? intel_crtc_update_cursor+0x358/0x36e [i915]
[    2.824451]  [<ffffffffa038e822>] drm_mode_set_config_internal+0x4e/0xba [drm]
[    2.824463]  [<ffffffffa03d9131>] restore_fbdev_mode+0x97/0xb5 [drm_kms_helper]
[    2.824472]  [<ffffffffa03d9201>] drm_fb_helper_restore_fbdev_mode_unlocked+0x22/0x37 [drm_kms_helper]
[    2.824482]  [<ffffffffa03da411>] drm_fb_helper_set_par+0x3f/0x5f [drm_kms_helper]
[    2.824491]  [<ffffffffa00a4dd2>] fbcon_init+0x303/0x3f2 [fbcon]
[    2.824498]  [<ffffffff813156b6>] visual_init+0xb8/0x10e
[    2.824503]  [<ffffffff81316f16>] do_bind_con_driver+0x1af/0x2d6
[    2.824508]  [<ffffffff81317179>] do_take_over_console+0x13c/0x16c
[    2.824516]  [<ffffffffa00a32f1>] do_fbcon_takeover+0x4a/0x80 [fbcon]
[    2.824523]  [<ffffffffa0078107>] fb_console_init+0x107/0x113 [fbcon]
[    2.824529]  [<ffffffffa0078000>] ? 0xffffffffa0077fff
[    2.824533]  [<ffffffffa0078000>] ? 0xffffffffa0077fff
[    2.824540]  [<ffffffff8100030e>] do_one_initcall+0xea/0x184
[    2.824545]  [<ffffffff811259c0>] ? __vunmap+0x91/0xb8
[    2.824553]  [<ffffffff810bc54e>] load_module+0x19e3/0x1cdd
[    2.824559]  [<ffffffff810b9e5f>] ? module_unload_free+0xd2/0xd2
[    2.824567]  [<ffffffff81498be2>] ? page_fault+0x22/0x30
[    2.824574]  [<ffffffff810bc8dc>] SyS_init_module+0x94/0xa1
[    2.824581]  [<ffffffff814971d2>] system_call_fastpath+0x16/0x1b
[    2.824585] ---[ end trace 115b23325c1ae553 ]---
Comment 30 Daniel Vetter 2014-11-21 07:59:20 UTC
Presumably fixed in 3.18-rc with

commit 08aff3fe26ae7a0d6f302ac2e1b7e2eb9933cd42
Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
Date:   Mon Aug 18 22:16:09 2014 +0300

    drm/i915: Move DP port disable to post_disable for pch platforms

Thanks for the report and please reopen if that's not the case.
Comment 31 Gary 2014-11-21 08:01:16 UTC
Dear Sender,

I will attend a series of whole day training from 11/17 to 11/21. and the mail are expected to be delay.
You could reach me by my cellula if necessary.

Thanks for your understanding.
Comment 32 Kalin KOZHUHAROV 2014-11-26 05:34:35 UTC
I retested this on my R731 dynabook, still get similar error with fresh 3.18.0-rc6 :-(
As far as I could confirm the patch in comment #30 is included.

[    2.814376] ------------[ cut here ]------------
[    2.814456] WARNING: CPU: 2 PID: 1370 at drivers/gpu/drm/i915/intel_display.c:994 intel_disable_pipe+0x21d/0x229 [i915]()
[    2.814458] pipe_off wait timed out
[    2.814508] Modules linked in: fbcon(+) bitblit softcursor font snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic arc4 iwldvm mac80211 joydev i915 i2c_algo_bit drm_kms_helper snd_hda_intel iwlwifi drm snd_hda_controller sr_mod sdhci_pci cfg80211 snd_hda_codec intel_gtt sdhci ehci_pci ehci_hcd e1000e agpgart cdrom xhci_pci mmc_core xhci_hcd snd_hwdep toshiba_haps usbcore snd_pcm toshiba_acpi usb_common sparse_keymap video rfkill wmi toshiba_bluetooth led_class ptp pps_core snd_timer snd
[    2.814514] CPU: 2 PID: 1370 Comm: modprobe Not tainted 3.18.0-rc6-r1 #1
[    2.814517] Hardware name: TOSHIBA dynabook R731/W2UB/Portable PC, BIOS Version 3.90   07/31/2012
[    2.814523]  0000000000000009 ffff8802411ff828 ffffffff8149ba3a 000000000000fafa
[    2.814526]  ffff8802411ff878 ffff8802411ff868 ffffffff81067ac7 0000000000000000
[    2.814530]  ffffffffa0432f60 ffff8802403d0000 0000000000070008 00000000fffb770d
[    2.814532] Call Trace:
[    2.814544]  [<ffffffff8149ba3a>] dump_stack+0x46/0x58
[    2.814553]  [<ffffffff81067ac7>] warn_slowpath_common+0x7c/0x96
[    2.814608]  [<ffffffffa0432f60>] ? intel_disable_pipe+0x21d/0x229 [i915]
[    2.814614]  [<ffffffff81067b22>] warn_slowpath_fmt+0x41/0x43
[    2.814663]  [<ffffffffa0432f60>] intel_disable_pipe+0x21d/0x229 [i915]
[    2.814714]  [<ffffffffa043d3b6>] ironlake_crtc_disable+0x8f/0x712 [i915]
[    2.814759]  [<ffffffffa042fcf9>] ? intel_dump_pipe_config+0x1cd/0x35d [i915]
[    2.814815]  [<ffffffffa045df59>] ? intel_lvds_compute_config+0xe8/0x10d [i915]
[    2.814865]  [<ffffffffa0438219>] __intel_set_mode+0x8a9/0x122e [i915]
[    2.814914]  [<ffffffffa043ef13>] intel_set_mode+0x11/0x2a [i915]
[    2.814960]  [<ffffffffa043fdab>] intel_crtc_set_config+0x99f/0xa82 [i915]
[    2.815001]  [<ffffffffa03527c4>] drm_mode_set_config_internal+0x4e/0xcb [drm]
[    2.815017]  [<ffffffffa03d4e17>] restore_fbdev_mode+0xb5/0xce [drm_kms_helper]
[    2.815029]  [<ffffffffa03d4e52>] drm_fb_helper_restore_fbdev_mode_unlocked+0x22/0x37 [drm_kms_helper]
[    2.815041]  [<ffffffffa03d6359>] drm_fb_helper_set_par+0x3f/0x5f [drm_kms_helper]
[    2.815091]  [<ffffffffa0448e0d>] intel_fbdev_set_par+0x15/0x58 [i915]
[    2.815102]  [<ffffffffa00d5d84>] fbcon_init+0x2fe/0x3ed [fbcon]
[    2.815108]  [<ffffffff8131b00d>] visual_init+0xb7/0x10d
[    2.815113]  [<ffffffff8131c830>] do_bind_con_driver+0x1ab/0x2cd
[    2.815118]  [<ffffffff8131ce11>] do_take_over_console+0x132/0x162
[    2.815125]  [<ffffffffa00d42f6>] do_fbcon_takeover+0x4a/0x82 [fbcon]
[    2.815133]  [<ffffffffa00dd10a>] fb_console_init+0x10a/0x116 [fbcon]
[    2.815139]  [<ffffffffa00dd000>] ? 0xffffffffa00dd000
[    2.815147]  [<ffffffff8100030e>] do_one_initcall+0xea/0x170
[    2.815155]  [<ffffffff8112ad13>] ? __vunmap+0xa7/0xae
[    2.815162]  [<ffffffff810c0219>] load_module+0x1620/0x1c79
[    2.815166]  [<ffffffff810bda47>] ? store_uevent+0x39/0x39
[    2.815174]  [<ffffffff814a2102>] ? page_fault+0x22/0x30
[    2.815179]  [<ffffffff810c0904>] SyS_init_module+0x92/0x9f
[    2.815184]  [<ffffffff814a0792>] system_call_fastpath+0x12/0x17
[    2.815188] ---[ end trace 38ffd124b325b690 ]---
Comment 33 Adam Williamson 2014-11-26 07:20:07 UTC
You have an ironlake, not a sandybridge, and the traceback is not the same.
Comment 34 Daniel Vetter 2014-11-26 08:19:53 UTC
Yup, please file a new bug for this one. Or sign up on Bug 62251

Note You need to log in before you can comment on or make changes to this bug.