Bug 51721 - kernel panic when switching from battery to AC power supply
kernel panic when switching from battery to AC power supply
Status: CLOSED DUPLICATE of bug 51661
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: acpi_power-battery
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-14 09:30 UTC by wander.homer
Modified: 2013-01-28 23:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.7.0
Tree: Mainline
Regression: No


Attachments
dmesg.log (61.30 KB, application/octet-stream)
2012-12-14 09:31 UTC, wander.homer
Details
uname -a (89 bytes, text/plain)
2012-12-14 09:32 UTC, wander.homer
Details
kernel dump (sorry bad quality) (431.47 KB, application/octet-stream)
2012-12-14 09:32 UTC, wander.homer
Details

Description wander.homer 2012-12-14 09:30:03 UTC
Steps to reproduce:

- boot notebook to gui or console
- if attached to AC power supply -> detach to run on battery
- (re)connect to AC power supply -> kernel panic

Older kernels (<= 3.6.*) work just fine. 

kernel dump doesn't tell me anything so I'm not sure which component is causing this issue.
Comment 1 wander.homer 2012-12-14 09:31:08 UTC
Created attachment 89201 [details]
dmesg.log
Comment 2 wander.homer 2012-12-14 09:32:00 UTC
Created attachment 89221 [details]
uname -a
Comment 3 wander.homer 2012-12-14 09:32:46 UTC
Created attachment 89231 [details]
kernel dump (sorry bad quality)
Comment 4 wander.homer 2012-12-14 09:37:39 UTC
Same issue:

https://bugzilla.kernel.org/show_bug.cgi?id=51721
Comment 5 wander.homer 2012-12-15 14:12:08 UTC

*** This bug has been marked as a duplicate of bug 51661 ***

Note You need to log in before you can comment on or make changes to this bug.