Bug 51671 - ALX driver unusable on new kernel
ALX driver unusable on new kernel
Status: CLOSED CODE_FIX
Product: Backports project
Classification: Unclassified
Component: Backports
All Linux
: P1 high
Assigned To: Backports Project Mailing List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 05:54 UTC by Hexchain Tong
Modified: 2013-07-30 14:10 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.7.0
Tree: Mainline
Regression: No


Attachments

Description Hexchain Tong 2012-12-13 05:54:04 UTC
After upgraded to kernel 3.7, the ALX driver in compat-drivers nolonger functions. Building is successful, but it is unable to load.

dmesg before kernel update, using compat-wireless 20121003:
Dec 12 12:12:09 lightning.hexchain.org kernel: alx 0000:03:00.0: DMA to 64-BIT addresses
Dec 12 12:12:09 lightning.hexchain.org kernel: alx 0000:03:00.0: (unregistered net_device): HW Flags = 0x415
Dec 12 12:12:09 lightning.hexchain.org kernel: alx 0000:03:00.0: (unregistered net_device): reset PHY, pws = 1, az = 0, ptp = 0
Dec 12 12:12:09 lightning.hexchain.org kernel: alx 0000:03:00.0: (unregistered net_device): speed = 0x2f, autoneg = 1
Dec 12 12:12:09 lightning.hexchain.org kernel: alx 0000:03:00.0: irq 45 for MSI/MSI-X
Dec 12 12:12:09 lightning.hexchain.org kernel: alx: Atheros Gigabit Network Connection

After kernel update, any version of compat-driver before 20121204 fails to build.
dmesg after kernel update, using the newest compat-driver-u:
Dec 12 22:31:21 lightning.hexchain.org kernel: alx 0000:03:00.0: DMA to 64-BIT addresses
Dec 12 22:31:21 lightning.hexchain.org kernel: alx 0000:03:00.0: config PHY speed/duplex failed,err=4
Dec 12 22:31:21 lightning.hexchain.org kernel: alx 0000:03:00.0: error when probe device, error = -5
Dec 12 22:31:21 lightning.hexchain.org kernel: alx: probe of 0000:03:00.0 failed with error -5
Comment 1 Luis R. Rodriguez 2012-12-14 18:53:47 UTC
Can you post the output of dmesg ?
Comment 2 QCA Ethernet team 2012-12-14 20:51:23 UTC
compat-driver of 20121204, just pass compiler, all of tx/rx function is abnormal, we are debugging it internally.
Comment 3 Hexchain Tong 2012-12-16 12:16:38 UTC
(In reply to comment #1)
> Can you post the output of dmesg ?

I think it is in the first post. I'm using systemd and the log was grep'd from systemd journal, so it may look a bit strange.

(In reply to comment #2)
> compat-driver of 20121204, just pass compiler, all of tx/rx function is
> abnormal, we are debugging it internally.

So, there's no way to use this driver with 3.7 kernel?
Comment 4 Oleksandr Natalenko 2012-12-16 13:49:05 UTC
In rare cases alx fails with similar symptoms on 3.6 kernels. But it happens rarely enough.
Comment 5 QCA Ethernet team 2012-12-17 03:19:17 UTC
(In reply to comment #3)
> 
> (In reply to comment #2)
> > compat-driver of 20121204, just pass compiler, all of tx/rx function is
> > abnormal, we are debugging it internally.
> 
> So, there's no way to use this driver with 3.7 kernel?

yes, but we'll publish a real usable one soon.
Comment 6 Oleksandr Natalenko 2012-12-19 22:08:08 UTC
I have to say that compat-wireless-2012-09-27-pc.tar.bz2 works with 3.6.11. But I haven't tested it with 3.7.
Comment 8 Hexchain Tong 2012-12-20 06:35:52 UTC
(In reply to comment #7)
> Try this guy:
> 
> http://www.kernel.org/pub/linux/kernel/projects/backports/2012/12/19/compat-drivers-2012-12-19-u.tar.bz2

I've successfully installed this driver on 3.7.1-1-ARCH. Works well so far.

$ dmesg | grep 03:00.0
[    0.462070] pci 0000:03:00.0: [1969:1091] type 00 class 0x020000
[    0.462100] pci 0000:03:00.0: reg 10: [mem 0xf1400000-0xf143ffff 64bit]
[    0.462115] pci 0000:03:00.0: reg 18: [io  0x2000-0x207f]
[    0.462250] pci 0000:03:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[  274.912505] alx 0000:03:00.0: alx(5c:f9:dd:41:1d:0a): Qualcomm Atheros Ethernet Network Connection
[  274.923191] alx 0000:03:00.0: irq 47 for MSI/MSI-X
[  274.923196] alx 0000:03:00.0: irq 48 for MSI/MSI-X
[  274.923200] alx 0000:03:00.0: irq 49 for MSI/MSI-X
[  274.923203] alx 0000:03:00.0: irq 50 for MSI/MSI-X
[  274.923206] alx 0000:03:00.0: irq 51 for MSI/MSI-X
[  274.923209] alx 0000:03:00.0: irq 52 for MSI/MSI-X
[  274.923213] alx 0000:03:00.0: irq 53 for MSI/MSI-X
[  274.923216] alx 0000:03:00.0: irq 54 for MSI/MSI-X
[  274.923249] alx 0000:03:00.0: irq 55 for MSI/MSI-X
[  276.549546] alx 0000:03:00.0 eth0: NIC Link Up: 100 Mbps Full
Comment 9 Oleksandr Natalenko 2012-12-20 08:28:16 UTC
Fixed with 3.6.11, thanks, guys.

===
[ 9135.574895] Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver
[ 9135.585114] alx 0000:02:00.0: alx(84:8f:69:d3:a6:09): Qualcomm Atheros Ethernet Network Connection
[ 9156.532616] alx 0000:02:00.0: irq 45 for MSI/MSI-X
[ 9156.532641] alx 0000:02:00.0: irq 46 for MSI/MSI-X
[ 9156.532655] alx 0000:02:00.0: irq 47 for MSI/MSI-X
[ 9156.532671] alx 0000:02:00.0: irq 48 for MSI/MSI-X
[ 9156.532683] alx 0000:02:00.0: irq 49 for MSI/MSI-X
[ 9156.534190] alx 0000:02:00.0: eth0: NIC Link Up: 1 Gbps Full
===
Comment 10 mp-001 2013-02-21 07:48:40 UTC
Im on fedora 18 running on asus n76vm. Since upgraded from fedora 17 alx will crash when the interface comes up. When running the f17 kernel i've kept (vmlinuz-3.6.11-1.fc17.x86_64), alx is quite usable.


wget http://www.kernel.org/pub/linux/kernel/projects/backports/2013/02/20/compat-drivers-2013-02-20-u.tar.bz2
tar -xf compat-drivers-2013-02-20-u.tar.bz2
cd compat-drivers-2013-02-20-u
./scripts/driver-select alx
sudo make install
sudo modprobe alx

===
Feb 21 08:16:46 N38 kernel: [36872.286081] Disabling lock debugging due to kernel taint
Feb 21 08:16:46 N38 kernel: [36872.286499] Compat-drivers backport release: compat-drivers-2013-02-20-u
Feb 21 08:16:46 N38 kernel: [36872.286500] Backport based on linux-next.git next-20130220
Feb 21 08:16:46 N38 kernel: [36872.286501] compat.git: linux-next.git
Feb 21 08:16:46 N38 kernel: [36872.288050] Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver
Feb 21 08:16:46 N38 kernel: [36872.290175] alx 0000:04:00.0: alx(30:85:a9:01:9b:01): Qualcomm Atheros Ethernet Network Connection
Feb 21 08:16:46 N38 systemd-udevd[427]: specified group 'input' unknown
Feb 21 08:16:46 N38 NetworkManager[889]: <warn> failed to allocate link cache: (-10) Operation not supported
Feb 21 08:16:46 N38 NetworkManager[889]: <info> (p3p1): carrier is OFF
Feb 21 08:16:46 N38 NetworkManager[889]: <info> (p3p1): new Ethernet device (driver: 'alx' ifindex: 9)
Feb 21 08:16:46 N38 kernel: [36872.372088] IPv6: ADDRCONF(NETDEV_UP): p3p1: link is not ready
Feb 21 08:16:46 N38 NetworkManager[889]: <info> (p3p1): exported as /org/freedesktop/NetworkManager/Devices/1
Feb 21 08:16:46 N38 NetworkManager[889]: <info> (p3p1): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Feb 21 08:16:46 N38 NetworkManager[889]: <info> (p3p1): bringing up device.
Feb 21 08:16:46 N38 NetworkManager[889]: <info> (p3p1): preparing device.
Feb 21 08:16:46 N38 NetworkManager[889]: <info> (p3p1): deactivating device (reason 'managed') [2]
===

Since the driver does not detect a link, i restart NetworkManager:

service NetworkManager restart

Then it crashes:

===
...
Feb 21 08:18:12 N38 kernel: [36957.690744] ------------[ cut here ]------------
Feb 21 08:18:12 N38 kernel: [36957.690761] WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0x238/0x250()
Feb 21 08:18:12 N38 kernel: [36957.690764] Hardware name: N76VM
Feb 21 08:18:12 N38 kernel: [36957.690767] NETDEV WATCHDOG: p3p1 (alx): transmit queue 3 timed out
Feb 21 08:18:12 N38 kernel: [36957.690769] Modules linked in: alx(OF) compat(OF) usb_storage dm_crypt tcp_lp fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat xt_CHECKSUM iptable_mangle bridge stp llc lockd sunrpc rfcomm bnep be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ip6t_REJECT ib_addr nf_conntrack_ipv4 nf_conntrack_ipv6 iw_cm nf_defrag_ipv4 nf_defrag_ipv6 ib_cm ib_sa ib_mad xt_conntrack nf_conntrack ib_core iscsi_tcp ip6table_filter libiscsi_tcp libiscsi ip6_tables scsi_transport_iscsi binfmt_misc snd_hda_codec_realtek arc4 snd_hda_intel snd_hda_codec iTCO_wdt asus_nb_wmi asus_wmi iTCO_vendor_support snd_hwdep sparse_keymap uvcvideo snd_seq videobuf2_vmalloc snd_seq_device iwldvm videobuf2_memops videobuf2_core snd_pcm videodev vhost_net btusb mac80211 media tun bluetooth macvtap macvlan coretemp kvm_intel kvm iwlwifi snd_page_alloc uinput cfg80211 snd_timer snd lpc_ich joydev rfkill soundcore mei microcode i2c_i801 serio_raw mfd_core nouveau crc32c_intel i915 i2c_algo_bit ttm drm_kms_helper ghash_clmulni_intel drm mxm_wmi i2c_core wmi video
Feb 21 08:18:12 N38 kernel: [36957.690878] Pid: 0, comm: swapper/0 Tainted: GF          O 3.7.8-202.fc18.x86_64 #1
Feb 21 08:18:12 N38 kernel: [36957.690880] Call Trace:
Feb 21 08:18:12 N38 kernel: [36957.690883]  <IRQ>  [<ffffffff8105e6df>] warn_slowpath_common+0x7f/0xc0
Feb 21 08:18:12 N38 kernel: [36957.690897]  [<ffffffff8105e7d6>] warn_slowpath_fmt+0x46/0x50
Feb 21 08:18:12 N38 kernel: [36957.690904]  [<ffffffff81096365>] ? sched_clock_cpu+0xc5/0x120
Feb 21 08:18:12 N38 kernel: [36957.690910]  [<ffffffff815456c8>] dev_watchdog+0x238/0x250
Feb 21 08:18:12 N38 kernel: [36957.690914]  [<ffffffff81545490>] ? dev_deactivate_queue.constprop.30+0x80/0x80
Feb 21 08:18:12 N38 kernel: [36957.690921]  [<ffffffff8106d3ea>] call_timer_fn+0x3a/0x120
Feb 21 08:18:12 N38 kernel: [36957.690926]  [<ffffffff81092ac9>] ? scheduler_tick+0x109/0x140
Feb 21 08:18:12 N38 kernel: [36957.690930]  [<ffffffff81545490>] ? dev_deactivate_queue.constprop.30+0x80/0x80
Feb 21 08:18:12 N38 kernel: [36957.690937]  [<ffffffff8106f17e>] run_timer_softirq+0x1fe/0x2b0
Feb 21 08:18:12 N38 kernel: [36957.690942]  [<ffffffff81067060>] __do_softirq+0xd0/0x210
Feb 21 08:18:12 N38 kernel: [36957.690948]  [<ffffffff8101b903>] ? native_sched_clock+0x13/0x80
Feb 21 08:18:12 N38 kernel: [36957.690954]  [<ffffffff81640b9c>] call_softirq+0x1c/0x30
Feb 21 08:18:12 N38 kernel: [36957.690961]  [<ffffffff81016315>] do_softirq+0x75/0xb0
Feb 21 08:18:12 N38 kernel: [36957.690965]  [<ffffffff81067335>] irq_exit+0xb5/0xc0
Feb 21 08:18:12 N38 kernel: [36957.690969]  [<ffffffff8164152e>] smp_apic_timer_interrupt+0x6e/0x99
Feb 21 08:18:12 N38 kernel: [36957.690976]  [<ffffffff8164045d>] apic_timer_interrupt+0x6d/0x80
Feb 21 08:18:12 N38 kernel: [36957.690978]  <EOI>  [<ffffffff81346c50>] ? intel_idle+0xf0/0x150
Feb 21 08:18:12 N38 kernel: [36957.690988]  [<ffffffff81346c2e>] ? intel_idle+0xce/0x150
Feb 21 08:18:12 N38 kernel: [36957.690996]  [<ffffffff814df899>] cpuidle_enter+0x19/0x20
Feb 21 08:18:12 N38 kernel: [36957.691001]  [<ffffffff814dff29>] cpuidle_idle_call+0xa9/0x260
Feb 21 08:18:12 N38 kernel: [36957.691006]  [<ffffffff8101d4af>] cpu_idle+0xaf/0x120
Feb 21 08:18:12 N38 kernel: [36957.691013]  [<ffffffff816139c2>] rest_init+0x72/0x80
Feb 21 08:18:12 N38 kernel: [36957.691021]  [<ffffffff81cfbc44>] start_kernel+0x3d1/0x3de
Feb 21 08:18:12 N38 kernel: [36957.691026]  [<ffffffff81cfb672>] ? repair_env_string+0x5e/0x5e
Feb 21 08:18:12 N38 kernel: [36957.691032]  [<ffffffff81cfb356>] x86_64_start_reservations+0x131/0x135
Feb 21 08:18:12 N38 kernel: [36957.691037]  [<ffffffff81cfb45a>] x86_64_start_kernel+0x100/0x10f
Feb 21 08:18:12 N38 kernel: [36957.691040] ---[ end trace aea5f9c812fd911f ]---
Feb 21 08:18:12 N38 kernel: [36957.691046] alx 0000:04:00.0 p3p1: -----------------TPD-ring(0)------------------
Feb 21 08:18:12 N38 kernel: [36957.691052] alx 0000:04:00.0 p3p1: F8: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691056] alx 0000:04:00.0 p3p1: F9: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691059] alx 0000:04:00.0 p3p1: FA: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691062] alx 0000:04:00.0 p3p1: FB: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691065] alx 0000:04:00.0 p3p1: FC: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691069] alx 0000:04:00.0 p3p1: FD: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691072] alx 0000:04:00.0 p3p1: FE: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691075] alx 0000:04:00.0 p3p1: FF: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691078] alx 0000:04:00.0 p3p1: 0: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691081] alx 0000:04:00.0 p3p1: 1: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691084] alx 0000:04:00.0 p3p1: 2: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691088] alx 0000:04:00.0 p3p1: 3: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691091] alx 0000:04:00.0 p3p1: -----------------TPD-ring(1)------------------
Feb 21 08:18:12 N38 kernel: [36957.691094] alx 0000:04:00.0 p3p1: F8: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691097] alx 0000:04:00.0 p3p1: F9: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691100] alx 0000:04:00.0 p3p1: FA: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691103] alx 0000:04:00.0 p3p1: FB: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691106] alx 0000:04:00.0 p3p1: FC: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691110] alx 0000:04:00.0 p3p1: FD: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691113] alx 0000:04:00.0 p3p1: FE: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691116] alx 0000:04:00.0 p3p1: FF: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691119] alx 0000:04:00.0 p3p1: 0: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691122] alx 0000:04:00.0 p3p1: 1: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691125] alx 0000:04:00.0 p3p1: 2: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691129] alx 0000:04:00.0 p3p1: 3: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691132] alx 0000:04:00.0 p3p1: -----------------TPD-ring(2)------------------
Feb 21 08:18:12 N38 kernel: [36957.691135] alx 0000:04:00.0 p3p1: F8: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691138] alx 0000:04:00.0 p3p1: F9: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691141] alx 0000:04:00.0 p3p1: FA: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691144] alx 0000:04:00.0 p3p1: FB: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691147] alx 0000:04:00.0 p3p1: FC: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691150] alx 0000:04:00.0 p3p1: FD: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691154] alx 0000:04:00.0 p3p1: FE: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691157] alx 0000:04:00.0 p3p1: FF: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691161] alx 0000:04:00.0 p3p1: 0: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691164] alx 0000:04:00.0 p3p1: 1: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691168] alx 0000:04:00.0 p3p1: 2: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691171] alx 0000:04:00.0 p3p1: 3: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691174] alx 0000:04:00.0 p3p1: -----------------TPD-ring(3)------------------
Feb 21 08:18:12 N38 kernel: [36957.691177] alx 0000:04:00.0 p3p1: F9: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691181] alx 0000:04:00.0 p3p1: FA: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691184] alx 0000:04:00.0 p3p1: FB: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691187] alx 0000:04:00.0 p3p1: FC: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691190] alx 0000:04:00.0 p3p1: FD: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691193] alx 0000:04:00.0 p3p1: FE: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691196] alx 0000:04:00.0 p3p1: FF: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691200] alx 0000:04:00.0 p3p1: 0: W0=0000005A, W1=80000000, W2=35EFF002
Feb 21 08:18:12 N38 kernel: [36957.691203] alx 0000:04:00.0 p3p1: 1: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691206] alx 0000:04:00.0 p3p1: 2: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691209] alx 0000:04:00.0 p3p1: 3: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691212] alx 0000:04:00.0 p3p1: 4: W0=00000000, W1=00000000, W2=0
Feb 21 08:18:12 N38 kernel: [36957.691215] alx 0000:04:00.0 p3p1: ---------------dump registers-----------------
Feb 21 08:18:12 N38 kernel: [36957.691227] alx 0000:04:00.0 p3p1: 1400: C0020CE0,00000000,00000064,00001C01
Feb 21 08:18:12 N38 kernel: [36957.691237] alx 0000:04:00.0 p3p1: 1410: 00002214,474019AA,03FE003E,00000000
Feb 21 08:18:12 N38 kernel: [36957.691248] alx 0000:04:00.0 p3p1: 1420: 00000000,E03EBB60,00000240,CF01C831
Feb 21 08:18:12 N38 kernel: [36957.691258] alx 0000:04:00.0 p3p1: 1430: 0000CC01,00000000,00000000,00000010
Feb 21 08:18:12 N38 kernel: [36957.691269] alx 0000:04:00.0 p3p1: 1440: 8010020C,00000020,0007801A,00000180
Feb 21 08:18:12 N38 kernel: [36957.691279] alx 0000:04:00.0 p3p1: 1450: 00000000,14700040,00000040,00000000
Feb 21 08:18:12 N38 kernel: [36957.691290] alx 0000:04:00.0 p3p1: 1460: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691300] alx 0000:04:00.0 p3p1: 1470: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691310] alx 0000:04:00.0 p3p1: 1480: 64205CEF,60405060,A9019B01,00003085
Feb 21 08:18:12 N38 kernel: [36957.691321] alx 0000:04:00.0 p3p1: 1490: 80000010,40000000,07A1F037,000005F2
Feb 21 08:18:12 N38 kernel: [36957.691331] alx 0000:04:00.0 p3p1: 14A0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691342] alx 0000:04:00.0 p3p1: 14B0: 3BED200D,14364D17,6A3E67EA,B855AABE
Feb 21 08:18:12 N38 kernel: [36957.691352] alx 0000:04:00.0 p3p1: 14C0: E214AD3D,EA49AF7C,A54F2BEC,2A94B30D
Feb 21 08:18:12 N38 kernel: [36957.691362] alx 0000:04:00.0 p3p1: 14D0: 1805EC6C,E291D73D,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691373] alx 0000:04:00.0 p3p1: 14E0: 1CBEB000,1CBEA000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691383] alx 0000:04:00.0 p3p1: 14F0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691393] alx 0000:04:00.0 p3p1: 1500: 05FF05E0,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691403] alx 0000:04:00.0 p3p1: 1510: 00000020,00000000,0BDF0BC0,00000020
Feb 21 08:18:12 N38 kernel: [36957.691414] alx 0000:04:00.0 p3p1: 1520: 05DF0000,000005E0,0BBF0600,000005C0
Feb 21 08:18:12 N38 kernel: [36957.691424] alx 0000:04:00.0 p3p1: 1530: 06000BE0,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691434] alx 0000:04:00.0 p3p1: 1540: 00000001,00000001,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691446] alx 0000:04:00.0 p3p1: 1550: 1CBEE000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691456] alx 0000:04:00.0 p3p1: 1560: 00000200,000005F8,1CBEC000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691466] alx 0000:04:00.0 p3p1: 1570: 00000000,00000000,00000200,1CBE9000
Feb 21 08:18:12 N38 kernel: [36957.691477] alx 0000:04:00.0 p3p1: 1580: 1CBE8000,00000100,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691487] alx 0000:04:00.0 p3p1: 1590: 020000F5,000008BF,01800080,00000000
Feb 21 08:18:12 N38 kernel: [36957.691498] alx 0000:04:00.0 p3p1: 15A0: AC8080BF,00001210,00C0044E,00000100
Feb 21 08:18:12 N38 kernel: [36957.691508] alx 0000:04:00.0 p3p1: 15B0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691519] alx 0000:04:00.0 p3p1: 15C0: 04047C24,00030D40,00000055,000000C8
Feb 21 08:18:12 N38 kernel: [36957.691529] alx 0000:04:00.0 p3p1: 15D0: 00214321,00000000,00438765,00000000
Feb 21 08:18:12 N38 kernel: [36957.691539] alx 0000:04:00.0 p3p1: 15E0: 000001FF,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691550] alx 0000:04:00.0 p3p1: 15F0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691560] alx 0000:04:00.0 p3p1: 1600: 00201081,7C0F96E7,00004E20,00000000
Feb 21 08:18:12 N38 kernel: [36957.691572] alx 0000:04:00.0 p3p1: 1610: FFFFFFFB,00000000,00000001,00000001
Feb 21 08:18:12 N38 kernel: [36957.691582] alx 0000:04:00.0 p3p1: 1620: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691592] alx 0000:04:00.0 p3p1: 1630: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691602] alx 0000:04:00.0 p3p1: 1640: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691612] alx 0000:04:00.0 p3p1: 1650: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691622] alx 0000:04:00.0 p3p1: 1660: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691633] alx 0000:04:00.0 p3p1: 1670: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691644] alx 0000:04:00.0 p3p1: 1680: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691654] alx 0000:04:00.0 p3p1: 1690: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691664] alx 0000:04:00.0 p3p1: 16A0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691674] alx 0000:04:00.0 p3p1: 16B0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691685] alx 0000:04:00.0 p3p1: 16C0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691695] alx 0000:04:00.0 p3p1: 16D0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691706] alx 0000:04:00.0 p3p1: 16E0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691716] alx 0000:04:00.0 p3p1: 16F0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691746] alx 0000:04:00.0 p3p1: 1700: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691756] alx 0000:04:00.0 p3p1: 1710: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691767] alx 0000:04:00.0 p3p1: 1720: 00000000,00000000,00000001,00000000
Feb 21 08:18:12 N38 kernel: [36957.691778] alx 0000:04:00.0 p3p1: 1730: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691790] alx 0000:04:00.0 p3p1: 1740: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691807] alx 0000:04:00.0 p3p1: 1750: 00000000,00000000,00000000,00000001
Feb 21 08:18:12 N38 kernel: [36957.691819] alx 0000:04:00.0 p3p1: 1760: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691830] alx 0000:04:00.0 p3p1: 1770: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691841] alx 0000:04:00.0 p3p1: 1780: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691852] alx 0000:04:00.0 p3p1: 1790: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691863] alx 0000:04:00.0 p3p1: 17A0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691875] alx 0000:04:00.0 p3p1: 17B0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691887] alx 0000:04:00.0 p3p1: 17C0: 00000000,00000000,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691898] alx 0000:04:00.0 p3p1: 17D0: 00000000,00000001,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691909] alx 0000:04:00.0 p3p1: 17E0: 00000000,0000005A,00000000,00000000
Feb 21 08:18:12 N38 kernel: [36957.691920] alx 0000:04:00.0 p3p1: 17F0: 00000000,00000000,00000000,00000000
===

Have to hard reset the box, can't unload the module.

There are people having related problems: 
https://aur.archlinux.org/packages/dkms-alx/

Any info i can provide?
Comment 11 pru 2013-03-05 19:53:42 UTC
The last working thing on F18 is compat-wireless-3.6.8-1-snpc.tar.bz2 (with compilation fixes), but the compat-drivers-* do not.
Comment 12 mp-001 2013-03-09 22:00:46 UTC
compat-drivers-2013-03-04-u is working on F18 (at least kernel 3.7.9-205 and 3.8.1-201 / Asus N76VM), but after suspend-resume the device is gone (`sudo rmmod alx; sudo modprobe alx` is fixing this).
Comment 13 QCA Ethernet team 2013-03-09 22:43:03 UTC
(In reply to comment #12)
> compat-drivers-2013-03-04-u is working on F18 (at least kernel 3.7.9-205 and
> 3.8.1-201 / Asus N76VM), but after suspend-resume the device is gone (`sudo
> rmmod alx; sudo modprobe alx` is fixing this).

could you post the dmesg log ?
Comment 14 mp-001 2013-03-11 20:12:12 UTC
Here dmesg:

### booting ...
[    6.666705] alx 0000:04:00.0: irq 47 for MSI/MSI-X
[    6.666711] alx 0000:04:00.0: irq 48 for MSI/MSI-X
[    6.666714] alx 0000:04:00.0: irq 49 for MSI/MSI-X
[    6.666717] alx 0000:04:00.0: irq 50 for MSI/MSI-X
[    6.666721] alx 0000:04:00.0: irq 51 for MSI/MSI-X
[    6.666724] alx 0000:04:00.0: irq 52 for MSI/MSI-X
[    6.666728] alx 0000:04:00.0: irq 53 for MSI/MSI-X
[    6.666732] alx 0000:04:00.0: irq 54 for MSI/MSI-X
[    6.666735] alx 0000:04:00.0: irq 55 for MSI/MSI-X
[    6.667708] alx 0000:04:00.0 p3p1: NIC Link Up: 1 Gbps Full
[    6.974830] Bridge firewalling registered
[    6.978233] RPC: Registered named UNIX socket transport module.
[    6.978236] RPC: Registered udp transport module.
[    6.978237] RPC: Registered tcp transport module.
[    6.978238] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    7.018578] device virbr0-nic entered promiscuous mode
[    7.130203] virbr0: topology change detected, propagating
[    7.130211] virbr0: port 1(virbr0-nic) entered forwarding state
[    7.130231] virbr0: port 1(virbr0-nic) entered forwarding state
[    7.151878] virbr0: port 1(virbr0-nic) entered disabled state
[    7.173009] systemd-readahead[411]: Failed to read event: Value too large for defined data type
[    7.271444] Ebtables v2.0 registered
[    7.317803] cgroup: libvirtd (1340) created nested cgroup for controller "memory" which has incomplete hierarchy support. Nested cgroups may change behavior in the future.
[    7.317809] cgroup: "memory" requires setting use_hierarchy to 1 on the root.
[    7.317897] cgroup: libvirtd (1340) created nested cgroup for controller "devices" which has incomplete hierarchy support. Nested cgroups may change behavior in the future.
[    7.317994] cgroup: libvirtd (1340) created nested cgroup for controller "blkio" which has incomplete hierarchy support. Nested cgroups may change behavior in the future.
[    8.762277] SELinux: initialized (dev mqueue, type mqueue), uses transition SIDs
[    8.762338] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[    8.780100] SELinux: initialized (dev mqueue, type mqueue), uses transition SIDs
[    8.780563] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[   19.299383] fuse init (API version 7.20)
[   19.304469] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[   19.329191] SELinux: initialized (dev fusectl, type fusectl), uses genfs_contexts


##### Suspend/Resume


[   51.801000] PM: Syncing filesystems ... done.
[   51.802365] PM: Preparing system for mem sleep
[   51.919598] Freezing user space processes ... (elapsed 0.01 seconds) done.
[   51.931307] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
[   51.942323] PM: Entering mem sleep
[   51.942674] Suspending console(s) (use no_console_suspend to debug)
[   51.942920] xhci_hcd 0000:00:14.0: WARN Event TRB for slot 1 ep 0 with no TDs queued?
[   51.942954] sd 1:0:0:0: [sdb] Synchronizing SCSI cache
[   51.942958] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[   51.943089] sd 0:0:0:0: [sda] Stopping disk
[   51.943800] sd 1:0:0:0: [sdb] Stopping disk
[   51.956198] nouveau  [     DRM] suspending fbcon...
[   51.956201] nouveau  [     DRM] suspending display...
[   51.956209] nouveau  [     DRM] unpinning framebuffer(s)...
[   51.956281] nouveau  [     DRM] evicting buffers...
[   51.963344] nouveau  [     DRM] suspending client object trees...
[   52.602795] ACPI: Cannot transition to non-D0 state from D3
[   54.281631] alx 0000:04:00.0 p3p1: wol: ctrl=3, speed=C
[   54.285938] alx 0000:04:00.0: System wakeup enabled by ACPI
[   54.297100] PM: suspend of devices complete after 2355.576 msecs
[   54.297221] PM: late suspend of devices complete after 0.119 msecs
[   54.308033] ehci-pci 0000:00:1d.0: System wakeup enabled by ACPI
[   54.318957] ehci-pci 0000:00:1a.0: System wakeup enabled by ACPI
[   54.340919] xhci_hcd 0000:00:14.0: System wakeup enabled by ACPI
[   54.351908] PM: noirq suspend of devices complete after 54.714 msecs
[   54.352556] ACPI: Preparing to enter system sleep state S3
[   54.434093] PM: Saving platform NVS memory
[   54.487218] Disabling non-boot CPUs ...
[   54.488995] smpboot: CPU 1 is now offline
[   54.489186] CPU 1 offline: Remove Rx thread
[   54.490536] smpboot: CPU 2 is now offline
[   54.490676] CPU 2 offline: Remove Rx thread
[   54.492095] smpboot: CPU 3 is now offline
[   54.492242] CPU 3 offline: Remove Rx thread
[   54.493810] smpboot: CPU 4 is now offline
[   54.494017] CPU 4 offline: Remove Rx thread
[   54.495326] smpboot: CPU 5 is now offline
[   54.495477] CPU 5 offline: Remove Rx thread
[   54.495788] Broke affinity for irq 42
[   54.496805] smpboot: CPU 6 is now offline
[   54.496971] CPU 6 offline: Remove Rx thread
[   54.497277] Broke affinity for irq 23
[   54.497279] Broke affinity for irq 41
[   54.498300] smpboot: CPU 7 is now offline
[   54.498534] CPU 7 offline: Remove Rx thread
[   54.498641] Extended CMOS year: 2000
[   54.499792] ACPI: Low-level resume complete
[   54.499834] PM: Restoring platform NVS memory
[   54.501452] Extended CMOS year: 2000
[   54.502155] microcode: CPU0 updated to revision 0x13, date = 2012-07-16
[   54.502187] Enabling non-boot CPUs ...
[   54.502256] smpboot: Booting Node 0 Processor 1 APIC 0x2
[   54.516592] microcode: CPU1 updated to revision 0x13, date = 2012-07-16
[   54.516596] bnx2i: CPU 1 online: Create Rx thread
[   54.516638] CPU1 is up
[   54.516679] smpboot: Booting Node 0 Processor 2 APIC 0x4
[   54.531035] microcode: CPU2 updated to revision 0x13, date = 2012-07-16
[   54.531039] bnx2i: CPU 2 online: Create Rx thread
[   54.531068] CPU2 is up
[   54.531109] smpboot: Booting Node 0 Processor 3 APIC 0x6
[   54.545475] microcode: CPU3 updated to revision 0x13, date = 2012-07-16
[   54.545480] bnx2i: CPU 3 online: Create Rx thread
[   54.545508] CPU3 is up
[   54.545542] smpboot: Booting Node 0 Processor 4 APIC 0x1
[   54.559845] microcode: CPU4 updated to revision 0x13, date = 2012-07-16
[   54.559849] bnx2i: CPU 4 online: Create Rx thread
[   54.559880] CPU4 is up
[   54.559914] smpboot: Booting Node 0 Processor 5 APIC 0x3
[   54.574260] microcode: CPU5 updated to revision 0x13, date = 2012-07-16
[   54.574264] bnx2i: CPU 5 online: Create Rx thread
[   54.574289] CPU5 is up
[   54.574322] smpboot: Booting Node 0 Processor 6 APIC 0x5
[   54.588624] microcode: CPU6 updated to revision 0x13, date = 2012-07-16
[   54.588633] bnx2i: CPU 6 online: Create Rx thread
[   54.588660] CPU6 is up
[   54.588688] smpboot: Booting Node 0 Processor 7 APIC 0x7
[   54.602966] microcode: CPU7 updated to revision 0x13, date = 2012-07-16
[   54.602969] bnx2i: CPU 7 online: Create Rx thread
[   54.602995] CPU7 is up
[   54.613273] ACPI: Waking up from system sleep state S3
[   54.685567] xhci_hcd 0000:00:14.0: System wakeup disabled by ACPI
[   54.707544] ehci-pci 0000:00:1a.0: System wakeup disabled by ACPI
[   54.729531] ehci-pci 0000:00:1d.0: System wakeup disabled by ACPI
[   54.740565] nouveau 0000:01:00.0: power state changed by ACPI to D0
[   54.773587] PM: noirq resume of devices complete after 109.717 msecs
[   54.773683] PM: early resume of devices complete after 0.074 msecs
[   54.773712] i915 0000:00:02.0: setting latency timer to 64
[   54.773723] xhci_hcd 0000:00:14.0: setting latency timer to 64
[   54.773756] ehci-pci 0000:00:1a.0: setting latency timer to 64
[   54.773768] usb usb1: root hub lost power or was reset
[   54.773770] usb usb3: root hub lost power or was reset
[   54.773772] usb usb4: root hub lost power or was reset
[   54.773793] ahci 0000:00:1f.2: setting latency timer to 64
[   54.773794] nouveau  [     DRM] re-enabling device...
[   54.773811] mei 0000:00:16.0: irq 44 for MSI/MSI-X
[   54.773845] xhci_hcd 0000:00:14.0: Slot 1 endpoint 2 not removed from BW list!
[   54.773851] nouveau  [     DRM] resuming client object trees...
[   54.773856] nouveau  [   VBIOS][0000:01:00.0] running init tables
[   54.773870] alx 0000:04:00.0: System wakeup disabled by ACPI
[   54.773891] snd_hda_intel 0000:00:1b.0: irq 42 for MSI/MSI-X
[   54.773931] ehci-pci 0000:00:1d.0: setting latency timer to 64
[   54.773991] usb usb2: root hub lost power or was reset
[   54.774078] xhci_hcd 0000:00:14.0: irq 46 for MSI/MSI-X
[   54.776668] mei 0000:00:16.0: unexpected reset: dev_state = RESETING
[   54.777665] ehci-pci 0000:00:1a.0: cache line size of 64 is not supported
[   54.777876] ehci-pci 0000:00:1d.0: cache line size of 64 is not supported
[   54.925686] nouveau  [     DRM] resuming display...
[   55.079363] ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[   55.080891] ata3.00: ACPI cmd ef/10:06:00:00:00:a0 (SET FEATURES) succeeded
[   55.080903] ata3.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[   55.081303] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[   55.082027] ata2.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[   55.082111] ata2.00: ACPI cmd ef/10:06:00:00:00:a0 (SET FEATURES) succeeded
[   55.082115] ata2.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[   55.083149] ata2.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[   55.083154] ata3.00: ACPI cmd ef/10:06:00:00:00:a0 (SET FEATURES) succeeded
[   55.083155] ata3.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[   55.083231] ata2.00: ACPI cmd ef/10:06:00:00:00:a0 (SET FEATURES) succeeded
[   55.083235] ata2.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[   55.083509] ata3.00: configured for UDMA/100
[   55.083579] ata2.00: configured for UDMA/133
[   55.083738] sd 1:0:0:0: [sdb] Starting disk
[   55.228348] usb 3-3: reset low-speed USB device number 2 using xhci_hcd
[   55.242226] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff88021ec41840
[   55.242232] usb 3-3: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
[   55.342262] usb 2-1: reset high-speed USB device number 2 using ehci-pci
[   55.558141] usb 1-1: reset high-speed USB device number 2 using ehci-pci
[   55.949055] usb 1-1.1: reset full-speed USB device number 3 using ehci-pci
[   56.027058] btusb 1-1.1:1.0: no reset_resume for driver btusb?
[   56.027061] btusb 1-1.1:1.1: no reset_resume for driver btusb?
[   56.097967] usb 1-1.3: reset high-speed USB device number 4 using ehci-pci
[   56.775847] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off
[   57.627026] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[   57.633272] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[   57.633359] ata1.00: ACPI cmd ef/10:06:00:00:00:a0 (SET FEATURES) succeeded
[   57.633363] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[   57.645737] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[   57.645826] ata1.00: ACPI cmd ef/10:06:00:00:00:a0 (SET FEATURES) succeeded
[   57.645829] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[   57.651976] ata1.00: configured for UDMA/133
[   57.652361] sd 0:0:0:0: [sda] Starting disk
[   57.654026] Extended CMOS year: 2000
[   57.677143] PM: resume of devices complete after 2904.997 msecs
[   57.677639] PM: Finishing wakeup.
[   57.677640] Restarting tasks ... done.
[   57.690291] video LNXVIDEO:00: Restoring backlight state
[   57.690295] video LNXVIDEO:01: Restoring backlight state


###### sudo rmmod alx; sudo modprobe alx


[  102.414400] Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver
[  102.432649] alx 0000:04:00.0: alx(30:85:a9:01:9b:01): Qualcomm Atheros Ethernet Network Connection
[  102.451912] systemd-udevd[2839]: renamed network interface eth0 to p3p1
[  102.460935] alx 0000:04:00.0: irq 47 for MSI/MSI-X
[  102.460958] alx 0000:04:00.0: irq 48 for MSI/MSI-X
[  102.460974] alx 0000:04:00.0: irq 49 for MSI/MSI-X
[  102.460991] alx 0000:04:00.0: irq 50 for MSI/MSI-X
[  102.461007] alx 0000:04:00.0: irq 51 for MSI/MSI-X
[  102.461025] alx 0000:04:00.0: irq 52 for MSI/MSI-X
[  102.461042] alx 0000:04:00.0: irq 53 for MSI/MSI-X
[  102.461059] alx 0000:04:00.0: irq 54 for MSI/MSI-X
[  102.461077] alx 0000:04:00.0: irq 55 for MSI/MSI-X
[  102.462652] IPv6: ADDRCONF(NETDEV_UP): p3p1: link is not ready
[  104.329822] alx 0000:04:00.0 p3p1: NIC Link Up: 1 Gbps Full
[  104.330071] IPv6: ADDRCONF(NETDEV_CHANGE): p3p1: link becomes ready
Comment 15 QCA Ethernet team 2013-05-02 16:28:34 UTC
(In reply to comment #14)

please remove following lines in alx_resume

-	if (!netif_running(netdev))
-		return 0;
-


that should fix your issue.



> Here dmesg:
> 
> 
> 
> ###### sudo rmmod alx; sudo modprobe alx
> 
> 
> [  102.414400] Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver
> [  102.432649] alx 0000:04:00.0: alx(30:85:a9:01:9b:01): Qualcomm Atheros
> Ethernet Network Connection
> [  102.451912] systemd-udevd[2839]: renamed network interface eth0 to p3p1
> [  102.460935] alx 0000:04:00.0: irq 47 for MSI/MSI-X
> [  102.460958] alx 0000:04:00.0: irq 48 for MSI/MSI-X
> [  102.460974] alx 0000:04:00.0: irq 49 for MSI/MSI-X
> [  102.460991] alx 0000:04:00.0: irq 50 for MSI/MSI-X
> [  102.461007] alx 0000:04:00.0: irq 51 for MSI/MSI-X
> [  102.461025] alx 0000:04:00.0: irq 52 for MSI/MSI-X
> [  102.461042] alx 0000:04:00.0: irq 53 for MSI/MSI-X
> [  102.461059] alx 0000:04:00.0: irq 54 for MSI/MSI-X
> [  102.461077] alx 0000:04:00.0: irq 55 for MSI/MSI-X
> [  102.462652] IPv6: ADDRCONF(NETDEV_UP): p3p1: link is not ready
> [  104.329822] alx 0000:04:00.0 p3p1: NIC Link Up: 1 Gbps Full
> [  104.330071] IPv6: ADDRCONF(NETDEV_CHANGE): p3p1: link becomes ready

Note You need to log in before you can comment on or make changes to this bug.