Bug 5163 - x crashes at startup
x crashes at startup
Status: REJECTED INSUFFICIENT_DATA
Product: Other
Classification: Unclassified
Component: Other
i386 Linux
: P2 normal
Assigned To: other_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-31 10:54 UTC by beverly ashley
Modified: 2006-02-14 07:55 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.13
Tree: Mainline
Regression: ---


Attachments
Response to bunk's question (37.67 KB, text/plain)
2005-08-31 12:20 UTC, beverly ashley
Details

Description beverly ashley 2005-08-31 10:54:33 UTC
Most recent kernel where this bug did not occur: 2.6.12
Distribution: slackware
Hardware Environment: AMD64/MSI MB/NVIDIA chipset
Software Environment:X11-6.8.1
Problem Description: X crashes at startup.  Keyboard/mouse locked out.  Kernel
is alive because I can log in from a terminal and shut the system down.

Steps to reproduce: startx
Comment 1 Adrian Bunk 2005-08-31 11:19:20 UTC
Please attach:
- the exact error messages you are seeing
- output of "dmesg -s 1000000"
- your .config
- the output of ./scripts/ver_linux

Is this an unpatches ftp.kernel.org kernel or a distribution kernel?
In the latter case, does the problem also occur with an unpatched ftp.kernel.org
kernel?

Comment 2 beverly ashley 2005-08-31 12:20:50 UTC
Created attachment 5834 [details]
Response to bunk's question
Comment 3 Dmitry Torokhov 2005-08-31 13:16:59 UTC
Could you post your /var/log/xorg.0.log (or whatever log file your xserver 
generates) please?
Comment 4 Vojtech Pavlik 2005-08-31 13:36:32 UTC
Have you tried 'killall X'? Does this return the machine to a useable state?
Comment 5 beverly ashley 2005-09-17 16:18:48 UTC
Earlier I posted a bug against the 2.6.13 kernel in which
X crashed at startup while under 2.6.12 it did not.

I tried a different window manager, different version of
X: x11-6.8.2 vs x11-6.8.1. The original kernel was compiled
for the AMD64. I re-compiled for an Athlon. None of these
changes was successful.

In desperation I changed the video card from a 16Mb Nvidia
PCI card to a 64Mb AGP Nvidia and the problem was solved.

Although the development group will probably dismiss the
problem as hardware related I think something changed in
the 2.6.13 kernel which was unintended.

Thanks for any consideration given to the original problem.
Comment 6 Dmitry Torokhov 2005-09-17 16:23:25 UTC
What driver are you using from your Nvidia card?  
Comment 7 Adrian Bunk 2006-02-14 07:55:26 UTC
I'm assuming this issue is already fixed.

Please reopen this bug if:
- it is still present in recent 2.6 kernels and
- you can provide the requested information.

Note You need to log in before you can comment on or make changes to this bug.