Bug 5134 - USB2 mass storages conflict
USB2 mass storages conflict
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-08-26 13:18 UTC by Leonid Kof
Modified: 2005-09-02 00:27 UTC (History)
1 user (show)

See Also:
Kernel Version: kernel 2.6.11.4-21.7
Tree: Mainline
Regression: ---


Attachments
System information relevant to the bug (319.81 KB, application/x-gunzip)
2005-08-26 13:37 UTC, Leonid Kof
Details

Description Leonid Kof 2005-08-26 13:18:21 UTC
Most recent kernel where this bug did not occur:
I have never tried the below test before
Distribution: SuSE 9.3

Hardware Environment:
Laptop Samsung X20, Pentium M 1.6 GHz, 2GB RAM, USB Controller: Intel
Corporation 82801FB/FBM/FR/FW/FRW, External USB2 DVD-RW "Freecom Classic"

Software Environment:
SuSE 9.3 with kernel 2.6.11.4-21.7, patched with patch #5737 (see bug #5010)

Problem Description:
USB2 mass storages seem to conflict, see "Steps to reproduce" for an exact
description. In my case the iPod conflicts with an external DVD drive

Steps to reproduce:
0. boot
1. plug in the iPod
2. mount the iPod
3. start data transfer to/from the iPod (I just started xmms to play songs
stored on the iPod)
4. plug in the DVD drive
5. after few seconds xmms does not respond any more, as the files to be played
are no more accessible. At this point the iPod file system can still be read,
"ll /USB" shows the correct file list
6. after about a minute the iPod file system cannot be read any more,
"ll /USB" shows just an empty directory

Some comments:
1. The problem is not symmetric: if the DVD drive is plugged in first, and the
iPod is plugged in after that, everything works fine.
2. The problem seems to be USB2-specific: I tried to replace the iPod by a foto
camera (USB1) in the above test sequence, and everything worked.
Comment 1 Nishanth Aravamudan 2005-08-26 13:28:45 UTC
I am guessing that 2.6.11.4-21.7 is a distro kernel? Please file a bug with a
distro or reproduce in 2.6.12.5/2.6.13-rc7. Thanks, Nish
Comment 2 Leonid Kof 2005-08-26 13:37:54 UTC
Created attachment 5777 [details]
System information relevant to the bug

P.S. Sorry, in few hours I'm going offline until 7.09 and will not be able to
answer test/info/... requests.
Comment 3 Greg Kroah-Hartman 2005-09-02 00:27:05 UTC
Distro specific bugs should go in distro specific bugzillas.

If you can reproduce this on 2.6.13, please reopen it.

Note You need to log in before you can comment on or make changes to this bug.