Bug 5133 - Ondemand governor makes system unstable
Ondemand governor makes system unstable
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: cpufreq
i386 Linux
: P2 high
Assigned To: cpufreq
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 12:50 UTC by Juha Heljoranta
Modified: 2007-04-29 07:51 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.13-rc7
Tree: Mainline
Regression: ---


Attachments
backtraces from 2.6.12-gentoo-r9 (5.81 KB, text/plain)
2005-08-26 13:02 UTC, Juha Heljoranta
Details
kernel-2.6.12-gentoo-r9 config (30.40 KB, text/plain)
2005-08-26 13:03 UTC, Juha Heljoranta
Details
backtrace from 2.6.13-rc7 (1.25 KB, text/plain)
2005-08-26 13:04 UTC, Juha Heljoranta
Details
backtrace from 2.6.13 (713 bytes, text/plain)
2005-08-31 10:42 UTC, Juha Heljoranta
Details

Description Juha Heljoranta 2005-08-26 12:50:51 UTC
Distribution: Gentoo
Hardware Environment: x86_64
Software Environment:
Problem Description: When using ondemand governor the kernel will freeze, reboot
or most of the processes just become unstable after some time of usage.

Steps to reproduce:

start to use ondemand governor:
echo ondemand >/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

After some hours, say 1 - 4 h, the system becomes unstable when used normally
(surf net, read mail, etc.)


Symptoms:
System might reboot itself without warning, kill X, make some process to behave
oddly before the process dies, etc.

Normally there is no warnings, errors or what so ever. After enabling a kernel
debug I got few backtraces.


If I do not use the ondemand governor then the system works just fine (uptime
+30 days). I haven't changed my kernel configuration for some time so it was
quite easy to spot what caused system to freek out.


I recall that I've seen the same symptoms when using some 2.6.9 - 2.6.10
(Gentoo) kernels with ondemand governor. Back then I just decided to stick with
the default (performance) governor.
Comment 1 Juha Heljoranta 2005-08-26 13:02:07 UTC
Created attachment 5774 [details]
backtraces from 2.6.12-gentoo-r9
Comment 2 Juha Heljoranta 2005-08-26 13:03:06 UTC
Created attachment 5775 [details]
kernel-2.6.12-gentoo-r9 config
Comment 3 Juha Heljoranta 2005-08-26 13:04:22 UTC
Created attachment 5776 [details]
backtrace from 2.6.13-rc7
Comment 4 Juha Heljoranta 2005-08-26 13:08:30 UTC
Note that the system didn't start to show symptoms immediatetly after backtraces
appeared, but little while after messages (like hour or two).
Comment 5 Juha Heljoranta 2005-08-31 10:42:52 UTC
Created attachment 5831 [details]
backtrace from 2.6.13

I enabled cpufreq debug but I haven't noticed anything interesting, except lot
of 'printk: xx messages suppressed' -messages.

Is there anything that I could do to get this bug fixed?
Comment 6 Daniel Drake 2005-09-17 10:11:16 UTC
Downstream bug report: http://bugs.gentoo.org/show_bug.cgi?id=103497
Comment 7 Diego Calleja 2006-07-30 08:48:33 UTC
What is the state of this bug?
Comment 8 Daniel Drake 2007-04-29 07:03:31 UTC
no response from reporter, marking as NEEDINFO
Comment 9 Juha Heljoranta 2007-04-29 07:37:02 UTC
It seems that the ondemand cpufreq scaling governor has been fixed some where
between 2.6.14 and 2.6.17. Ondemand governor has been my default cpu frequency
governor at least since 2.6.18. I might have used it with 2.6.17.
IIRC I tried to use ondemand with 2.6.14 and 2.6.15 but with same symptoms.
Comment 10 Daniel Drake 2007-04-29 07:51:45 UTC
Great, thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.