Bug 5124 - Build broken (in mach-es7000) without CONFIG_ACPI
Summary: Build broken (in mach-es7000) without CONFIG_ACPI
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 blocking
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-24 10:02 UTC by Richard Perrin
Modified: 2006-04-11 00:41 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.13-rc7
Tree: Mainline
Regression: ---


Attachments
Config file which breaks 2.6.13-rc7 build (39.90 KB, application/octet-stream)
2005-08-24 10:05 UTC, Richard Perrin
Details
Corrections to es7000 platform code for non-ACPI build (3.66 KB, patch)
2005-08-25 21:34 UTC, Natalie Protasevich
Details | Diff
Corrections to es7000 platform code for non-ACPI build (updated) (3.66 KB, patch)
2005-08-26 10:07 UTC, Natalie Protasevich
Details | Diff

Description Richard Perrin 2005-08-24 10:02:30 UTC
Most recent kernel where this bug did not occur:
Did not occur on 2.6.11.11, no others tested

Problem Description:
Kernel will not build with "CONFIG_X86_GENERICARCH=y" and "CONFIG_ACPI not set".
Output from make:
[...]
  CC      arch/i386/mach-generic/../mach-es7000/es7000plat.o
In file included from arch/i386/mach-es7000/es7000plat.c:42:
arch/i386/mach-es7000/es7000.h:82: error: field `id' has incomplete type
arch/i386/mach-es7000/es7000.h:88: error: field `Header' has incomplete type
arch/i386/mach-es7000/es7000plat.c: In function `parse_unisys_oem':
arch/i386/mach-es7000/es7000plat.c:154: error: `es7000_rename_gsi' undeclared
(first use in this function)
arch/i386/mach-es7000/es7000plat.c:154: error: (Each undeclared identifier is
reported only once
arch/i386/mach-es7000/es7000plat.c:154: error: for each function it appears in.)
arch/i386/mach-es7000/es7000plat.c: In function `find_unisys_acpi_oem_table':
arch/i386/mach-es7000/es7000plat.c:168: warning: implicit declaration of
function `acpi_find_rsdp'
arch/i386/mach-es7000/es7000plat.c:170: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:172: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:175: warning: implicit declaration of
function `__acpi_map_table'
arch/i386/mach-es7000/es7000plat.c:175: error: invalid application of `sizeof'
to an incomplete type
arch/i386/mach-es7000/es7000plat.c:179: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:179: error: invalid application of `sizeof'
to an incomplete type
arch/i386/mach-es7000/es7000plat.c:181: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:185: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:188: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:194: error: invalid application of `sizeof'
to an incomplete type
arch/i386/mach-es7000/es7000plat.c:197: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:198: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:201: warning: implicit declaration of
function `acpi_table_print'
arch/i386/mach-es7000/es7000plat.c:202: error: dereferencing pointer to
incomplete type
arch/i386/mach-es7000/es7000plat.c:204: error: dereferencing pointer to
incomplete type
make[2]: *** [arch/i386/mach-generic/../mach-es7000/es7000plat.o] Error 1
make[1]: *** [arch/i386/mach-generic/../mach-es7000] Error 2
make: *** [arch/i386/mach-generic] Error 2

Changing the config to include CONFIG_ACPI=y will cause build of this file to
succeed. Full build has not been attempted.

Steps to reproduce:
1) cp attached config file to kernel-top-level/.config
2) make
Comment 1 Richard Perrin 2005-08-24 10:05:19 UTC
Created attachment 5746 [details]
Config file which breaks 2.6.13-rc7 build
Comment 2 Natalie Protasevich 2005-08-25 21:34:51 UTC
Created attachment 5768 [details]
Corrections to es7000 platform code for non-ACPI build

I think this patch will correct problems with the build. 
Thanks,
--Natalie
Comment 3 Natalie Protasevich 2005-08-26 10:07:12 UTC
Created attachment 5771 [details]
Corrections to es7000 platform code for non-ACPI build (updated)

Updated the patch, since Len noted there is no more CONFIG_ACPI_BOOT. Replaced
it with CONFIG_ACPI.
Thanks,
--Natalie
Comment 4 Adrian Bunk 2006-04-11 00:41:19 UTC
The fix was included in 2.6.17-rc1.

Note You need to log in before you can comment on or make changes to this bug.