Bug 5084 - 915G: IDE IRQ related boot failure - ASUS P5GD2
915G: IDE IRQ related boot failure - ASUS P5GD2
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: IO/Storage
Classification: Unclassified
Component: IDE
i386 Linux
: P2 high
Assigned To: Bartlomiej Zolnierkiewicz
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 15:52 UTC by Alexander Fieroch
Modified: 2008-02-16 11:39 UTC (History)
15 users (show)

See Also:
Kernel Version: 2.6.10 up to current 2.6.20
Tree: Mainline
Regression: ---


Attachments
different syslogs showing the problems (26.77 KB, application/x-bzip)
2005-08-17 15:55 UTC, Alexander Fieroch
Details
syslog with kernel parameters "pci=routeirq irqpoll acpi=off noapic" (131.89 KB, text/plain)
2005-08-18 13:20 UTC, Alexander Fieroch
Details
lspci -vv output (14.73 KB, text/plain)
2005-08-18 13:22 UTC, Alexander Fieroch
Details
acpidump output (123.51 KB, text/plain)
2005-08-18 13:24 UTC, Alexander Fieroch
Details
syslog with CONFIG_PCI_MSI=y and kerneloptions pci=routeirq apic=verbose acpi=verbose (77.06 KB, text/plain)
2005-08-19 03:58 UTC, Alexander Fieroch
Details
syslog with CONFIG_PCI_MSI=n and kerneloptions pci=routeirq apic=verbose acpi=verbose (90.14 KB, text/plain)
2005-08-19 04:00 UTC, Alexander Fieroch
Details
syslog with CONFIG_PCI_MSI=y and kerneloptions pci=noacpi apic=verbose acpi=verbose (70.16 KB, text/plain)
2005-08-19 04:03 UTC, Alexander Fieroch
Details
syslog with CONFIG_PCI_MSI=n and kerneloptions pci=noacpi apic=verbose acpi=verbose (81.62 KB, text/plain)
2005-08-19 04:05 UTC, Alexander Fieroch
Details
syslog with kerneloptions pci=routeirq apic=debug acpi=debug irqpoll, WORKING MOSTLY (46.33 KB, text/plain)
2005-08-19 04:09 UTC, Alexander Fieroch
Details
syslog dump for a 32-bit system with SCSI (17.90 KB, text/plain)
2005-11-05 16:08 UTC, Marek Szuba
Details
kernel 2.6.20 syslog with "DriveReady SeekComplete DataRequest" error (109.93 KB, text/plain)
2007-02-16 02:35 UTC, Alexander Fieroch
Details
Bug_5084 syslog, lspci, lsmod (8.48 KB, application/rtf)
2007-07-02 17:06 UTC, Gaston Bougie
Details

Description Alexander Fieroch 2005-08-17 15:52:33 UTC
Distribution: debian sarge/i386 & debian sid/amd64
Hardware Environment: P4 630 em64t, ASUS P5GD2 Premium Board
Software Environment:
Problem Description:

Problem 1:
while booting the message "hdb: cdrom_pc_intr: The drive appears
confused (ireason = 0x01)" repeats many times and the system hangs
for some seconds.

Problem 2:
message "irq XXX: nobody cared!" followed by a call trace repeats
while booting and while running linux.

Problem 3:
kernel is hanging for some time while it shows following error:
hda: dma_timer_expiry: dma status == 0x64
hda: DMA interrupt recovery
hda: lost interrupt 


Problem discussed on the kernel-dev list we found out, that the problem is
definitely IRQ routing where BIOS or Linux ACPI is responsible.
http://article.gmane.org/gmane.linux.kernel/317636
http://article.gmane.org/gmane.linux.kernel/303955

All problems occur since kernel 2.6.10 up to the current kernel 2.6.13rc6-git8.
Kernel 2.6.8/9 are working but with continuously APIC Errors in syslog. Also
they yet do not contain drivers for my raid, hd-audio and lan what makes them
useless for me too.


I'm asked for complete syslogs tested with the current kernel (2.6.13rc6-git8)
and following options:
- module MSI on, kerneloptions: pci=routeirq apic=verbose acpi=verbose
- module MSI off, kerneloption: pci=routeirq apic=verbose acpi=verbose
- module MSI on, kerneloptions: pci=noacpi apic=verbose acpi=verbose
- module MSI off, kerneloption: pci=noacpi apic=verbose acpi=verbose
- kerneloption: pci=routeirq apic=debug acpi=debug irqpoll

...you'll find them as attachment + /proc/interrupts and "lspci -v"-output.


The last syslog with kernelparameter "irqpoll" reduces the number of errors a
lot. Problem 3 does not occur anymore and there are less error-messages with
problem 1 and problem 2. I can use my ide-harddisk (hda) again without problems
but cdrom (hdb) and dvdrom (hde) are still not working. Trying to copy files
from cdrom causes a kernel panic:

(log with kernel 2.6.13-rc6-git1, but current kernel causes a similar kernelpanic)
-----
hdb: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
hdb: media error (bad sector): error=0x30 { LastFailedSense=0x03 }
NMI Watchdog detected LOCKUP on CPU0CPU0
Modules linked in: lp 8250_pnp 8250 serial_core analog parport_pc parport
snd_bt87x i2c_i801 snd_hda_intel snd_hda_codec snd_seq_oss snd_seq_midi
snd_seq_midi_event snd_seq snd_mpu401 snd_mpu401_uart snd_ens1370 snd_rawmidi
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc
snd_ak4531_codec snd
Pid: 0, comm: swapper Not tainted 2.6.13-rc6-git1
RIP: 0010:[<ffffffff8043c393>] <ffffffff8043c393>{_spin_lock+97}
RSP: 0018:ffffffff805e5b80  EFLAGS: 00000002
RAX: 0000000000000000 RBX: ffffffff80666928 RCX: ffff810081763f60
RDX: 0000000000020001 RSI: ffffffff805e5bb8 RDI: 0000000000000001
RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
R10: 0000000000000001 R11: 0000000000aaaaaa R12: ffffffff80666900
R13: ffffffff80666928 R14: ffffffff805e5bb8 R15: ffffffff805e5ca8
FS:  0000000000000000(0000) GS:ffffffff80665800(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 00002aaaaaaae000 CR3: 0000000030144000 CR4: 00000000000006e0
Process swapper (pid: 0, threadinfo ffffffff80670000, task ffffffff804db800)
Stack: 0000000000000000 ffffffff801553b8 0000000000000001 0000000000007358
       0000000000007358 0000000000007356 ffffffffffffff6a 0000000000000202
       ffffffff805e5ca8 ffffffff8011055b
Call Trace: <IRQ> <ffffffff801553b8>{__do_IRQ+125} <ffffffff8011055b>{do_IRQ+69}
       <ffffffff8010e030>{ret_from_intr+0}
<ffffffff8013460e>{release_console_sem+345}
       <ffffffff80135189>{vprintk+752} <ffffffff8012dadd>{__wake_up+56}
       <ffffffff801351fc>{printk+78} <ffffffff8012ddf5>{activate_task+133}
       <ffffffff80130831>{try_to_wake_up+994}
<ffffffff8031a0b9>{ide_dump_status+1366}
       <ffffffff803223cf>{cdrom_decode_status+708}
<ffffffff8032271e>{cdrom_read_intr+0}
       <ffffffff80322786>{cdrom_read_intr+104}
<ffffffff8013cc3e>{lock_timer_base+27}
       <ffffffff8032271e>{cdrom_read_intr+0} <ffffffff80317a62>{ide_intr+396}
       <ffffffff80155a4c>{note_interrupt+284} <ffffffff8015542d>{__do_IRQ+242}
       <ffffffff8011055b>{do_IRQ+69} <ffffffff8010e030>{ret_from_intr+0}
        <EOI> <ffffffff8043b728>{preempt_schedule_irq+95}
<ffffffff8010e15e>{retint_kernel+38}
       <ffffffff8010c4a3>{mwait_idle+90} <ffffffff8027ebf0>{acpi_processor_idle+299}
       <ffffffff8010c42d>{cpu_idle+79} <ffffffff806727aa>{start_kernel+464}
       <ffffffff806721fc>{_sinittext+508}

Code: 0f b6 03 84 c0 7e 0b eb 9a c7 43 04 00 00 00 00 5b c3 8b 7b
console shuts up ...
 <0>Kernel panic - not syncing: Aiee, killing interrupt handler!

----
Comment 1 Alexander Fieroch 2005-08-17 15:55:18 UTC
Created attachment 5662 [details]
different syslogs showing the problems
Comment 2 Len Brown 2005-08-17 20:25:31 UTC
Did this work with kernels before 2.6.10,
or that is just the oldest one tested?

does this system work properly if booted with "acpi=off",
"noapic", or both?

Please attach the output from lspci -vv and from acpidump,
available in pmtools here:
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/utils
Comment 3 Alexander Fieroch 2005-08-18 13:16:34 UTC
As I have written above with kernel 2.6.8 and 2.6.9 the errors do not occur but
I get endless apic errors in syslog:

May 28 13:12:53 orclex kernel: APIC error on CPU0: 60(60)
May 28 13:13:05 orclex last message repeated 44 times

This is repeating every few seconds.

Furthermore kernel 2.6.8 & and 2.6.9 do not have drivers for my raid, hd-audio
and lan - so they are more or less useless for me.
But the cdrom drive is working without problems and that's something that
doesn't work for me since kernel 2.6.10.

Also I've tried a kernel < 2.6.8 but there is no driver for my sata and I can
not boot.

No kernel is working without problems any option I've tried. I'll attach a new
syslog with kernel parameters "pci=routeirq irqpoll acpi=off noapic". After
booting and trying to copy files from cdrom or dvdrom the kernel does not hang
with a kernelpanic as before but it does not copy any files too and I get the
following errors repeatedly:

hdb: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
hdb: media error (bad sector): error=0x30 { LastFailedSense=0x03 }
ide: failed opcode was: unknown
end_request: I/O error, dev hdb, sector 1306960
Buffer I/O error on device hdb, logical block 326740

Comment 4 Alexander Fieroch 2005-08-18 13:20:29 UTC
Created attachment 5668 [details]
syslog with kernel parameters "pci=routeirq irqpoll acpi=off noapic"

syslog (kernel 2.6.13rc6-git8) with kernel parameters "pci=routeirq irqpoll
acpi=off noapic"

shows the repeated media errors when accessing a cdrom/dvdrom drive
Comment 5 Alexander Fieroch 2005-08-18 13:22:44 UTC
Created attachment 5669 [details]
lspci -vv output
Comment 6 Alexander Fieroch 2005-08-18 13:24:22 UTC
Created attachment 5670 [details]
acpidump output
Comment 7 Alexander Fieroch 2005-08-19 03:58:27 UTC
Created attachment 5677 [details]
syslog with CONFIG_PCI_MSI=y and kerneloptions pci=routeirq apic=verbose acpi=verbose

syslog (kernel 2.6.13rc6-git8) with CONFIG_PCI_MSI=y and kerneloptions
pci=routeirq apic=verbose acpi=verbose

/proc/interrupts was:
	   CPU0       CPU1
  0:	 122106 	 0    IO-APIC-edge  timer
  1:	    221 	 0    IO-APIC-edge  i8042
  8:	      0 	 0    IO-APIC-edge  rtc
  9:	      0 	 0   IO-APIC-level  acpi
 10:	      0 	 0    IO-APIC-edge  MPU401 UART
169:	   1847 	 0   IO-APIC-level  skge, uhci_hcd:usb5, HDA Intel
177:	      0 	 0   IO-APIC-level  Ensoniq AudioPCI
185:	    300 	 0   IO-APIC-level  ide2, ide3, ehci_hcd:usb1,
uhci_hcd:usb2
193:	   5357 	 0   IO-APIC-level  libata, uhci_hcd:usb3
201:	1100000 	 0   IO-APIC-level  ide0, uhci_hcd:usb4
209:	      5 	 0   IO-APIC-level  bttv0, ohci1394, Bt87x audio
NMI:	     75 	54
LOC:	 119439     119443
ERR:	      1
MIS:	      0
Comment 8 Alexander Fieroch 2005-08-19 04:00:56 UTC
Created attachment 5678 [details]
syslog with CONFIG_PCI_MSI=n and kerneloptions pci=routeirq apic=verbose acpi=verbose

/proc/interrupts was:

	   CPU0       CPU1
  0:	  96347 	 0    IO-APIC-edge  timer
  1:	    209 	 0    IO-APIC-edge  i8042
  7:	      0 	 0    IO-APIC-edge  parport0
  8:	      0 	 0    IO-APIC-edge  rtc
  9:	      0 	 0   IO-APIC-level  acpi
 10:	      0 	 0    IO-APIC-edge  MPU401 UART
 16:	   1513 	 0   IO-APIC-level  skge, uhci_hcd:usb5, HDA Intel
 17:	      0 	 0   IO-APIC-level  Ensoniq AudioPCI
 18:	    155 	 0   IO-APIC-level  ide2, ide3, ehci_hcd:usb1,
uhci_hcd:usb2
 19:	   4089 	 0   IO-APIC-level  libata, uhci_hcd:usb3
 20:	1000000 	 1   IO-APIC-level  ide0, uhci_hcd:usb4
 21:	      5 	 0   IO-APIC-level  bttv0, ohci1394, Bt87x audio
NMI:	     75 	54
LOC:	  94623      94636
ERR:	      1
MIS:	      0
Comment 9 Alexander Fieroch 2005-08-19 04:03:26 UTC
Created attachment 5679 [details]
syslog with CONFIG_PCI_MSI=y and kerneloptions pci=noacpi apic=verbose acpi=verbose

/proc/interrupts was:

	   CPU0       CPU1
  0:	  72590 	 0    IO-APIC-edge  timer
  1:	    136 	 0    IO-APIC-edge  i8042
  2:	      0 	 0	    XT-PIC  cascade
  8:	      0 	 0    IO-APIC-edge  rtc
  9:	      0 	 0    IO-APIC-edge  acpi
 10:	      0 	 0    IO-APIC-edge  MPU401 UART
129:	   1217 	 0   IO-APIC-level  skge, uhci_hcd:usb5, HDA Intel
137:	      0 	 0   IO-APIC-level  Ensoniq AudioPCI
145:	 994198 	 0   IO-APIC-level  ide0, uhci_hcd:usb4
153:	   4132 	 0   IO-APIC-level  libata, uhci_hcd:usb3
161:	      5 	 0   IO-APIC-level  bttv0, ohci1394, Bt87x audio
169:	    245 	 0   IO-APIC-level  ide2, ide3, ehci_hcd:usb1,
uhci_hcd:usb2
NMI:	     81 	60
LOC:	  71016      71025
ERR:	      2
MIS:	      0
Comment 10 Alexander Fieroch 2005-08-19 04:05:34 UTC
Created attachment 5680 [details]
syslog with CONFIG_PCI_MSI=n and kerneloptions pci=noacpi apic=verbose acpi=verbose

/proc/interrupts was:

	   CPU0       CPU1
  0:	  89740 	 0    IO-APIC-edge  timer
  1:	    110 	 0    IO-APIC-edge  i8042
  2:	      0 	 0	    XT-PIC  cascade
  7:	      2 	 0    IO-APIC-edge  parport0
  8:	      0 	 0    IO-APIC-edge  rtc
  9:	      0 	 0    IO-APIC-edge  acpi
 10:	      0 	 0    IO-APIC-edge  MPU401 UART
 16:	   2313 	 0   IO-APIC-level  skge, uhci_hcd:usb5, HDA Intel
 17:	      0 	 0   IO-APIC-level  Ensoniq AudioPCI
 18:	1200000 	 0   IO-APIC-level  ide0, uhci_hcd:usb4
 19:	   4056 	 0   IO-APIC-level  libata, uhci_hcd:usb3
 21:	      5 	 0   IO-APIC-level  bttv0, ohci1394, Bt87x audio
 23:	    227 	 0   IO-APIC-level  ide2, ide3, ehci_hcd:usb1,
uhci_hcd:usb2
NMI:	     76 	55
LOC:	  87797      87819
ERR:	      1
MIS:	      0
Comment 11 Alexander Fieroch 2005-08-19 04:09:53 UTC
Created attachment 5681 [details]
syslog with kerneloptions pci=routeirq apic=debug acpi=debug irqpoll, WORKING MOSTLY

irqpoll reduces the number of errors and makes it possible to use hda but
copying files from cdrom/dvdrom leads to a kernel panic as listed above.

/proc/interrupts was:

	   CPU0       CPU1
  0:	  23901 	 0    IO-APIC-edge  timer
  1:	    144 	 0    IO-APIC-edge  i8042
  8:	      0 	 0    IO-APIC-edge  rtc
  9:	      0 	 0   IO-APIC-level  acpi
 10:	      0 	 0    IO-APIC-edge  MPU401 UART
169:	   5863 	 0   IO-APIC-level  skge, uhci_hcd:usb5, HDA Intel
177:	      0 	 0   IO-APIC-level  Ensoniq AudioPCI
185:	    496 	 0   IO-APIC-level  ide2, ide3, ehci_hcd:usb1,
uhci_hcd:usb2
193:	   4293 	 0   IO-APIC-level  libata, uhci_hcd:usb3
201:	 100000 	 0   IO-APIC-level  ide0, uhci_hcd:usb4
209:	      5 	 0   IO-APIC-level  bttv0, ohci1394, Bt87x audio
NMI:	     75 	54
LOC:	  25091      25076
ERR:	      1
MIS:	      0
Comment 12 Alexander Fieroch 2005-08-24 14:28:36 UTC
Still no change with kernel 2.6.13rc7. 
All errors still occur.
No cdrom/dvd is working since 2.6.10. 
Comment 13 Len Brown 2005-09-14 23:44:32 UTC
irqpoll is a workaround - masking the issue at hand -- not a fix.
CONFIG_PCI_MSI is useless and just complicates matters, leave it out.

it would be interseting to know if an i386  kernel works better
than x86_64 here.  you may be able to do such a comparison by
booting from a pair of distro cdroms.

> ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
> ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
> ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
> ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)

Duplicate identical interrupt source overrides?
This suggests a junk pre-production BIOS -- can you verify
that this board is running the latest BIOS?

just for grins, try "pnpacpi=off" and verify no difference.

Hmmm, this looks strange:

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH6: IDE controller at PCI slot 0000:00:1f.1
ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 20
ICH6: chipset revision 3
ICH6: 100% native mode on irq 20
BM-DMA at 0x5800-0x5807, BIOS settings: hda:DMA, hdb:DMA
BM-DMA at 0x5808-0x580f, BIOS settings: hdc:pio, hdd:pio
Probing IDE interface ide0...
hda: IC35L060AVV207-0, ATA DISK drive
hdb: SONY CD-RW CRX210E1, ATAPI CD/DVD-ROM drive
ide0 at 0x7000-0x7007,0x6802 on irq 20
Probing IDE interface ide1...
IT8212: IDE controller at PCI slot 0000:01:04.0
ACPI: PCI Interrupt 0000:01:04.0[A] -> GSI 23 (level, low) -> IRQ 18
IT8212: chipset revision 19
it821x: controller in pass through mode.
IT8212: 100% native mode on irq 18
ide2: BM-DMA at 0x9800-0x9807, BIOS settings: hde:pio, hdf:pio
ide3: BM-DMA at 0x9808-0x980f, BIOS settings: hdg:pio, hdh:pio
Probing IDE interface ide2...
hde: Pioneer DVD-ROM ATAPIModel DVD-104S 012, ATAPI CD/DVD-ROM drive
ide2 at 0xb000-0xb007,0xa802 on irq 18
Probing IDE interface ide3...
hdg: SAMSUNG SP1203N, ATA DISK drive
ide3 at 0xa400-0xa407,0xa002 on irq 18
Probing IDE interface ide1...
hda: max request size: 1024KiB
hda: 120103200 sectors (61492 MB) w/1821KiB Cache, CHS=16383/255/63, UDMA(100)
hda: cache flushes supported
hda: hda1 hda2
hdg: max request size: 1024KiB
hdg: 234493056 sectors (120060 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(133)
hdg: cache flushes supported
hdg: hdg1
hdb: cdrom_pc_intr: The drive appears confused (ireason = 0x01)

> 100% native mode on irq XXX

For PATA, I've always seen this as
"not 100% native mode: will probe irqs later"

I don't suppose there are some BIOS SETUP options associated
with IDE that change this behaviour?


Comment 14 Alexander Fieroch 2005-09-15 13:51:47 UTC
bugme-daemon@kernel-bugs.osdl.org wrote:
> irqpoll is a workaround - masking the issue at hand -- not a fix.
> CONFIG_PCI_MSI is useless and just complicates matters, leave it out.

ok

> it would be interseting to know if an i386  kernel works better
> than x86_64 here.  you may be able to do such a comparison by
> booting from a pair of distro cdroms.

I can't boot from cdrom! that's the problem - no cdrom or dvdrom is working!
But I'm running debian unstable for amd64 and debian stable for i386 on
that machine - both with same errors. The distro-kernels have the same
problems that my self-compiled kernels have.

BTW: kernel 2.6.14rc1 does not fix the problem

>>ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
>>ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
>>ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
>>ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
> 
> 
> Duplicate identical interrupt source overrides?
> This suggests a junk pre-production BIOS -- can you verify
> that this board is running the latest BIOS?

The board was shipped with "P5GD2 Premium BIOS version 1008". I've
upgraded the BIOS to 1009 and currently the latest available "Beta BIOS
1010.003". The problems I have are not eliminated with any of these BIOS
versions. I could downgrade to the latest stable version 1009 (perhaps
the duplicate lines disappear) but the problems will still be there.

> just for grins, try "pnpacpi=off" and verify no difference.

no difference, same errors.

> Hmmm, this looks strange:
> 
> Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
> ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
> ICH6: IDE controller at PCI slot 0000:00:1f.1
> ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 20
> ICH6: chipset revision 3
> ICH6: 100% native mode on irq 20
> BM-DMA at 0x5800-0x5807, BIOS settings: hda:DMA, hdb:DMA
> BM-DMA at 0x5808-0x580f, BIOS settings: hdc:pio, hdd:pio
> Probing IDE interface ide0...
> hda: IC35L060AVV207-0, ATA DISK drive
> hdb: SONY CD-RW CRX210E1, ATAPI CD/DVD-ROM drive
> ide0 at 0x7000-0x7007,0x6802 on irq 20
> Probing IDE interface ide1...
> IT8212: IDE controller at PCI slot 0000:01:04.0
> ACPI: PCI Interrupt 0000:01:04.0[A] -> GSI 23 (level, low) -> IRQ 18
> IT8212: chipset revision 19
> it821x: controller in pass through mode.
> IT8212: 100% native mode on irq 18
> ide2: BM-DMA at 0x9800-0x9807, BIOS settings: hde:pio, hdf:pio
> ide3: BM-DMA at 0x9808-0x980f, BIOS settings: hdg:pio, hdh:pio
> Probing IDE interface ide2...
> hde: Pioneer DVD-ROM ATAPIModel DVD-104S 012, ATAPI CD/DVD-ROM drive
> ide2 at 0xb000-0xb007,0xa802 on irq 18
> Probing IDE interface ide3...
> hdg: SAMSUNG SP1203N, ATA DISK drive
> ide3 at 0xa400-0xa407,0xa002 on irq 18
> Probing IDE interface ide1...
> hda: max request size: 1024KiB
> hda: 120103200 sectors (61492 MB) w/1821KiB Cache, CHS=16383/255/63, UDMA(100)
> hda: cache flushes supported
> hda: hda1 hda2
> hdg: max request size: 1024KiB
> hdg: 234493056 sectors (120060 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(133)
> hdg: cache flushes supported
> hdg: hdg1
> hdb: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> 
> 
>>100% native mode on irq XXX
> 
> 
> For PATA, I've always seen this as
> "not 100% native mode: will probe irqs later"
> 
> I don't suppose there are some BIOS SETUP options associated
> with IDE that change this behaviour?

I got a mail from someone having the same problems and error messages
with an ASUS P8P800-E deluxe board. He has changed the BIOS option
SATA/IDE-Controller from "advanced mode" to "compatibility mode" and all
errors disappear. But that is not working for me. In compatibility mode
the BIOS does not recognize my SATA harddisk and can not boot from it -
but that's the harddisk with linux on it!
Comment 15 Robert Morell 2005-09-30 16:29:08 UTC
I'm hitting this bug as well.  I can boot from it8212 in RAID mode just fine
using ITE's drivers, but they only compile up to 2.6.9, and the builtin drivers
from 2.6.10 and up have this problem.  irqpoll fixes the problem (irqfixup does
not..), but performance goes from 84MB/s with ITE's driver and 2.6.9 to 3.0MB/s
with the new driver (2.6.12, latest stable gentoo kernel).

I'm using Gigabyte K8NS Pro (x86_64) motherboard, with newest BIOS and firmware
all around.  Sorry I can't submit a syslog, but I need this RAID running to boot
from it, and unfortunately can't set up any serial stuff.
Gentoo distro, not that it matters; the IT8212 driver is identical on all
kernels I can find.

If it helps, it won't even mount XFS read-only ("hde: Lost interrupt" messages)
but it will mount ext3 read-only, and not read/write (no messages, for some reason).
Comment 16 Alexander Fieroch 2005-10-11 15:00:34 UTC
There is still no change in the current kernel 2.6.14rc4. Any access to files on
cdrom returns the following error continuously and no cdrom or dvdrom can be used.

hdb: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
hdb: media error (bad sector): error=0x30 { LastFailedSense=0x03 }
ide: failed opcode was: unknown
end_request: I/O error, dev hdb, sector 1306960
Buffer I/O error on device hdb, logical block 326740

Is anybody working on that problem?
I would like to help! You can give me patches I can test.
Comment 17 Marek Szuba 2005-11-05 15:53:14 UTC
I've got a somewhat similar problem with a 32-bit P4 2.6 GHz on a MSI 865PE 
Neo2-S. The setup looks as follows: the system boots off one of the two SCSI 
discs connected to an Adaptec AIC-7892A U160/m controller (using the new driver) 
 plus has an IDE HD (as master) and a CD-RW drive (as slave). With 2.4 the 
system has no problems; however, both 2.6.13.4 and 2.6.14 exhibit the following 
behaviour:

- with "irqpoll", it produces about 45 "The drive appears confused" messages as 
described by the others while scanning the IDE interface; then, having detected 
the SCSI controller and started probing it for devices, the kernel produces "irq 
185: nobody cared" followed by a call trace, followed by "Disabling IRQ #185". 
After this the system resumes normal boot procedure, gets up and running and 
stays like this for several days (depending on usage of SCSI bandwidth, I 
suppose), after which it locks up hard and has to be power-cycled;

- with no "irqpoll", the scenario is similar - except instead of resuming the 
boot procedure (I'm also not sure if the "disabled IRQ" message appears), I get 
something along the lines of "attempting to queue an ABORT command", followed by 
an oops (which unfortunately I don't have copied down, as it doesn't appear in 
any logs) and a hard lock-up.
Comment 18 Marek Szuba 2005-11-05 16:08:23 UTC
Created attachment 6482 [details]
syslog dump for a 32-bit system with SCSI

Syslog dump from start till execution of init, with irqpoll. /proc/interrupts
was:
	   CPU0       CPU1	 
  0:   75388248 	 0    IO-APIC-edge  timer
  1:	    617 	 0    IO-APIC-edge  i8042
169:	      0 	 0   IO-APIC-level  acpi
185:	 100000 	 0   IO-APIC-level  ide0, aic7xxx
193:	7549096 	 0   IO-APIC-level  eth0
201:  568232455 	 0   IO-APIC-level  eth1
NMI:	      0 	 0 
LOC:   75386123   75386139 
ERR:	      0
MIS:	      0
Comment 19 Alexander Fieroch 2006-01-05 14:19:59 UTC
The BIOS option SATA for the above errors was set to...

---
Configure SATA as     [Standard IDE], [Enhanced Mode], [S-ATA+P-ATA]
---

Now I've changed this to...

---
Configure SATA as     [AHCI]
ALPE and ASP   [Disabled]
   Stagger Spinup Support   [Disabled]
   AHCI Port 3 Interlock Switch   [Disabled]
---


With that option it is working mostly without errors in syslog while booting.

But I still get the "DriveReady SeekComplete Error" messages while copying files
from CDROM or DVD and the copy hangs. Both drives (CDRW and DVD) are not broken. 


Jan  5 20:43:29 orclex kernel: hdb: cdrom_decode_status: status=0x51 {
DriveReady SeekComplete Error }
Jan  5 20:43:29 orclex kernel: hdb: cdrom_decode_status: error=0x40 {
LastFailedSense=0x04 }
Jan  5 20:43:29 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:29 orclex kernel: hdb: cdrom_decode_status: status=0x51 {
DriveReady SeekComplete Error }
Jan  5 20:43:29 orclex kernel: hdb: cdrom_decode_status: error=0x40 {
LastFailedSense=0x04 }
Jan  5 20:43:29 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:29 orclex kernel: hdb: DMA disabled
Jan  5 20:43:29 orclex kernel: hdb: ide_intr: huh? expected NULL handler on exit
Jan  5 20:43:29 orclex kernel: hdb: ATAPI reset complete
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x50 { DriveReady
SeekComplete }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x51 { DriveReady
SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x04 { AbortedCommand }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x51 { DriveReady
SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x04 { AbortedCommand }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x51 { DriveReady
SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x04 { AbortedCommand }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: ATAPI reset complete
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x51 { DriveReady
SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x04 { AbortedCommand }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x51 { DriveReady
SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x04 { AbortedCommand }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x51 { DriveReady
SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x04 { AbortedCommand }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x51 { DriveReady
SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x04 { AbortedCommand }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: ATAPI reset complete
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x51 { DriveReady
SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x04 { AbortedCommand }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: cdrom_read_intr: data underrun (4 blocks)
Jan  5 20:43:30 orclex kernel: end_request: I/O error, dev hdb, sector 29476
Jan  5 20:43:30 orclex kernel: printk: 27 messages suppressed.
Jan  5 20:43:30 orclex kernel: Buffer I/O error on device hdb, logical block 7369
Jan  5 20:43:30 orclex kernel: hdb: status error: status=0x59 { DriveReady
SeekComplete DataRequest Error }
Jan  5 20:43:30 orclex kernel: hdb: status error: error=0x00 { }
Jan  5 20:43:30 orclex kernel: ide: failed opcode was: unknown
Jan  5 20:43:30 orclex kernel: hdb: drive not ready for command
Jan  5 20:43:30 orclex kernel: hdb: request sense failure: status=0x51 {
DriveReady SeekComplete Error }
Jan  5 20:43:30 orclex kernel: hdb: request sense failure: error=0x04 {
AbortedCommand }
Jan  5 20:44:31 orclex kernel: hdb: lost interrupt
Jan  5 20:44:32 orclex kernel: hdb: lost interrupt
...


I'm not sure if this should be a new bug report, because this failure does not
occur while booting but when using cdrom drives.
Comment 20 Alexander Fieroch 2006-02-16 02:48:22 UTC
Up to current 2.6.13rc3 I get "DriveReady SeekComplete Error" with every
harddrives connected to the IDE raid of this ASUS mainboard:


Feb 16 10:05:08 orclex kernel: Probing IDE interface ide1...
Feb 16 10:05:08 orclex kernel: IT8212: IDE controller at PCI slot 0000:01:04.0
Feb 16 10:05:08 orclex kernel: ACPI: PCI Interrupt 0000:01:04.0[A] -> GSI 23
(level, low) -> IRQ 20
Feb 16 10:05:08 orclex kernel: IT8212: chipset revision 19
Feb 16 10:05:08 orclex kernel: it821x: controller in pass through mode.
Feb 16 10:05:08 orclex kernel: IT8212: 100%% native mode on irq 20
Feb 16 10:05:08 orclex kernel:     ide2: BM-DMA at 0x8400-0x8407, BIOS settings:
hde:pio, hdf:pio
Feb 16 10:05:08 orclex kernel:     ide3: BM-DMA at 0x8408-0x840f, BIOS settings:
hdg:pio, hdh:pio
Feb 16 10:05:08 orclex kernel: Probing IDE interface ide2...
Feb 16 10:05:08 orclex kernel: Probing IDE interface ide3...
Feb 16 10:05:08 orclex kernel: hdg: IC35L060AVV207-0, ATA DISK drive
Feb 16 10:05:08 orclex kernel: hdh: SAMSUNG SP1203N, ATA DISK drive
Feb 16 10:05:08 orclex kernel: ide3 at 0x9000-0x9007,0x8802 on irq 20
Feb 16 10:05:08 orclex kernel: PDC20267: IDE controller at PCI slot 0000:01:09.0
Feb 16 10:05:08 orclex kernel: ACPI: PCI Interrupt 0000:01:09.0[A] -> GSI 17
(level, low) -> IRQ 17
Feb 16 10:05:08 orclex kernel: PDC20267: chipset revision 2
Feb 16 10:05:08 orclex kernel: PDC20267: ROM enabled at 0xd7f40000
Feb 16 10:05:08 orclex kernel: PDC20267: 100%% native mode on irq 17
Feb 16 10:05:08 orclex kernel: PDC20267: (U)DMA Burst Bit ENABLED Primary PCI
Mode Secondary PCI Mode.
Feb 16 10:05:08 orclex kernel:     ide4: BM-DMA at 0xa400-0xa407, BIOS settings:
hdi:pio, hdj:pio
Feb 16 10:05:08 orclex kernel:     ide5: BM-DMA at 0xa408-0xa40f, BIOS settings:
hdk:pio, hdl:pio
Feb 16 10:05:08 orclex kernel: Probing IDE interface ide4...
Feb 16 10:05:08 orclex kernel: hdi: Pioneer DVD-ROM ATAPIModel DVD-104S 012,
ATAPI CD/DVD-ROM drive
Feb 16 10:05:08 orclex kernel: ide4 at 0xb800-0xb807,0xb402 on irq 17
Feb 16 10:05:08 orclex kernel: Probing IDE interface ide5...
Feb 16 10:05:08 orclex kernel: Probing IDE interface ide1...
Feb 16 10:05:08 orclex kernel: Probing IDE interface ide2...
Feb 16 10:05:08 orclex kernel: Probing IDE interface ide5...
Feb 16 10:05:08 orclex kernel: hdg: max request size: 512KiB
Feb 16 10:05:08 orclex kernel: hdg: 120103200 sectors (61492 MB) w/1821KiB
Cache, CHS=16383/255/63, UDMA(100)
Feb 16 10:05:08 orclex kernel: hdg: cache flushes supported
Feb 16 10:05:08 orclex kernel:  hdg:hdg: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdg: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdg: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdg: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdg: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdg: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel:  hdg1 hdg2
Feb 16 10:05:08 orclex kernel: hdh: max request size: 512KiB
Feb 16 10:05:08 orclex kernel: hdh: 234493056 sectors (120060 MB) w/2048KiB
Cache, CHS=16383/255/63, UDMA(133)
Feb 16 10:05:08 orclex kernel: hdh: cache flushes supported
Feb 16 10:05:08 orclex kernel:  hdh:hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: ide3: reset: success
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: hdg: DMA disabled
Feb 16 10:05:08 orclex kernel: ide3: reset: success
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Feb 16 10:05:08 orclex kernel: hdh: dma_intr: error=0x84 { DriveStatusError BadCRC }
Feb 16 10:05:08 orclex kernel: ide: failed opcode was: unknown
Feb 16 10:05:08 orclex kernel: end_request: I/O error, dev hdh, sector 0
Feb 16 10:05:08 orclex kernel: Buffer I/O error on device hdh, logical block 0
Feb 16 10:05:08 orclex kernel: ldm_validate_partition_table(): Disk read failed.
Feb 16 10:05:08 orclex kernel:  unable to read partition table


Connecting these harddrives to the Promise PDC20267 controller card, no errors
appear.
Comment 21 Alexander Fieroch 2006-02-16 02:50:57 UTC
up to current 2.6.16rc3 not 2.6.13rc3, of course
Comment 22 Bartlomiej Zolnierkiewicz 2006-02-16 04:53:16 UTC
looks like it821x specific problem
Comment 23 Stanislaw Zegadlo 2006-04-20 02:55:03 UTC
Hi!
 I had the same problem and managed to fix it in my system.
Hardware:
 Server System:
Asus NCL-DS motherboard
	Intel E7520
SCSI: AIC-7902 PCI-X Dual U320 SCSI
SATA: Intel ICH5R, 2 ports
Configuration:
	One CDROM (IDE), One HDD 200GB (IDE, new model), One SCSI 76GB

1.No problem with kernel 2.4 (RH 9)
2.Problems with cdrom ("drive confused", "nobody cared", "disabling IRQ #17" -
its ICH5R 

IRQ)
3.Systems tested: Gentoo Live CD x86_64(2.6.15), Ubuntu Live CD x86_64 (2.6.15),
Knoppix 

Live CD (2.6.x) x86_64, Fedora Core 4 i386 (2.6.9?), Fedora Core 5 i386 &
x86_64(2.6.15), 

Centos 4 x86_64(2.6.15)
 No differences.
4.I've played with IDE Configuration BIOS option (AMI BIOS).
IDE Configuration
Onboard IDE Operate Mode:
 Enhanced Mode: PATA+SATA,SATA,PATA
 Compatible Mode

 a. default - Enhanced/PATA+SATA - problems as in 2.
 b. Enhanced/PATA - problems as in 2.
 c. Compatible Mode - problems (2) are gone, but HDD IDE is missing
 d. Ehanced Mode: SATA - bingo! No problems at all.

I hope my tests will help to pinpoint the bug.

Comment 24 Vidar Braut Haarr 2006-11-19 17:24:35 UTC
Just calling in another "confirmed". I first experienced this when upgrading my
Ubuntu install from 2.6.8 to 2.6.10 (vendor patched i386). During the first
reboot following the upgrade, the boot seemed to take a *very* long time, and I
had a look and saw the messages mentioned in this bug.

I tried the Fedora Core 6 install DVD and the Gentoo 2006.1 install DVD, and
they both have the same problem.

I can still boot to Ubuntu, but it takes *ages*, and the DVD-ROM does not work -
it is a Plextor PX-708A. If you want me to attach any log output to the bug,
please advise.
Comment 25 Alexander Fieroch 2007-02-16 02:35:32 UTC
Created attachment 10434 [details]
kernel 2.6.20 syslog with "DriveReady SeekComplete DataRequest" error

The errors still appear in kernel 2.6.20:

hda: status error: status=0x58 { DriveReady SeekComplete DataRequest }
ide: failed opcode was: unknown
hda: drive not ready for command

This message is repeated continuously and I cannot access the drive. It's the
same connecting other (not broken!) dvd/cdrom drives to the mainboard's ide or
raid controller.
Comment 26 Vidar Braut Haarr 2007-02-27 09:45:00 UTC
I no longer experience this problem with the Fedora Core 7 Test 1 kernel, which
ships with a (probably heavily patched) 2.6.19 kernel[1].

1: From <http://www.desktoplinux.com/news/NS7633319656.html>, since I'm not
booted in FC7test1 now, and can't do a uname -a.
Comment 27 Gaston Bougie 2007-07-02 16:56:49 UTC
Hi,
finally I've also similar people with this problem.
I can reproduce the problem as I download from a fast newsserver towards a pata ide disc that shares the same bus [05] as the nic is on:

           +-1e.0-[0000:05]--+-00.0  Promise Technology, Inc. 20269
           |                 \-01.0  Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]

I've never worked with this bugzilla, but hope that I can help with providing the right info.

Debian stable
Linux server 2.6.18-4-amd64 #1 SMP Thu May 10 01:01:58 UTC 2007 x86_64 GNU/Linux


Comment 28 Gaston Bougie 2007-07-02 17:06:47 UTC
Created attachment 11927 [details]
Bug_5084 syslog, lspci, lsmod
Comment 29 Natalie Protasevich 2007-07-03 19:30:36 UTC
Alexander, Gaston,
Have you tried changing IDE configuration suggested in #23 (or similar setting in your BIOS)?
Thanks.
Comment 30 Gaston Bougie 2007-07-03 23:13:11 UTC
(In reply to comment #29)
> Alexander, Gaston,
> Have you tried changing IDE configuration suggested in #23 (or similar setting
> in your BIOS)?
> Thanks.
> 

Hi Natalie, thank you for your fast reply.
I've found a workaround.
My mainboard is an Asus P5B
It has 4 sata connectors on board and 1 onboard pata ide.
As the 1 pata was not enough, I've placed an extra ide controller.
So I've hooked the 2 ide cables both to the extra ide controller.
As this gave me my problems I've changed the setup and put one cable on the on-board controller, and one cable on the extra ide controller.

This works fine for me as a workaround, but I think when I'm going to use the second ide channel of the extra controller I will be having those problems again..... but on the other hand... sata it will be next.

If anyone needs to get things tested, maybe I can help.

Regards,
Gaston
Comment 31 Alexander Fieroch 2007-07-03 23:16:08 UTC
Yes I have. Setting the onboard IDE operate mode to 'c' ("Compatible Mode") results in having only PATA and no SATA. But my linux partition is on a SATA drive, so I can't use this. Setting it to 'd' ("Ehanced Mode: SATA") disables PATA. Surely disabling IDE results in having no IDE-problems, but I still need PATA and not only SATA.
So these configurations are no choice for me and I have to use the configuration "Enhanced/PATA+SATA" to have PATA and SATA simultaneously. 
In current kernel 2.6.21 the problems are still in there.
Comment 32 Natalie Protasevich 2007-08-05 23:55:21 UTC
It appears to be a BIOS problem, and I am copying to Tejun - he can sort out why SATA and PATA are mutually exclusive in this case.
Comment 33 Tejun Heo 2007-08-06 00:19:07 UTC
Wheee... confusing.  I think there are two separate problems reported here.

* screaming IRQ problem.  This might be caused by the IDE driver not clearing BMDMA IRQ pending bit on ichs or misrouted IRQ lines.

* CRC error when transferring data to/from an ODD device.  Possibly caused by cable misdetection or faulty device.

Compatibility mode packs PATA and SATA to standard two channel SFF interface.  Mapping varies depending on configuration but it usually allocates one channel to PATA and the other to SATA.  So, if you have more than two SATA ports, only two of them will be usable in the compatible mode.  This is hardware limitation and you must use enhanced mode to access all the ports.

Alxander, please test 2.6.22.1 without only libata drivers (ie. no IDE drivers) such that both PATA and SATA ports are driven by libata drivers.  Set BIOS to enhanced mode on both PATA and SATA and report the dmesg.

Thanks.
Comment 34 Len Brown 2007-08-18 22:26:27 UTC
Alexander,
If I read this bug report properly, the screaming interrupt
problem happens both with and without "acpi=off", as do
the data errors.  So this doesn't appear to be related to ACPI.

(now, you can try the 4 combinations of "acpi=off"
and "noapic" to disable the IOAPIC just to be sure it isn't
something funky about the interrupt configuration.
If it is the device or device driver, it will likely
fail the same way in all 4 configurations.)

Moving this bug from ACPI to IO/Storage - IDE
Comment 35 Bartlomiej Zolnierkiewicz 2007-08-19 05:54:48 UTC
> * screaming IRQ problem.  This might be caused by the IDE driver not clearing
> BMDMA IRQ pending bit on ichs or misrouted IRQ lines.

should be fixed already for ICHs

> * CRC error when transferring data to/from an ODD device.  Possibly caused by
> cable misdetection or faulty device.

bad cable or host driver specific problem (doesn't belong to this bugzilla bug)

Alexander/Robert/Marek/Vidar/Gaston: please retest with 2.6.23-rc2 and confirm that the problems have been fixed or that they are still there.  Thanks!
Comment 36 Natalie Protasevich 2007-10-11 00:08:18 UTC
Sounds good... has any of the reportes have chance to test the latest kernel? How is it working for you guys?
Thanks.
Comment 37 Vidar Braut Haarr 2007-10-17 00:50:03 UTC
I'll test it when the ubuntu repositories update to 2.6.23, they're currently at 2.6.22.
Comment 38 Alexander Fieroch 2007-10-17 08:25:11 UTC
Currently with kernel 2.6.23 I do not have the problems anymore but I've changed my hardware too. So someone else should verify that the problems are fixed too.
Comment 39 Bartlomiej Zolnierkiewicz 2008-02-16 11:39:01 UTC
I assume that this problem has been fixed and I'm closing this bug
(please re-open if it still happens with recent kernels).

Note You need to log in before you can comment on or make changes to this bug.