Bug 5054 - cannot change debug_level or debug_layer
Summary: cannot change debug_level or debug_layer
Status: REJECTED INVALID
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: acpi_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-12 08:23 UTC by Sanjoy Mahajan
Modified: 2005-08-12 10:39 UTC (History)
0 users

See Also:
Kernel Version: 2.6.13-rc6
Tree: Mainline
Regression: ---


Attachments

Description Sanjoy Mahajan 2005-08-12 08:23:09 UTC
Distribution: Debian testing
Hardware Environment: TP 600X
Software Environment: hacked DSDT (see Bug #4989), kernel patched with patches
from Bug #5008 (ec burst mode), Bug #5035 (specific hotkey), Bug #5037 (S3 sleep
hang workaround), booted with command line:

BOOT_IMAGE=+three-patches ro root=305 idebus=66 apm=off acpi=force pci=noacpi
console=ttyS0,115200 console=tty0 acpi_sleep=s3_bios ec_burst=1

Problem Description: Sometimes I cannot change the debug_level or debug_layer
settings, whether I use 'echo -n' or 'echo' > /proc/acpi/debug_layer or
/proc/acpi/debug_level.  It's intermittent.  I wasn't able to change either
value, then I was able to a few times, and right now I cannot.

Here's an example transcript of it failing:

# cat /proc/acpi/debug_layer
Description              	Hex        SET
ACPI_UTILITIES           	0x00000001 [ ]
ACPI_HARDWARE            	0x00000002 [ ]
ACPI_EVENTS              	0x00000004 [ ]
ACPI_TABLES              	0x00000008 [ ]
ACPI_NAMESPACE           	0x00000010 [*]
ACPI_PARSER              	0x00000020 [ ]
ACPI_DISPATCHER          	0x00000040 [ ]
ACPI_EXECUTER            	0x00000080 [ ]
ACPI_RESOURCES           	0x00000100 [ ]
ACPI_CA_DEBUGGER         	0x00000200 [ ]
ACPI_OS_SERVICES         	0x00000400 [ ]
ACPI_CA_DISASSEMBLER     	0x00000800 [ ]
ACPI_COMPILER            	0x00001000 [ ]
ACPI_TOOLS               	0x00002000 [ ]
ACPI_ALL_DRIVERS         	0xFFFF0000 [ ]
--
debug_layer = 0x00000010 (* = enabled, - = partial)
# echo -n 0x4100000 > debug_layer
# cat /proc/acpi/debug_layer
Description              	Hex        SET
ACPI_UTILITIES           	0x00000001 [ ]
ACPI_HARDWARE            	0x00000002 [ ]
ACPI_EVENTS              	0x00000004 [ ]
ACPI_TABLES              	0x00000008 [ ]
ACPI_NAMESPACE           	0x00000010 [*]
ACPI_PARSER              	0x00000020 [ ]
ACPI_DISPATCHER          	0x00000040 [ ]
ACPI_EXECUTER            	0x00000080 [ ]
ACPI_RESOURCES           	0x00000100 [ ]
ACPI_CA_DEBUGGER         	0x00000200 [ ]
ACPI_OS_SERVICES         	0x00000400 [ ]
ACPI_CA_DISASSEMBLER     	0x00000800 [ ]
ACPI_COMPILER            	0x00001000 [ ]
ACPI_TOOLS               	0x00002000 [ ]
ACPI_ALL_DRIVERS         	0xFFFF0000 [ ]
--
debug_layer = 0x00000010 (* = enabled, - = partial)


Steps to reproduce: Have never seen this happen before, so don't know if I can
reproduce it.  But this is also the first time I've booted with the testing
kernel and ec_burst=1 so maybe there's a culprit in ec_burst or in one of the
patches.
Comment 1 Sanjoy Mahajan 2005-08-12 10:39:17 UTC
Sorry I must be smoking dope.  

echo -n 0x4100000 > debug_layer

was not working because I didn't give the full path /proc/acpi/debug_layer (so
it worked when I had cd'ed to /proc/acpi but not otherwise).

Note You need to log in before you can comment on or make changes to this bug.