Bug 5028 - battery are not present
battery are not present
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Battery
i386 Linux
: P2 normal
Assigned To: Luming Yu
:
Depends on: 4980
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-08 13:45 UTC by Oleksij Rempel (fishor)
Modified: 2005-09-07 20:19 UTC (History)
1 user (show)

See Also:
Kernel Version: kernel 2.6.13-rc6
Tree: Mainline
Regression: ---


Attachments

Description Oleksij Rempel (fishor) 2005-08-08 13:45:41 UTC
Distribution:kubuntu 5.04 
Hardware Environment:laptop samsung nv5000  
Software Environment:kernel+acpi 
Problem Description: 
 
With kernel 2.6.13-rc6 battery are not present but they are pluget with kernel 
2.6.13-rc5-mm1 it worket.
Comment 1 Luming Yu 2005-08-12 00:34:44 UTC
Please test patch at bug 3851, with ec_burst=1 and 0 
Comment 2 Oleksij Rempel (fishor) 2005-08-12 02:49:39 UTC
I tested this patch with kernel 2.6.12.4 and didn't get suspend-to-mem working,
hang instead. Am I took corect patch?
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/release/2.6.12/acpi-20050729-2.6.12.patch.gz
Comment 3 Luming Yu 2005-08-12 05:52:08 UTC
what about battery?
Comment 4 Oleksij Rempel (fishor) 2005-08-12 13:36:11 UTC
I'm sorry :) With ec_burst=0 and 1 batt_info show proper information. If ac 
changet to batt it's working too. With kernel 2.6.13-rc6 batt_info didn't 
worked after resume too but i cant test it. 
Comment 5 Luming Yu 2005-08-18 08:11:18 UTC
closing it since battery works.
Comment 6 Len Brown 2005-09-02 23:00:42 UTC
Does this issue exist in 2.6.13?
Did it exist in 2.6.12 or earlier kernels?


Please clarify comment #4.
Did the latest patch in bug 3851 make all the issues go away?
If it fixed some issues and not others, can you clarify which
went away and which remain?  Are the issues that remain
a regression versus an earlier release, or did they never work?
Comment 7 Len Brown 2005-09-07 20:19:19 UTC
please re-open if there are issues in 2.6.13 or later.
thanks.

Note You need to log in before you can comment on or make changes to this bug.