Bug 50231 - No CPU frequency scaling for Intel Atom 2550
Summary: No CPU frequency scaling for Intel Atom 2550
Status: CLOSED DOCUMENTED
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Processor (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-07 17:58 UTC by Lukasz Wieczorek
Modified: 2013-12-11 15:14 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.7.10
Tree: Mainline
Regression: No


Attachments
dmesg (56.37 KB, text/plain)
2012-11-07 18:01 UTC, Lukasz Wieczorek
Details
dmidecode (5.80 KB, text/plain)
2012-11-07 18:02 UTC, Lukasz Wieczorek
Details
lsmod (1.70 KB, text/plain)
2012-11-07 18:02 UTC, Lukasz Wieczorek
Details
CPU features (8.44 KB, text/plain)
2012-11-07 18:02 UTC, Lukasz Wieczorek
Details
Kernel configoptimized for Atom- no CPU scaling (118.86 KB, application/octet-stream)
2012-11-24 18:43 UTC, Lukasz Wieczorek
Details
acpidump output (119.94 KB, text/plain)
2013-01-29 10:08 UTC, Lukasz Wieczorek
Details

Description Lukasz Wieczorek 2012-11-07 17:58:19 UTC
The summary says it all- CPU works with the highest frequency running fans at fast pace. Dmidecode says ACPI is supported, and although daemon starts and required (?) modules are loaded, no frequency scaling can be observed.
Comment 1 Lukasz Wieczorek 2012-11-07 18:01:44 UTC
Created attachment 85831 [details]
dmesg
Comment 2 Lukasz Wieczorek 2012-11-07 18:02:17 UTC
Created attachment 85841 [details]
dmidecode
Comment 3 Lukasz Wieczorek 2012-11-07 18:02:34 UTC
Created attachment 85851 [details]
lsmod
Comment 4 Lukasz Wieczorek 2012-11-07 18:02:58 UTC
Created attachment 85861 [details]
CPU features
Comment 5 Alan 2012-11-08 14:08:37 UTC
[    0.786778] fb0: VESA VGA frame buffer device
[    0.788042] intel_idle: MWAIT substates: 0x10
[    0.788046] intel_idle: does not run on family 6 model 54

Your kernel also appears to have crashed twice and to have various bizarre drivers in it as well as some you need missing. That may also be involved.

You want PATA_SCH included for your disk, ACPI_PROCESSOR and to move to 3.5.current or 3.6 kernels for some of the other graphics stuff I suspect. That or turn off a lot of what is being loaded and clashing.

I'm not sure if intel_idle will handle the Cedartrail in 3.6 but thats a good first check.
Comment 6 Lukasz Wieczorek 2012-11-09 10:05:36 UTC
Well, that's true- I have problems with graphics- it took me some time to figure out proper settings for text mode to have any output on CRT. I did not report it since this piece of hardware runs headless.

As for upgrading to 3.5/3.6... I'm running Slackware 14, out of the box so it should be pretty good tested. For 3.5/3.6 I would have to refresh kernel headers which would affect the rest of the system for me.

I was not able to find in kernel change log if D2550 should be supported better than generic Intel.

Anyway I loaded manually almost all modules related to ACPI, with no error but one:
root@genesis:~# modprobe acpi-cpufreq
ERROR: could not insert 'acpi_cpufreq': Input/output error
which gave no error in dmesg above this one.

Of course CPU still runs at the highest clock.
Comment 7 Alan 2012-11-09 11:15:42 UTC
The kernel builds independently of needing any matching user space headers and has for years.

With all the previous crashes in the log, the wrong disk driver in use and the like its pretty much impossible to do any useful debug.
Comment 8 Lukasz Wieczorek 2012-11-09 19:42:40 UTC
You were right- I messed up a bit dev packages. 

What I found Atom is a different CPU type so I'll give it a go with 3.6.6. Will let you know the results.
Comment 9 Lukasz Wieczorek 2012-11-24 18:40:29 UTC
I tried to use 3.6.6 for this piece of hardware, but I was not able to bring up a working kernel- it is more difficult that it works as a headless machine.


Anyway, I checked the configuration of original Slackware14 kernel and to me all required modules are made, including PATA and video. I made a slight modifications including Atom opt. checking ACPI, video and PATA. I made a small changes, recompiled the kernel, it booted well but CPU scaling will not work.

I uploading the kernel configuration, if you are able to suggest what should be included/excluded for this hardware, your help is much appreciated.
Comment 10 Lukasz Wieczorek 2012-11-24 18:43:24 UTC
Created attachment 87191 [details]
Kernel configoptimized for Atom- no CPU scaling
Comment 11 Lukasz Wieczorek 2013-01-02 18:07:07 UTC
The same results I am getting for 3.7.1 after BIOS upgrade to the latest version:

root@genesis:~# modprobe acpi-cpufreq
ERROR: could not insert 'acpi_cpufreq': No such device

User space powernowd will not work either:

powernowd: PowerNow Daemon v1.00, (c) 2003-2008 John Clemens
/sys/devices/system/cpu/cpu0/cpufreq/affected_cpus: No such file or directory
powernowd: err=2

If any fresh idea you could suggest I would spend some time on testing.

Thank you.

Lukasz Wieczorek
Comment 12 Len Brown 2013-01-29 02:25:40 UTC
Please check in your BIOS SETUP that CPU Frequency Scaling
is enabled.  Sometimes called EIST -- Enhanced Intel Speed Step.

Please attach the output from "acpidump"
you can get it in the latest kernel tree under tools/power/acpi/

If/when you have this directory, please show the output of...
# grep . /sys/devices/system/cpu/cpu0/cpufreq/*
Comment 13 Lukasz Wieczorek 2013-01-29 10:07:26 UTC
Len, 

thx for your hints!

I even upgraded BIOS on this motherboard since i suspected some bugs were preventing CPU scaling. It did not help.

Please see output of acpidump in attachement.

'grep' command gives no input since it looks like there is not correct /proc branch which AFAIK means kernel is not able to see this feature.
Comment 14 Lukasz Wieczorek 2013-01-29 10:08:56 UTC
Created attachment 92131 [details]
acpidump output
Comment 15 Lukasz Wieczorek 2013-02-15 14:24:08 UTC
Well... it looks like an Intel joke: according to http://ark.intel.com/ this processor will not support CPU scaling... I am almost sure, when I decided to buy this proc the web page stated it is supported.

So I think we can close this bug - super power saving proc that will not support CPU scaling :(.
Comment 16 marco.molteni.en.voyage 2013-03-16 19:33:39 UTC
Lukasz, I think you were confused by http://ark.intel.com/products/65470/Intel-Atom-Processor-D2550-1M-Cache-1_86-GHz about the Atom D2550: it says that it doesn't support "Enhanced SpeedStep", but it also says that it does support (plain) SpeedStep.

I stumbled on this bug because I have an Asus EEBox EB1033 with the Atom D2550, with a vanilla kernel 3.5.0-25 from Ubuntu server 12.10, and I have exactly the same problem.
Comment 17 Lukasz Wieczorek 2013-03-17 12:10:53 UTC
Hi Marco,

probably you are right... though I am not able to find where Intel openly declares SpeedStep should work for this CPU.

PS. The bug still exists in 3.7.10.
Comment 18 Lan Tianyu 2013-12-11 15:14:30 UTC
Hi, just check the acpidump and it doesn't have aml method required by acpi-cpufreq. This is why acpi-cpufreq doesn't work. So close this bug.

Note You need to log in before you can comment on or make changes to this bug.