Bug 4991 - Kernel OOPS in reiserfs_releasepage on Dual Opteron system
Summary: Kernel OOPS in reiserfs_releasepage on Dual Opteron system
Status: REJECTED DUPLICATE of bug 4851
Alias: None
Product: File System
Classification: Unclassified
Component: ReiserFS (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: ReiseFS developers team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-03 05:18 UTC by j5uv22602
Modified: 2006-04-22 10:27 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.12
Tree: Mainline
Regression: ---


Attachments
messages/syslog output (12.26 KB, text/plain)
2005-08-04 12:00 UTC, j5uv22602
Details

Description j5uv22602 2005-08-03 05:18:35 UTC
Distribution: Gentoo
Hardware Environment: AMD Dual Opteron 64 (2.2 ghz)
Software Environment: Gentoo Linux
Problem Description: Kernel OOPS in reiserfs_releasepage:

kernel: Modules linked in: raid0 md nfs nfsd exportfs lockd sunrpc usbcore
sd_mod aic79xx
kernel: Pid: 118, comm: kswapd1 Not tainted 2.6.12-gentoo-r4
kernel: RIP: 0010:[reiserfs_releasepage+128/208]
<ffffffff801bd2f0>{reiserfs_releasepage+128}
kernel: RIP: 0010:[<ffffffff801bd2f0>] <ffffffff801bd2f0>{reiserfs_releasepage+128}
kernel: RSP: 0018:ffff8103ffe8bb48  EFLAGS: 00010213
kernel: RAX: 0000000005001009 RBX: 0000000000000000 RCX: 0000000000000000
kernel: RDX: ffff8103b22dda50 RSI: 00000000000000d0 RDI: ffffc2000160c168
kernel: RBP: ffff8100f0827c38 R08: 0000000000000002 R09: ffff8103ffe8ba16
kernel: R10: ffff8103ffe8ba78 R11: ffffffff801bd270 R12: ffff810204573df0
kernel: R13: ffffc2000160c168 R14: ffff8103ffe8be38 R15: 0000000000000001
kernel: FS:  00002aaaaadf6b00(0000) GS:ffffffff803e5840(0000) knlGS:0000000000000000
kernel: CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
kernel: CR2: 0000000000000040 CR3: 000000002791a000 CR4: 00000000000006a0
kernel: Process kswapd1 (pid: 118, threadinfo ffff8103ffe8a000, task
ffff8100100920f0)
kernel: Stack: ffff810204573df0 ffff8103b22dda50 ffff810204573df0 ffff810200000680
kernel:        0000000000000001 ffffffff8015ff55 ffff810200000c08 ffff810200000c08
kernel:        ffff810200000c18 ffff810200000c00
kernel: Call Trace:<ffffffff8015ff55>{shrink_zone+2933}
<ffffffff80160756>{balance_pgdat+566}
kernel:        <ffffffff80160a07>{kswapd+327}
<ffffffff80148900>{autoremove_wake_function+0}
kernel:        <ffffffff80148900>{autoremove_wake_function+0}
<ffffffff8012d070>{schedule_tail+64}
kernel:        <ffffffff8010e61b>{child_rip+8} <ffffffff801608c0>{kswapd+0}
kernel:        <ffffffff8010e613>{child_rip+0}
kernel:
kernel: Code: 48 83 7b 40 00 74 1b 8b 03 a8 02 75 10 8b 03 a8 04 75 0a 48

Steps to reproduce:
Appears to be completely random, although I suspect it occurs when system is
under heavy load (either disk or CPU.)
Comment 1 j5uv22602 2005-08-04 12:00:56 UTC
Created attachment 5507 [details]
messages/syslog output

/var/log/messages listing with additional errors. (date and machine name
removed)
Comment 2 j5uv22602 2005-09-07 04:54:16 UTC
Never mind. I found out what the problem was.
Please see:

http://bugs.gentoo.org/show_bug.cgi?id=104151
and
http://bugzilla.kernel.org/show_bug.cgi?id=4851

Setting kernel.randomize_va_space=0 in /etc/sysctl.conf
(echo 0 > /proc/sys/kernel/randomize_va_space) solved the problem.

It does seem to be a really bad bug introduced into the kernel,
but at least it's fixable for now.
Comment 3 Chris Mason 2006-01-20 09:16:03 UTC
Looks like this one can be closed?  It doesn't seem valid anymore. 
Comment 4 Adrian Bunk 2006-04-22 10:27:26 UTC

*** This bug has been marked as a duplicate of 4851 ***

Note You need to log in before you can comment on or make changes to this bug.