Bug 49591 - gspca,logitech quickcam web, black screen
Summary: gspca,logitech quickcam web, black screen
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Hans de Goede
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-26 07:49 UTC by epistemepromeneur
Modified: 2013-03-20 16:13 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.4.11, 3.5.4
Tree: Mainline
Regression: No


Attachments

Description epistemepromeneur 2012-10-26 07:49:00 UTC
Mandriva 2010.2 i586
kde 4.8.5
cheeze 2.30.1
kopete 1.2.3
skype 4.0.0.8

046d:0850 Logitech, Inc. QuickCam Web

gspca_main, gspca_stv06xx

- kernel 3.2.27

no pb

- 3.4.11

randomly black screen with cheeze, kopete, skype

with skype there are kernel error message of this type :
...
Oct 25 10:47:05 localhost kernel: [ 7803.038587] gspca_main: ISOC data error: [21] len=0, status=-18
Oct 25 10:47:05 localhost kernel: [ 7803.038597] gspca_main: ISOC data error: 
[29] len=0, status=-18
Oct 25 10:47:05 localhost kernel: [ 7803.070593] gspca_main: ISOC data error: 
[5] len=0, status=-18
Oct 25 10:47:05 localhost kernel: [ 7803.070598] gspca_main: ISOC data error: 
[13] len=0, status=-18
Oct 25 10:47:05 localhost kernel: [ 7803.070601] gspca_main: ISOC data error: 
[21] len=0, status=-18
Oct 25 10:47:05 localhost kernel: [ 7803.070604] gspca_main: ISOC data error: 
[29] len=0, status=-18
...

- 3.5.4
every time black screen with cheeze, kopete, skype
no kernel error message

it's similar to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=677533
Comment 1 epistemepromeneur 2012-10-26 07:51:18 UTC
in dmesg :

[   14.153180] gspca_main: v2.14.0 registered
[   14.171904] gspca_main: STV06xx-2.14.0 probing 046d:0850
[   14.179036] gspca_stv06xx: vv6410 sensor detected
Comment 2 epistemepromeneur 2012-10-29 15:05:29 UTC
MB : Asus M2N

onboard usb adapter : nvidia MCP61

the webcam is connected to
- a 2.0 usb port
- ohci controller

to this ohci controller alos is connected :

- a keyboard
- a mouse
- a bluetooth dongle
Comment 3 Hans de Goede 2012-10-29 15:56:51 UTC
Hi,

Can you try again without the bluetooth dongle ?

Also are you perhaps using the device through an USB-2 hub?

Regards,

Hans
Comment 4 epistemepromeneur 2012-10-29 16:39:24 UTC
i don't use any external hub

the hub is the one of the MB

the webcam is plugged in this hub, a 12 Mbit/s one.

i remember in the past (2011 with kernel 2.6.x) i had pb when i added the bt dongle.

when i added the bluetooth dongle then suddenly the webcam did not work anymore.

then i plugged the bt dongle in the hub included in the keyboard then no more pb.this is always the case.

most of the time bt dongle is unactivated (unactivated by default)


the ohci controller :
- usb 1.10
- 12 Mbit/s

camera :
- usb 1.00
- 12 Mbit/s
- 100 mA

silitek usb hub keyboard :
- usb 1.10
- 12 Mbit/s
- 40 mA

silitek usb keyboard
- usb 1.10
- 12 Mbit/s
- 40 mA

bt dongle (plugged in silitek usb hub keyboard) :
- usb 2.00
- 12 Mbit/s
- 100 mA


i will test without bt dongle and kernel 3.4.
i must install again a 3.4 kernel
Comment 5 epistemepromeneur 2012-10-29 18:42:20 UTC
kernel 3.5.4

no bt dongle

cheeze or kopete activates webcam (the led is lightning)
but
a black screen

kernel 3.4.11

i will test
Comment 6 epistemepromeneur 2012-10-30 09:06:41 UTC
for kernel 3.4.11

it is a random phenomenon

i must wait several days to do a meaning report

for kernel 3.5.4

i must connect the front panel usb plug to ehci mb connector
thus
camera will be alone plugged to ohci mb connector
Comment 7 epistemepromeneur 2012-10-30 13:34:55 UTC
for kernel 3.5.4

1.

i launch cheeze
then
blazck screen
then
i plug off mouse and keyboard and bluetooth dongle
then
black screen

2. i tried to isolate the camera by choosing other usb connector in the mb

for the front panel and by plugging mouse and keyboard to the front panel

result : black screen

in the 2 cases no error message in syslog or dmesg and the led stays light off

in dmesg we see the webcam is well seen by the system
Comment 8 epistemepromeneur 2012-10-30 13:50:00 UTC
in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=677533

in message #48

it is said :
- "Hmm, this is then likely caused by the new isoc bandwidth negotiation code
in 3.2"

- gspca_vc032x has compliancy pb with this

perhaps gspca_stv06xx has compliancy pb with some new feature in the kernel 3.4.11 or 3.5.4 ?
Comment 9 epistemepromeneur 2012-10-31 10:57:57 UTC
For 3.5.4

another hypothesis

using usbview with 3.2.28 or 3.4.11 then no pb

using usbview with 3.5.4 then pb : usbview can't find devices.

usbview expects the devices in /proc/usb/devices

perhaps something changes concerning usb devices in the kernel then cheeze, kopete or skype can't use /dev/video0
Comment 10 epistemepromeneur 2012-11-01 04:40:18 UTC
for 3.4.11

4 days without pb

pb disappeared
Comment 11 Erik Andr 2012-11-01 08:04:45 UTC
If this is a kernel regression, the best solution would be for you to do a kernel git bisect to find which commit that caused the problem.

http://wiki.debian.org/DebianKernel/GitBisect
Comment 12 epistemepromeneur 2012-11-10 09:08:17 UTC
i found there is a regression also for gspca_sn9c20x

see http://www.spinics.net/lists/linux-media/msg50036.html
Comment 13 Hans de Goede 2012-11-10 14:04:37 UTC
(In reply to comment #12)
> i found there is a regression also for gspca_sn9c20x
> 
> see http://www.spinics.net/lists/linux-media/msg50036.html

Which as you can see from the next mail in that thread, has long been fixed, and which is also completely unrelated to the problem you are seeing.
Comment 14 epistemepromeneur 2012-11-13 07:44:34 UTC
i resume diagnosis :

for kernel 3.5.4 and 3.6.5 with mandriva 2010.2 i586 bit and 
kernel 3.5.5 and 3.6.5 with mageia 3 alpha 2 x86_64

for cheese, kopete ,skype

- the led of the webcam is "light on"
- the screen is black
- there is no error message in dmesg, syslog, Xorg.0.log
Comment 15 epistemepromeneur 2012-11-17 15:10:21 UTC
an interesting bug report see comment 3

https://bugs.mageia.org/show_bug.cgi?id=6596
Comment 16 epistemepromeneur 2012-11-18 13:56:26 UTC
i found the solution !

for my mandriva 2010.2 i586 and kernel 3.6.5

i get gspca 2.15.18 source supplied by eric moine from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=677533 message 53

then

i fix ov534_9.c and spca505.c
by replacing all "err" calls by "pr_err" as adviced by eric moine for kernel >= 3.5
then
make install -- with succes
then
when using su -c"make install"
i had errors
then
i manually replaced all the *.ko.gz in

/lib/modules/3.6.5-nrj-desktop-pae-2mib/kernel/drivers/media/video/gspca/
/lib/modules/3.6.5-nrj-desktop-pae-2mib/kernel/drivers/media/video/gspca/gl860
/lib/modules/3.6.5-nrj-desktop-pae-2mib/kernel/drivers/media/video/gspca/m5602
/lib/modules/3.6.5-nrj-desktop-pae-2mib/kernel/drivers/media/video/gspca/stv06xx

by those in

~/gspca-2.15.18/build/

then

i restart the pc

then
 success !

i use now my webcam with mandriva 2010.2 + kernel 3.6.5 with
cheese, kopete, skype
Comment 17 epistemepromeneur 2012-11-18 14:01:28 UTC
i forget a step

i compress all *.ko to *.ko.gz with gzip
before i try to use "su -c"make install"
Comment 18 Javier Torres 2012-11-20 13:48:35 UTC
Hi,

I have the same camera (Lecocam) and the same problem: It works fine using 3.4 but there is no image using 3.5:

- "cat /dev/video0" returns an Input/output error.
- guvcview says "Could not grab image (select timeout): Resource temporarily unavailable"

The behaviour is the same in three different computers, and is reproducible with both USB 1.1 and 2.0 controllers.

I did a git bisect on the upstream kernel, and the first bad revision is:

# bad: [dec9c51442b5a524c137b6f4a54ec109a197a65a] [media] gspca_stv06xx: Convert to the control framework

Feel free to ask for more information that could help.

Thanks,
Javier
Comment 19 epistemepromeneur 2012-11-25 10:17:07 UTC
some good news

I worked with the former principal dev of gspca JF Moine (moinejf at
free.fr) for my pb

result:
- 2 patches that will be ported on kernel 3.8 by Team kernel (linus and
Greg)

one for gspca_stv06xx

  http://article.gmane.org/gmane.linux.drivers.video-input-infrastructure/57306

one for gspca_ov534

        http://article.gmane.org/gmane.linux.drivers.video-input-infrastructure/57295

- Team MIB, Rosalabs ported the patches to the kernel 3.6.8


they have been tested by MIB, Rosalabs team and me :
- me
tested model : logitech quickam express

mandriva 2010.2 i586 with kernel 3.5.4, 35.7, 3.6.5
rosa 2012.1 beta 2 x86_64  with kernel 3.6.8

- Mib Nicolo Constenza (abitrules at yahoo.it)
tested 3 models: Trust/Philips/TechMedia

rosa 2012.1 x86_64 with kernel 3.6.8

- Rosalabs

they are currently testing
Comment 20 Hans de Goede 2012-11-29 14:31:03 UTC
(In reply to comment #19)
> some good news
> 
> I worked with the former principal dev of gspca JF Moine (moinejf at
> free.fr) for my pb
> 
> result:
> - 2 patches that will be ported on kernel 3.8 by Team kernel (linus and
> Greg)
> 
> one for gspca_stv06xx
> 
>  
>   http://article.gmane.org/gmane.linux.drivers.video-input-infrastructure/57306

Thanks for all your work on this. I've added this patch to my kernel tree:
http://git.linuxtv.org/hgoede/gspca.git/commitdiff/5b3c9ba728dea92aacb101fa661f0d4ac604045f

And included it in my latest pull-request to Mauro (the linux-media subsystem maintainer, who in his turn will send it to Linus):
http://www.mail-archive.com/linux-media@vger.kernel.org/msg55688.html

> one for gspca_ov534
>       
> http://article.gmane.org/gmane.linux.drivers.video-input-infrastructure/57295

This is a completely different issue, if you wish to track this through bugzilla too, please create a new bug for this.
Comment 21 epistemepromeneur 2013-03-19 17:19:52 UTC
hello

i tested my webcam with opensuse 12.3 x86_64 with kernel 3.7.10 and 3.8.3
then
no success

when will the patch be included in the kernel ?

i must compile and install the v4l-db from git according to have my webcam working.

once i installed the v4l-db from git i am pleased to have a working webcam
but
there is a negative consequence :

nvidia installs badly because not same symbols are used in kernel 3.7.10 and v4l-db thus at boot nvidia driver is not loaded
Comment 22 Hans de Goede 2013-03-20 16:13:34 UTC
Hi,

(In reply to comment #21)
> hello
> 
> i tested my webcam with opensuse 12.3 x86_64 with kernel 3.7.10 and 3.8.3
> then
> no success
> 
> when will the patch be included in the kernel ?

Unfortunately the patch in question missed the 3.8 merge window, but it
is in Linus' tree now and thus will be part of the 3.9 release:
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/log/drivers/media/usb/gspca/stv06xx/stv06xx_vv6410.c

Regards,

Hans

Note You need to log in before you can comment on or make changes to this bug.