Bug 4953 - /proc/acpi/toshiba entries missing in ACPI20050708 ?
/proc/acpi/toshiba entries missing in ACPI20050708 ?
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform
i386 Linux
: P2 blocking
Assigned To: Len Brown
:
: 4539 4902 5066 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-27 17:13 UTC by David Leemans
Modified: 2010-10-08 18:17 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.12.3, 2.6.13-rc4, 2.6.13-rc6
Tree: Mainline
Regression: ---


Attachments
dmesg (10.24 KB, text/plain)
2005-07-27 17:19 UTC, David Leemans
Details
fix against 2.6.13-rc6 (1.90 KB, patch)
2005-08-15 10:43 UTC, Len Brown
Details | Diff

Description David Leemans 2005-07-27 17:13:45 UTC
Distribution: Slackware 10.1
Hardware Environment: Toshiba Satellite Pro 6000
Software Environment:
Problem Description:
/proc/acpi/toshiba entries are not created with by kernel 2.6.12.3 with
ACPI20050708. Hence it is no longer possible to get/set Toshiba specific settings. 
Plain kernel 2.6.12.2 is fine however. 


Steps to reproduce: 
boot with 2.6.12.3 patched with ACPI20050708. Notice that /proc/acpi/toshiba is
not there.
Comment 1 David Leemans 2005-07-27 17:19:44 UTC
Created attachment 5390 [details]
dmesg
Comment 2 David Leemans 2005-07-30 18:22:22 UTC
tried plain vanilla kernel 2.6.13-rc4 today, comes with ACPI20050408. Here
/proc/acpi/toshiba is missing too. 
And I do have CONFIG_TOSHIBA=y and CONFIG_ACPI_TOSHIBA=y in my .config.
When was it decided to ditch the Toshiba entries ?
Comment 3 Len Brown 2005-08-14 21:55:39 UTC
> toshiba_acpi: Using generic hotkey driver

Please build with CONFIG_ACPI_HOTKEY=n
Comment 4 David Leemans 2005-08-15 06:32:04 UTC
>> toshiba_acpi: Using generic hotkey driver
>Please build with CONFIG_ACPI_HOTKEY=n

Did so with plain 2.6.13-rc6, which comes with CONFIG_ACPI_HOTKEY=n by default :
still no /proc/acpi/toshiba entries. 
Comment 5 Len Brown 2005-08-15 09:30:29 UTC
hmmm, does it work if you boot with "acpi_specific_hotkey"?
Comment 6 Len Brown 2005-08-15 09:31:30 UTC
*** Bug 4539 has been marked as a duplicate of this bug. ***
Comment 7 Len Brown 2005-08-15 10:43:51 UTC
Created attachment 5647 [details]
fix against 2.6.13-rc6

let me know if this patch from Luming via bug 5035 doesn't fix it.
Comment 8 Len Brown 2005-08-15 13:39:22 UTC
*** Bug 5066 has been marked as a duplicate of this bug. ***
Comment 9 Len Brown 2005-08-15 13:41:29 UTC
*** Bug 4902 has been marked as a duplicate of this bug. ***
Comment 10 Len Brown 2005-08-15 13:45:29 UTC
fix in comment #7 applied to-linus
Comment 11 David Leemans 2005-08-15 15:42:49 UTC
> hmmm, does it work if you boot with "acpi_specific_hotkey"?

Well yes, it does ! I will report back on trying the fix from comment #7.
Comment 12 David Leemans 2005-08-15 15:59:39 UTC
I applied the patch to 2.6.13-rc6 and can confirm that if fixes the problem of
the missing /proc/acpi/toshiba entries. Job well done, Len ! 
Comment 13 Len Brown 2005-08-16 14:17:28 UTC
linus pulled this fix in after 2.6.13-rc6 -- closing.

Note You need to log in before you can comment on or make changes to this bug.