Bug 4950 - 2.6.8-2.6.9 regression(battery state don't change)
2.6.8-2.6.9 regression(battery state don't change)
Status: REJECTED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Battery
i386 Linux
: P2 high
Assigned To: Luming Yu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-27 06:36 UTC by david mugnai
Modified: 2005-09-07 01:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.13-rc3-mm1
Tree: Mainline
Regression: ---


Attachments
dmesg -s40000 (15.07 KB, text/plain)
2005-07-27 06:38 UTC, david mugnai
Details
dmidecode (7.65 KB, text/plain)
2005-07-27 06:39 UTC, david mugnai
Details
acpidump (100.37 KB, text/plain)
2005-07-27 06:40 UTC, david mugnai
Details
lspci -vv (10.02 KB, text/plain)
2005-07-27 06:41 UTC, david mugnai
Details
cat /proc/interrupts (700 bytes, text/plain)
2005-07-27 06:41 UTC, david mugnai
Details
2.6.9 ec driver changes against 2.6.8 (1.34 KB, patch)
2005-08-21 18:59 UTC, Luming Yu
Details | Diff

Description david mugnai 2005-07-27 06:36:50 UTC
Distribution:
debian unstable, kernel self-compiled

Hardware Environment:
notebook, acer aspire 1450

Problem Description:
the battery and ac_adapter state don't change after boot.
with the original debian kernel 2.6.8 all works fine, but with any other kernel
the state isn't updated

I've compiled the 2.6.13-rc3-mm1 with and without the preemption, no luck

Steps to reproduce:
cat /proc/acpi/battery/BAT1/state
cat /proc/acpi/ac_adapter/ACAD/state
Comment 1 david mugnai 2005-07-27 06:38:25 UTC
Created attachment 5384 [details]
dmesg -s40000
Comment 2 david mugnai 2005-07-27 06:39:15 UTC
Created attachment 5385 [details]
dmidecode
Comment 3 david mugnai 2005-07-27 06:40:32 UTC
Created attachment 5386 [details]
acpidump
Comment 4 david mugnai 2005-07-27 06:41:12 UTC
Created attachment 5387 [details]
lspci -vv
Comment 5 david mugnai 2005-07-27 06:41:51 UTC
Created attachment 5388 [details]
cat /proc/interrupts
Comment 6 Andrew Morton 2005-07-29 01:58:03 UTC
Is the bug also present in 2.6.13-rc4?

Thanks.
Comment 7 david mugnai 2005-07-29 12:27:19 UTC
Hi Andrew, now i'm running 2.6.13-rc4 (no-preempt) but no luck.

sometimes plug and unplug the ac power updates the battery and ac-adapter status.

Now i'm running with the ac cable plugged and acpi -V says:
     Battery 1: discharging, 19%, 01:34:17 remaining
     Thermal 1: ok, 54.0 degrees C
  AC Adapter 1: off-line

Thank you
Comment 8 Andrew Morton 2005-08-04 15:44:59 UTC
OK, well a few more ACPI-related fixups will be going into 2.6.13-rc6...

Lots of people are reporting various problems with their battery monitors.
Comment 9 david mugnai 2005-08-06 02:56:59 UTC
ok, i'm waiting for the rc6, now i'm trying the rc5 but no luck :-(
Comment 10 david mugnai 2005-08-08 05:00:27 UTC
even the rc6 doesn't work properly

david@dog:~$ uname -r
2.6.13-rc6dvdnp

with the ac-adapter online:

david@dog:~$ cat /proc/acpi/battery/BAT1/state
present:                 yes
capacity state:          ok
charging state:          discharging
present rate:            3296 mA
remaining capacity:      2784 mAh
present voltage:         15296 mV

david@dog:~$ cat /proc/acpi/ac_adapter/ACAD/state
state:                   off-line
Comment 11 d3ity 2005-08-13 01:20:34 UTC
Battery monitoring on my laptop, an Acer Ferrari 4000, using the ATI Xpress200P
chipset is producing similar results, cat /proc/acpi/battery/BAT1/state shows
similar output even on 2.6.13-rc6.

From what it appears this is more of the same, however, on a diffrent model.
Comment 12 Luming Yu 2005-08-13 02:27:31 UTC
Please try option ec_burst=1
The patch at http://bugzilla.kernel.org/show_bug.cgi?id=3851 
could help.
Comment 13 david mugnai 2005-08-13 03:05:58 UTC
There are two patch for the 2.6.13-rc6, what should i use?

i've tried http://bugzilla.kernel.org/attachment.cgi?id=5599&action=view

but i obtain 

11 out of 12 hunks FAILED -- saving rejects to file drivers/acpi/ec.c.rej

thank you
Comment 15 david mugnai 2005-08-13 09:32:01 UTC
HI,

with the patch 5574 my 2.6.13rc6 now show correctly the battery status

unfortunatly there are some other oddities with this kernel that make it
unusable :-)
Comment 16 Len Brown 2005-08-14 22:00:35 UTC
linux-2.6.8 worked fine, and everything later fails until
using ec_burst=1 with the latest kernel?

Curious that 2.6.8 worked, as it didn't have ec_burst.
Luming, do we have an ec_polling more regression here?
If so, we need to fix polling mode, as we can't count
on burst mode to be available on all systems yet.
Comment 17 Luming Yu 2005-08-21 18:59:03 UTC
Created attachment 5719 [details]
2.6.9 ec driver changes against 2.6.8

Please revert this 2.6.9 to 2.6.8 ec patch to see if 2.6.9 works well
Comment 18 david mugnai 2005-08-22 14:39:06 UTC
i've applied teh patch to a new 2.6.9 (patch -p1 -R)
but the battery status monitor doesn't work (with or without the ec_burst)

david@dog:~$ cat /proc/acpi/battery/BAT1/state
present:                 no

but i'm writing w/o the ac adapter :)
Comment 19 david mugnai 2005-08-30 01:20:13 UTC
Now i'm running with the last stable kernel (2.6.13) and all works fine

thank you for your work
Comment 20 Luming Yu 2005-09-07 01:58:16 UTC
I'm sorry, please try to revert this patch against 2.6.9: 
http://www.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/release/2.6.9/acpi-20040816-2.6.9.diff.gz 
If you reproduce the regression, then please reopen this bug. Thanks. 

Note You need to log in before you can comment on or make changes to this bug.