Bug 4926 - S3: hang in 2nd suspend -- Thinkpad 600X
Summary: S3: hang in 2nd suspend -- Thinkpad 600X
Status: REJECTED DUPLICATE of bug 5037
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Shaohua
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-22 12:45 UTC by Sanjoy Mahajan
Modified: 2005-08-17 23:23 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.13-rc3
Tree: Mainline
Regression: ---


Attachments
Modified 600X DSDT (40.54 KB, application/octet-stream)
2005-07-22 12:54 UTC, Sanjoy Mahajan
Details

Description Sanjoy Mahajan 2005-07-22 12:45:19 UTC
Distribution: Debian testing (etch)

Hardware Environment: Thinkpad 600X, Pentium III 650 MHz, 576MB memory

Software Environment: using my hacked DSDT mentioned in Bug #3534 (will attach
in next msg) that allowed S3 to work with 2.6.11.4.  It's the IBM DSDT with the
compile errors fixed, though some of my fixes may not be right (but they got S3
working)!

Problem Description: After going to sleep with 'echo mem > /sys/power/state',
the system displays 'stopping tasks' and then goes to sleep mostly fine (the
suspend light goes on, although the disk drive light also goes on even though
the disk is quiet).  With 2.6.11.4, it would wake up either upon opening the lid
or pressing the 'Fn' key.  With 2.6.13-rc3, nothing wakes it up.  Holding the
power switch for several seconds turns the machine off, but to turn it back on I
have to remove the AC cord and the main and spare batteries, then power it back
on.  Otherwise it just ignores the power on.

Steps to reproduce:

Boot into multi-user mode (which gets all the ACPI modules loaded), then 

   echo mem > /sys/power/state
Comment 1 Sanjoy Mahajan 2005-07-22 12:54:09 UTC
Created attachment 5362 [details]
Modified 600X DSDT

Here's the DSDT I compiled into the kernel.  With 2.6.11.4 plus this DSDT, S3
mostly worked.
Comment 2 Sanjoy Mahajan 2005-07-22 16:40:42 UTC
Correction: The disk light goes on only after I try to wake it up
(e.g. by pressing the Fn key).  The screen flashes briefly, the disk
light turns on (though the disk doesn't spin), then the screen goes
blank and nothing happens.  In order to reboot, I have to fully power
cycle by removing the batteries and AC cord.

-Sanjoy

Comment 3 Sanjoy Mahajan 2005-07-28 14:18:34 UTC
With 2.6.13-rc3-mm2, it now goes to sleep (S3) and wakes up once, but the second
time I suspend, it will hang after the 'stopping tasks ===== ...' message.
This hang happens whether or not I boot with acpi_sleep=s3_bios 

The console display is still messed up upon wake up (using XFree86 server), but
X works fine (as long as it wakes up).
Comment 4 Len Brown 2005-08-14 22:27:32 UTC
did repeated suspend/resume cycles work with a previous kernel?
If yes, what is the most recent version before it broke?

Is this still an issue in 2.6.13-rc6?
Comment 5 Sanjoy Mahajan 2005-08-14 22:58:08 UTC
> did repeated suspend/resume cycles work with a previous kernel?

2.6.11.4 and 2.6.12.3.  

> If yes, what is the most recent version before it broke?

Before 2.6.11, S3 sleep/wake didn't work at all.

Repeated slep/wake cycles work with 2.6.13-rc6, if I don't use a
preemptible kernel.  The 2.6.11.4 and 2.6.12.3 kernels above were not
preemptible.  Definitely the non-preemtible are okay, and the fully
pre-emptible 2.6.13-rc6 breaks.  I'm still not sure whether a
medium-preemptible (voluntary preempt) 2.6.13-rc6 breaks.  I have been
using it for the last 24 hours and stressing it out to try and break
it but it's still doing fine.  See Bug #5037 for the details and
ongoing testing.

Comment 6 Len Brown 2005-08-17 12:42:36 UTC
thanks for re-testing.
I'm glad to hear the latest kernel w/o preempt works fine.

Seems like there is no unique failure described in this bug report --
shall we close it as a duplicate of bug 5037?
Comment 7 Sanjoy Mahajan 2005-08-17 13:24:07 UTC
> shall we close it as a duplicate of bug 5037?

Yes.

Comment 8 Shaohua 2005-08-17 23:23:01 UTC

*** This bug has been marked as a duplicate of 5037 ***

Note You need to log in before you can comment on or make changes to this bug.