Bug 4920 - IDE CD Driver not able to read audio CDs (Interrupt problem)
IDE CD Driver not able to read audio CDs (Interrupt problem)
Status: REJECTED INSUFFICIENT_DATA
Product: IO/Storage
Classification: Unclassified
Component: IDE
i386 Linux
: P2 normal
Assigned To: Alan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 11:19 UTC by David M. Lloyd
Modified: 2007-09-06 07:36 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.13-rc3
Tree: Mainline
Regression: Yes


Attachments
dmesg output (13.78 KB, text/plain)
2005-07-21 11:21 UTC, David M. Lloyd
Details
lspci output (8.73 KB, text/plain)
2005-07-21 11:22 UTC, David M. Lloyd
Details
Fedora IDE patch (82.16 KB, patch)
2005-07-21 22:24 UTC, Dan Carpenter
Details | Diff
Support PATA port on PDC2037x (4.07 KB, patch)
2005-08-05 07:52 UTC, Daniel Drake
Details | Diff
dmesg from 2.6.14-rc1 (13.84 KB, text/plain)
2005-09-15 21:31 UTC, David M. Lloyd
Details

Description David M. Lloyd 2005-07-21 11:19:01 UTC
Distribution: Gentoo Linux
Hardware Environment:
- ASUS P4C800-E Deluxe (Intel 875P-based P4 mobo)
- SONY CD-RW CRX220E1, ATAPI CD/DVD-ROM drive
- Intel ICH5R IDE controller (1 PATA drive, 1 ATAPI CDROM)
- Promise 20378 IDE controller (1 PATA drive)
- Other info (lspci, dmesg) attached
Software Environment:
- (kernel.org) Linux 2.6.13-rc3
- ide_cd module
- Other info (dmesg) attached
Problem Description:
Inserting or attempting to read an audio CD results in large amounts of:
hdc: cdrom_pc_intr: The drive appears confused (ireason = 0x01)

Data CDs are readable without a problem.
Hacking up ide-cd.c to ignore ireason=0x01 seems to make the problem go away,
but is doubtless the wrong solution (I have no idea what ireason of 0x01 means).

Steps to reproduce:
Hard to say; thus far I'm the only one I've ever heard of with this issue.  I
did try 4 different cables, both PATA ports on the Intel controller, and two
different CDROM drives with the same effect however.  I attempted to use the
Promise PATA controller, but the driver seems to not support ATAPI, at least by
default; it ignores the drive altogether.  I didn't dig in to it any further
than that.

I can only speculate that there's something about my disk controller that it
doesn't like.  I haven't yet tried downgrading to an earlier version to see when
this appeared; I'm fairly certain it worked under one of Gentoo's 2.6.9 kernels
though, if that helps (probably not) :)  The problem was also present in
2.6.12-gentoo-r4.  Again, this probably doesn't help much, but there you are.

If this is something obvious, good... otherwise let me know if you need me to
drill down to a specific kernel version where the problem is introduced, and
I'll schedule a weekend or something to do it.  In the meantime, I've got a
little patch in my kernel to ignore ireason=0x01.
Comment 1 David M. Lloyd 2005-07-21 11:21:08 UTC
Created attachment 5357 [details]
dmesg output

This is the dmesg output from 2.6.13-rc3.
Comment 2 David M. Lloyd 2005-07-21 11:22:08 UTC
Created attachment 5358 [details]
lspci output
Comment 3 Bartlomiej Zolnierkiewicz 2005-07-21 14:20:45 UTC
Please try to narrow down the problem to a specific kernel version
(and remember to obtain dmesg output for it).  Thanks.
Comment 4 Andrew Morton 2005-07-21 19:33:14 UTC
Yeah, someone else reported this a couple of months back.  I was staring at
the `ireason' code wondering why we seemed to be getting an impossible
result back from the drive.  I think I had some workaround patch, but the
reporter disappeared on me.  IIRC Jens was hiding from me at the time, so
we didn't end up fixing it ;)

I do think we'll end up needing some driver-level workaround for it, but if
you can help identify the kernel version where it went bad then that would help
us understand why earlier kernels weren't failing.
Comment 5 Dan Carpenter 2005-07-21 22:22:21 UTC
Apparently this bug was recently fixed in fedora.  

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154933

It can't hurt to try out their ide-cd patch, David.  I'll attach it for you.



Comment 6 Dan Carpenter 2005-07-21 22:24:49 UTC
Created attachment 5361 [details]
Fedora IDE patch

This applies against 2.6.12.2 btw.
Comment 7 Andrew Morton 2005-07-21 23:58:59 UTC
Oh fanbloodytastic.  RH have an 80k IDE jumbopatch, about half of which is in
mainline.

Dave, would it be possible to get at least the important bits of that into
2.6.13 please?
Comment 8 Adrian Bunk 2005-07-22 01:25:33 UTC
Looking at the patch, it seems to be mostly equivalent to the IDE changes in
2.6.11-ac7.
Comment 9 David M. Lloyd 2005-07-22 08:57:48 UTC
Well, assuming some nasty person doesn't make me work this weekend, I will
identify the kernel version, and mess around with the redhat stuff and alan's
stuff to see what I can find out.
Comment 10 David M. Lloyd 2005-07-23 19:49:27 UTC
Slight complication - I recently reorganized all my drives around booting from the PATA port on my Promise onboard controller.  So, 2.6.9 and 2.6.10 won't boot, until I move all my disks around.  Going to try 2.6.11 anyway, I'm not sure when PATA support was added to libata and/or promise_sata.
Comment 11 Daniel Drake 2005-08-05 07:50:36 UTC
Assuming its the controller I am thinking of, no mainline kernels support the
PATA port yet.

I will attach the patch that Gentoo have included since 2.6.10 to aid your testing.
Comment 12 Daniel Drake 2005-08-05 07:52:11 UTC
Created attachment 5518 [details]
Support PATA port on PDC2037x
Comment 13 David M. Lloyd 2005-08-05 17:26:46 UTC
Ok, thanks... will hopefully get to it this weekend.
Comment 14 Andrew Morton 2005-09-14 23:33:56 UTC
So it looks like Daniel's patch was kind of merged into 2.6.14-rc1 or earlier.

David, could you please retest that kernel?
Comment 15 David M. Lloyd 2005-09-15 16:37:36 UTC
OK, will try in the next few days.
Comment 16 David M. Lloyd 2005-09-15 20:08:32 UTC
...or hours.  Unfortunately, the PDC 2037x PATA support doesn't seem to work
correctly on 2.6.14-rc1.  It detects that there are two SATA and one PATA ports,
but it doesn't see the drive attached to the third port; kernel panic ensues.
Comment 17 David M. Lloyd 2005-09-15 21:26:45 UTC
Ok, hacked my way around that and am now running on 2.6.14-rc1 (the promise
driver now thinks it's using a 3-port pata controller with two very broken pata
ports ;-/).

Unfortunately, I got the "hdc: cdrom_pc_intr: The drive appears confused
(ireason = 0x01)" spam, only now there's not even an audio CD in the drive.
Comment 18 David M. Lloyd 2005-09-15 21:31:02 UTC
Created attachment 6042 [details]
dmesg from 2.6.14-rc1

No CD was in the drive while I booted.
Comment 19 David M. Lloyd 2005-09-15 21:46:17 UTC
Besides the dmesg spam, the results are the same as before: I can read the cdrom
that came with my iPod, but nothing on audio CD.
Comment 20 Daniel Drake 2005-09-17 10:02:39 UTC
Downstream bug report: http://bugs.gentoo.org/show_bug.cgi?id=99288
Comment 21 Natalie Protasevich 2007-07-08 16:29:18 UTC
Any updates on this problem? Is it all working now with recent kernels?
Thanks.
Comment 22 Adrian Bunk 2007-09-06 07:36:05 UTC
Please reopen this bug if it's still present with kernel 2.6.22.

Note You need to log in before you can comment on or make changes to this bug.