Bug 4919 - APM resume: freeze at disk access
APM resume: freeze at disk access
Status: REJECTED DUPLICATE of bug 7225
Product: Power Management
Classification: Unclassified
Component: APM
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 01:47 UTC by Fredrik St
Modified: 2007-04-28 12:49 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.11
Tree: Mainline
Regression: ---


Attachments

Description Fredrik St 2005-07-21 01:47:18 UTC
Distribution: Mandriva LE2005
Hardware Environment: Dell Inspiron 8200 + ATI Radeon 9000 Mobility
Software Environment: Kernel 2.6.11-6mdk / 2.6.11.11 / 2.6.12.1, apmd 3.2.2

Problem Description:
After suspending and resuming, the console comes back alright, but the computer
freezes at the first physical disk access.

APM suspend & resume works fine with Mandrake 10.0 + kernel 2.6.3-7mdk + apmd 3.1.0.

The same thing seems to happen with Inspiron 8200 + Fedora Core 3 + Nvidia, see
<http://groups.yahoo.com/group/linux-dell-laptops/message/25669>.

Steps to reproduce:
1) Boot with acpi=off into console
2) Suspend (apm -s or Fn+Esc or close lid)
3) Resume (press powerbutton)
4) Type any command that involves disk access
Comment 1 Andrew Morton 2005-07-21 08:47:52 UTC
How strange - APM resume normally does quie a bit of disk I/O anyway, doesn't it?

re you able to be more precise about when the kernel broke?  2.6.3->2.6.12
is rather a large step.
Comment 2 Fredrik St 2005-07-27 02:20:28 UTC
After lots of tests I finally found out that disabling the haldaemon service
solves the problem, at least from console. So it seems that it wasn't a kernel
issue after all. I still experience similar freezes occasionally when suspending
from X but that is probably another issue.
Comment 3 Andrew Morton 2005-07-29 00:57:26 UTC
Well the kernel sholdn't go freezing like that.   What
is the haldaemon service??
Comment 4 Anonymous Emailer 2005-07-29 02:11:34 UTC
Reply-To: akpm@digeo.com


just testing something...

Comment 5 Fredrik St 2005-07-30 01:20:27 UTC
The haldaemon service is new to me too. I cannot find any real documentation but
there is a homepage at <http://www.freedesktop.org/Software/hal>. The following
is from the MandrivaClub knowledge base:

"HAL is a Hardware Abstraction Layer. The purpose of HAL is to allow programs to
interface with common hardware types in a generic manner. It is a vital
component of Mandrakelinux 10.1, Mandriva Linux Limited Edition 2005 and later
releases, and should not be disabled.
Pertinence: Essential. Package: hal. Doc: files in /usr/share/doc/hal-0.4.8."

I've added haldaemon to the services to be stopped at suspend and restarted at
resume. Also, the occasional hangs when suspending from X have stopped after I
set a switch in the suspend script causing the pcmcia card to eject instead of
suspending. It seems to work now, but I should try it out a few more days I think.
Comment 6 Wouter Cloetens 2005-08-06 05:51:08 UTC
Not sure if this is the same problem, but it certainly sounds very similar, so
I'm going to add my case to this bug.
Thinkpad R51 (1529-EHG), Debian Testing, vanilla kernel.org kernels, with and
without ipw2100 driver.
I'm using ACPI, not APM.
Suspend & resume to memory works fine with 2.6.7.
With 2.6.10, 2.6.11 and 2.6.12, on resume, the system hangs dead with the IDE
activity led on solid.
I'm now running 2.6.12.3 with the radeon suspend patch in bug 3022.
After reading this bug report, I added /etc/dbus-1/event.d/20hal stop and start
to my /etc/acpi/lid.sh. This seems to have fixed the problem.
Comment 7 Fredrik St 2006-09-27 23:45:13 UTC
I've been using the above configuration on my Dell Inspiron 8200 for almost a
year, and then upgraded to Mandriva 2006 which was entirely similar. apm suspend
has been working most of the time, but I still experienced occasional hangs.

I'm now running Ubuntu 6.06 Dapper instead. There are no problems with hal
anymore, but I had to write a small console switching script since APM suspend
only works from console for some reason. This was not the case with Mandriva
LE2005. APM suspend has worked flawlessly for a few weeks now but I don't use
this computer much anymore so it's still too early to tell.

It's strange that Wouter Cloetens had the same problem with hal using ACPI
suspend. I've spent some time trying to get ACPI to work with the Inspiron 8200
but the Radeon 9000 Mobility video never comes back properly. None of the
patches or tricks that I have found works properly. But this was only a video
issue, all other things worked well, hal included.
Comment 8 Rafael J. Wysocki 2006-09-29 02:48:33 UTC
You can try to use the s2ram tool to solve the video-after-resume problem with
the ACPI suspend (see http://en.opensuse.org/S2ram).
Comment 9 Rafael J. Wysocki 2006-10-25 09:58:31 UTC

*** This bug has been marked as a duplicate of 7225 ***

Note You need to log in before you can comment on or make changes to this bug.