Bug 49161 - Kernel 3.4 + on Samsung Ultrabook Series 9 - Machine Check Exception
Kernel 3.4 + on Samsung Ultrabook Series 9 - Machine Check Exception
Status: RESOLVED DUPLICATE of bug 47121
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
x86-64 Linux
: P1 blocking
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 19:45 UTC by Tu Hoang
Modified: 2012-11-21 17:09 UTC (History)
5 users (show)

See Also:
Kernel Version: linux-3.4 +
Tree: Mainline
Regression: Yes


Attachments

Description Tu Hoang 2012-10-20 19:45:56 UTC
I am running Archlinux with UEFI boot on Samsung Ultrabook series 9. With kernel above 3.4, the kernel panics due to a machine check exception very early during the boot process with both systemd and initscripts:

    http://i.imgur.com/P6hPK.jpg
    http://i.imgur.com/GGX6t.jpg

Any kernel under 3.4 works fine. The latest kernel I am able to use is:

Linux version 3.3.8-1-ARCH (tobias@T-POWA-LX) (gcc version 4.7.0 20120505 (prerelease) (GCC) ) #1 SMP PREEMPT Tue Jun 5 15:20:32 CEST 2012

System and motherboard info:

  System Info: #1
    Manufacturer: "SAMSUNG ELECTRONICS CO., LTD."
    Product: "900X3C/900X3D/900X4C/900X4D"
    Version: "0.1"
    Serial: "HU7M91GC601769"
    UUID: undefined, but settable
    Wake-up: 0x06 (Power Switch)
  Board Info: #2
    Manufacturer: "SAMSUNG ELECTRONICS CO., LTD."
    Product: "SAMSUNG_NP1234567890"
    Version: "FAB1"
    Serial: "123490EN400015"
    Asset Tag: "Base Board Asset Tag"
    Type: 0x0a (Motherboard)
    Features: 0x09
      Hosting Board
      Replaceable
    Location: "Part Component"

CPU info:

[tahoang@colossus-arch ~]$ cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 58
model name      : Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
stepping        : 9
microcode       : 0x12
cpu MHz         : 1696.027
cache size      : 3072 KB
physical id     : 0
siblings        : 4
core id         : 0
cpu cores       : 2
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips        : 3393.38
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

I looked online and found a couple other people experiencing the same issue on the same hardware but no resolution was posted. I am not sure whether this is because of my hardware or not. Please let me know if you need any other information.

Thank you for your attention!
Comment 1 H. Peter Anvin 2012-10-22 21:06:44 UTC
From the address I would guess this is yet another brilliant OEM who have programmed the legacy region to trigger MCEs in UEFI mode, which just isn't going to work right.
Comment 2 Tu Hoang 2012-10-23 03:25:54 UTC
(In reply to comment #1)
> From the address I would guess this is yet another brilliant OEM who have
> programmed the legacy region to trigger MCEs in UEFI mode, which just isn't
> going to work right.

So is there any chance that we are going to implement a fix for this?
Comment 3 Alan 2012-10-23 10:37:56 UTC
I think you'll need to ask Samsung that
Comment 4 Tu Hoang 2012-10-26 21:02:11 UTC
Well, this is the response from Samsung:

"We are sorry; we do not have any information about the Linux operating system that is installed on your Notebook. We recommend you contact the Linux support with the hardware specifications of the laptop for further assistance."

@Peter: Could you elaborate more about the issue?
Comment 5 Helge 2012-11-21 12:59:17 UTC
I'm having a similar issue w/ my Lenovo Thinkpad Edge E330. Since I'm also booting in UEFI mode I was wondering if booting via CSM could possibly work around this issue? Any thoughts on this?
Comment 6 Randolph Maaßen 2012-11-21 13:03:28 UTC
Hi,

I have a similar Samsung series 9 laptop, but with the i7 CPU.

I got the same mce-failure during ubuntu boot, but only when boot to internal hdd is eabled in bios. if I disable he boot entrys in biso with ! the system runs normal. I got no clue what this can be about.

Randolph
Comment 7 Tu Hoang 2012-11-21 17:09:44 UTC
Hi,

I just found out that there was an identical bug that was reported [47121]. The other bug was closed as RESOLVED WILL_NOT_FIX. In short, the root cause of the issue is samsung-laptop kernel module. It's loaded in kernel 3.4+ by udev after udev detects that the host machine is a samsung laptop. Seems like samsung-laptop writes into a memory region that it is not supposed to. samsung-laptop essentially enables things like laptop backlight under low light.

Since the bug was closed as WILL_NOT_FIX, the solution right now is to blacklist the kernel module so that it won't be loaded and also remove other tools that make direct use of it (so that it won't be loaded by those tools, in my case samsung-tools).

*** This bug has been marked as a duplicate of bug 47121 ***

Note You need to log in before you can comment on or make changes to this bug.