Bug 4889 - PCI: device 0000:07:00.0 has unknown header type 37, ignoring.
PCI: device 0000:07:00.0 has unknown header type 37, ignoring.
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: PCI
i386 Linux
: P2 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 5829
  Show dependency treegraph
 
Reported: 2005-07-15 09:23 UTC by Martin Mokrejs
Modified: 2006-05-09 05:09 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.13-rc3-git2
Tree: Mainline
Regression: ---


Attachments
with ACPI enabled (20.99 KB, text/plain)
2005-07-15 09:24 UTC, Martin Mokrejs
Details
without ACPI (17.84 KB, text/plain)
2005-07-15 09:25 UTC, Martin Mokrejs
Details
2.4.31 with ACPI (17.02 KB, text/plain)
2005-07-15 09:47 UTC, Martin Mokrejs
Details
with acpi-20050708 (21.69 KB, text/plain)
2005-07-16 01:40 UTC, Martin Mokrejs
Details
2.6.13 acpi=off (33.82 KB, text/plain)
2005-09-01 09:03 UTC, Martin Mokrejs
Details
2.6.13 pci=routeirq (37.88 KB, text/plain)
2005-09-01 09:04 UTC, Martin Mokrejs
Details
2.6.13 acpi=off pci=usepirqmask (33.80 KB, text/plain)
2005-09-01 09:05 UTC, Martin Mokrejs
Details
2.6.13 (36.91 KB, text/plain)
2005-09-01 09:39 UTC, Martin Mokrejs
Details
dmesg-2.6.16-rc5 (40.54 KB, text/plain)
2006-04-06 01:21 UTC, Martin Mokrejs
Details

Description Martin Mokrejs 2005-07-15 09:23:19 UTC
Distribution:
Hardware Environment:

ASUS L3000C laptop with PCMCIA USB2.0/Firewire card Kowell KW-7004

Software Environment:
Problem Description:

The card is not detected. Upon insert I get:

PCI: device 0000:07:00.0 has unknown header type 37, ignoring.

Steps to reproduce:
Comment 1 Martin Mokrejs 2005-07-15 09:24:47 UTC
Created attachment 5336 [details]
with ACPI enabled

Contains dmesg, lspci -v and /proc/interrupts
Comment 2 Martin Mokrejs 2005-07-15 09:25:21 UTC
Created attachment 5337 [details]
without ACPI

Contains dmesg, lspci -v and /proc/interrupts
Comment 3 Martin Mokrejs 2005-07-15 09:47:28 UTC
Created attachment 5338 [details]
2.4.31 with ACPI

With 2.4.31 kernel I get completely different errors.
Comment 4 Adrian Bunk 2005-07-15 12:49:59 UTC
Is this a new problem in 2.6.13-rc3-git2 or is it also present in kernel 2.6.12?
Comment 5 Martin Mokrejs 2005-07-15 13:15:18 UTC
I have seen this problem some time ago, but do not know exactly when was it
introduced. But it is definitely not new. The card never worked fine, true. Be
it 2.4.18 or later. But at the moment its is very weird behaviour.

Here it was detected on PCI under 2.6.3-bk2, see comment #21:
http://bugzilla.kernel.org/show_bug.cgi?id=1904
http://bugzilla.kernel.org/show_bug.cgi?id=2068

But I had very same PCI problem on 2.4.29-pre2:
http://marc.theaimsgroup.com/?l=linux-kernel&m=110337968920795&w=2
Comment 6 Martin Mokrejs 2005-07-15 13:34:43 UTC
Well, 2.6.11.6 gives same error message. One more old kernel I have left on my
laptop, and the gives a different error (2.6.10-rc3-bk8):

PCI: Error while updating region 0000:07:00.0/6 (40c00000 != 40c00020)
PCI: Error while updating region 0000:07:00.1/6 (40c01000 != 40c01020)
PCI: Error while updating region 0000:07:00.2/6 (40c02000 != 40c02020)
PCI: Error while updating region 0000:07:00.3/6 (40c03000 != 40c03020)
PCI: Error while updating region 0000:07:00.4/6 (40c03800 != 40c03820)
PCI: Error while updating region 0000:07:00.0/4 (00004801 != 523710b9)
PCI: Error while updating region 0000:07:00.1/4 (00004821 != 00000020)
PCI: Error while updating region 0000:07:00.2/4 (00004841 != 523710b9)
PCI: Error while updating region 0000:07:00.3/4 (00004861 != 00000020)
PCI: Error while updating region 0000:07:00.4/4 (00004881 != 525310b9)
PCI: Error while updating region 0000:07:00.0/5 (41003900 != 00000020)
PCI: Error while updating region 0000:07:00.1/5 (41003910 != 82b00130)
PCI: Error while updating region 0000:07:00.2/5 (41003920 != 82b00120)
PCI: Error while updating region 0000:07:00.3/5 (41003930 != 82b00130)
PCI: Error while updating region 0000:07:00.4/5 (41003940 != 82b00160)
PCI: Enabling device 0000:07:00.0 (0000 -> 0003)
ohci_hcd 0000:07:00.0: Found HC with no IRQ.  Check BIOS/PCI 0000:07:00.0 setup!
PCI: Enabling device 0000:07:00.1 (0110 -> 0113)
ohci_hcd 0000:07:00.1: Found HC with no IRQ.  Check BIOS/PCI 0000:07:00.1 setup!
PCI: Enabling device 0000:07:00.2 (0100 -> 0103)
ohci_hcd 0000:07:00.2: Found HC with no IRQ.  Check BIOS/PCI 0000:07:00.2 setup!
PCI: Enabling device 0000:07:00.3 (0110 -> 0113)
ehci_hcd 0000:07:00.3: Found HC with no IRQ.  Check BIOS/PCI 0000:07:00.3 setup!
ieee1394: Initialized config rom entry `ip1394'
ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>
ACPI: PCI interrupt 0000:02:07.2[C] -> GSI 3 (level, low) -> IRQ 3
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[3]  MMIO=[d6000000-d60007ff]  Max
Packet=[2048]
PCI: Enabling device 0000:07:00.4 (0140 -> 0143)
PCI: Setting latency timer of device 0000:07:00.4 to 64
ohci1394: Failed to allocate shared interrupt 0
ohci1394: probe of 0000:07:00.4 failed with error -12
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00e018000305e5fc]
eth1394: $Rev: 1224 $ Ben Collins <bcollins@debian.org>
eth1394: eth1: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)


And corresponding lspci output:

# lspci
0000:00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host
Bridge (rev 04)
0000:00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP
Bridge (rev 04)
0000:00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #1) (rev 02)
0000:00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #2) (rev 02)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
0000:00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
0000:00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 (rev 02)
0000:00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97
Audio Controller (rev 02)
0000:00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 02)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7
LW [Radeon Mobility 7500]
0000:02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
0000:02:07.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev a8)
0000:02:07.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev a8)
0000:02:07.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller
0000:07:00.0 USB Controller: Samsung Electronics Co., Ltd: Unknown device 5237
(rev 03)
0000:07:00.1 USB Controller: Samsung Electronics Co., Ltd: Unknown device 5237
(rev 03)
0000:07:00.2 USB Controller: Samsung Electronics Co., Ltd: Unknown device 5237
(rev 03)
0000:07:00.3 USB Controller: Samsung Electronics Co., Ltd: Unknown device 5239
(rev 01)
0000:07:00.4 FireWire (IEEE 1394): Samsung Electronics Co., Ltd: Unknown device 52
#

Someone (luk@arpartner.cz) said it has some chipset VT6306 , same as KW-7002.
Few details are at http://www.kouwell.com.tw/allp4.htm
Comment 7 Martin Mokrejs 2005-07-15 14:24:24 UTC
When PCI debug and PCMCIA debug are enabled, I get:

PCI: Found 0000:07:00.0 [1099/5237] 000c03 37
PCI: device 0000:07:00.0 has unknown header type 37, ignoring.

I have tested 1.18 BIOS and 1.21 (latest).
Comment 8 Martin Mokrejs 2005-07-16 01:40:12 UTC
Created attachment 5340 [details]
with acpi-20050708

Latest ACPI patches don't help.
Comment 9 Greg Kroah-Hartman 2005-08-04 13:15:42 UTC
Can you try Linus's latest git tree?  A fix went in that should solve this issue.
Comment 10 Martin Mokrejs 2005-08-04 14:32:08 UTC
2.6.13-rc5-git2 doesn't help.
Comment 11 Martin Mokrejs 2005-08-07 09:34:06 UTC
Still same problem with 2.6.13-rc5-git4.
Comment 12 Greg Kroah-Hartman 2005-08-18 13:52:32 UTC
Still a problem in 2.6.13-rc6-git9 or later?
Comment 13 Martin Mokrejs 2005-08-18 14:43:31 UTC
Still problem on 2.6.13-rc6-git10.
Comment 14 Martin Mokrejs 2005-09-01 09:03:47 UTC
Created attachment 5845 [details]
2.6.13 acpi=off
Comment 15 Martin Mokrejs 2005-09-01 09:04:35 UTC
Created attachment 5846 [details]
2.6.13 pci=routeirq
Comment 16 Martin Mokrejs 2005-09-01 09:05:20 UTC
Created attachment 5847 [details]
2.6.13 acpi=off pci=usepirqmask
Comment 17 Martin Mokrejs 2005-09-01 09:09:48 UTC
All these 3 attachments contain dmesg and lspci output from 2.6.13 kernel having
the "[PATCH] x86: pci_assign_unassigned_resources() update" from Ivan Kokshaysky
applied:

2.6.13 acpi=off  	text/plain  	2005-09-01 09:03 
2.6.13 pci=routeirq 	text/plain 	2005-09-01 09:04
2.6.13 acpi=off pci=usepirqmask 	text/plain 	2005-09-01 09:05 	

The appeared in 2.6.13-git2:
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=81d4af1340badcd2100c84fbd1bfd13156de41aa

Basically, it did not help either. ;)
Comment 18 Martin Mokrejs 2005-09-01 09:39:07 UTC
Created attachment 5848 [details]
2.6.13

with no extra flags
Comment 19 Martin Mokrejs 2005-10-14 09:17:59 UTC
So I finaly decided to open the PCMCIA card to find the chipset. It is ALI 5271
chip and also some 37AXNJTC / TSB41AB2 chip. It seems physically very similar
card is also this one, also not working under linux:

http://www.syba.com/product/43/05/01/
http://groups.google.com/group/comp.os.linux.portable/browse_thread/thread/1dbaa1f298a5642f/14b36170973206f7?lnk=st&q=ALI+M5271+linux&rnum=1&hl=en#14b36170973206f7

So, where can I get the "Orangeware USB Driver"?
Comment 20 Greg Kroah-Hartman 2005-10-14 11:24:29 UTC
Heh, I have no idea, sorry.  I'm guessing this falls into the "doesn't work on
Linux" class of devices :(
Comment 21 Greg Kroah-Hartman 2006-01-04 14:39:33 UTC
Closing as there is nothing we can do here, sorry.
Comment 22 Martin Mokrejs 2006-04-06 01:16:38 UTC
The card I had originally got physically broken. Maybe that was teh reason for
the "PCI: device 0000:07:00.0 has unknown header type 37, ignoring" message. In
the past I have 2 these cards (teh other for another person) and that's the card
I am testing now: it works in 2.6.16-rc5. I will attach the full dmesg output
just in case someone would think it does not work still.
Comment 23 Martin Mokrejs 2006-04-06 01:21:57 UTC
Created attachment 7784 [details]
dmesg-2.6.16-rc5

I have connected a 7-in-one card reader to read my 128MB smartmedia card. That
is maybe the cause why the "scsi emulated" disk got detected as 0:0:0:0. The
attempts to mount it forced kernel to fail and re-detect it, that time
correctly as 2:0:0:0.
Comment 24 Greg Kroah-Hartman 2006-05-08 14:52:21 UTC
Great, so it all works fine now?

Am closing.
Comment 25 Martin Mokrejs 2006-05-09 05:09:31 UTC
Yes, it works.

Note You need to log in before you can comment on or make changes to this bug.