Bug 48811 - lpc_ich: Resource conflict(s) found affecting gpio_ich
Summary: lpc_ich: Resource conflict(s) found affecting gpio_ich
Status: CLOSED INVALID
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_config-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-15 10:42 UTC by Andrey Ovcharov
Modified: 2014-01-05 13:47 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.6.2
Tree: Mainline
Regression: No


Attachments
all need info + broken dmesg on 3.6.2 (112.16 KB, application/octet-stream)
2012-10-15 10:49 UTC, Andrey Ovcharov
Details

Description Andrey Ovcharov 2012-10-15 10:42:25 UTC
After applying this patch:
https://bugzilla.kernel.org/show_bug.cgi?id=44991

which fixes:
lpc_ich: Resource conflict(s) found affecting iTCO_wdt https://bugzilla.kernel.org/show_bug.cgi?id=44991

I see the following in dmesg:

[    2.681024] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20120711/utaddress-251) 
[    2.681032] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver 
[    2.681035] ACPI Warning: 0x00000000000011b0-0x00000000000011bf SystemIO conflicts with Region \GPIO 1 (20120711/utaddress-251) 
[    2.681040] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver 
[    2.681042] ACPI Warning: 0x0000000000001180-0x00000000000011af SystemIO conflicts with Region \GPIO 1 (20120711/utaddress-251) 
[    2.681047] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver 
[    2.681048] lpc_ich: Resource conflict(s) found affecting gpio_ich
Comment 1 Andrey Ovcharov 2012-10-15 10:49:00 UTC
Created attachment 83501 [details]
all need info + broken dmesg on 3.6.2
Comment 2 Jean Delvare 2012-10-15 11:41:37 UTC
These messages are informative only and are expected if your BIOS has requested the GPIO pins for its own use. This isn't a bug and there's nothing to worry about.
Comment 3 Andrey Ovcharov 2012-10-15 11:44:41 UTC
https://bugzilla.kernel.org/show_bug.cgi?id=44991#c21

>This is the commit log, as it pointed out, it only fixes the iTCO_wdt problem,
>and doesn't touch other warning for "gpio_ich".

>If anybody see problem with this "gpio_ich", please create a new bugzilla to 
>trace that. thanks,
Comment 4 Jean Delvare 2012-10-15 11:50:48 UTC
The fix for bug #44991 is bad and I certainly don't want to do the same for gpio-ich. I presume the bug was reported for iTCO_wdt because users lost a feature (watchdog support) and wanted it back, but GPIO support for the ICH did not exist before (so this is no regression) and most systems and users don't need to access the GPIO pins. So I believe this is a non-issue in practice.

Agreed, these log messages can be bothersome, and given the number of complains we already received about them, we certainly should do something to improve the wording, but this is a general issue with ACPI resource conflict reporting, not specific to gpio-ich.
Comment 5 KernelBug 2013-07-07 23:00:56 UTC
Hi,

I don't know if this was supposed to been fixed, but I just compiled 3.9.9 and I'm seeing this message also in  /var/log/dmesg;

lpc_ich: Resource conflict(s) found affecting gpio_ich


THANKS
Comment 6 Jean Delvare 2013-07-08 05:16:52 UTC
This is an informative message, nothing to be fixed. Which is why this bug is closed as invalid.
Comment 7 KernelBug 2013-07-09 05:01:54 UTC
Sorry for being dense here, but if this is just informative, then why is it telling us this 'conflict(s)' and is affecting? To me this seem like it's causing an issue with that message...

THANKS
Comment 8 Arul Selvan 2013-12-29 17:51:54 UTC
Jean Delvare,

I understand this is informational and that the bug is already closed. However, I am wondering can|if the gpio_ich module use these pins if there are conflicts? For me (3.11.0-14-generic kernel), the gpio_ich module loads w/ out any error, however, I don't see anything in /sys/class/ for gpio, and also no mention of gpio_ich in dmesg.

Based on your commit log below (assuming your fix is included in my 3.11.0-14-generic kernel), it should work right?

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=4f600ada70beeb1dfe08e11e871bf31015aa0a3d


Thanks
-Arul
Comment 9 Jean Delvare 2014-01-05 13:47:53 UTC
This is not a support forum, sorry. If you need help, use support forums and mailing lists.

Note You need to log in before you can comment on or make changes to this bug.