Bug 4877 - NIC fails to initialize using sk98lin driver
Summary: NIC fails to initialize using sk98lin driver
Status: REJECTED WILL_NOT_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Stephen Hemminger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-12 17:55 UTC by Ryan Showalter
Modified: 2006-04-25 14:25 UTC (History)
0 users

See Also:
Kernel Version: 2.6.12.2
Tree: Mainline
Regression: ---


Attachments

Description Ryan Showalter 2005-07-12 17:55:54 UTC
Distribution:  Kernel 2.6.12.2 running in x86_64 mode
Hardware Environment:  On-board LAN Gigabyte GA-K8NS Pro nForce3
Software Environment:  
Problem Description:

The on-board ethernet controller is recognized by the sk98lin driver, however,
the driver fails to initialize the ethernet port (link does not occur).  It
worked fine in kernel 2.6.11.  Dmesg reports no trace of errors and reports that
the driver has sucessfully loaded and even ifconfig seems to think that
everything is fine.  However, it does not send or recieve any packets, and the
LEDs inside the port never turn on.

eth0      Link encap:Ethernet  HWaddr 00:0D:61:71:5E:2B  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:185 Memory:ed040000-0



Steps to reproduce:  Boot kernel 2.6.12.2 ; modprobe sk98lin
Comment 1 Stephan Huiser 2005-08-14 15:00:15 UTC
Same problem here.

kernel-version:
2.6.13-rc5

lspci:
0000:00:0f.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Gigabit
Ethernet 10/100/1000Base-T Adapter (rev 12)

module:
sk98lin / skge
Comment 2 Stephen Hemminger 2006-01-18 11:28:24 UTC
There are two drivers with same PCI table.
Please do:
         ethtool -i eth0
to see which one is using the card.
Comment 3 Stephen Hemminger 2006-04-11 09:49:04 UTC
How much memory is present? There is a bug with 4G or more of memory.
Comment 4 Stephen Hemminger 2006-04-25 14:25:19 UTC
Looks like administration confusion when sk98lin and skge are both
loaded at the same time.  This is an administration problem best solved
by blacklisting one of the modules using the modutils.

I suggest adding the following to modprobe.conf

blacklist sk98lin

and using the newer supported skge driver.

Note You need to log in before you can comment on or make changes to this bug.