Bug 4876 - porting_sony_acpi_to_generic_driver.patch
porting_sony_acpi_to_generic_driver.patch
Status: REJECTED DUPLICATE of bug 5749
Product: Drivers
Classification: Unclassified
Component: Platform
i386 Linux
: P2 normal
Assigned To: Luming Yu
:
: 4193 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-12 07:53 UTC by Luming Yu
Modified: 2010-10-08 18:16 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6
Tree: Mainline
Regression: ---


Attachments
scratch version (3.74 KB, patch)
2005-07-12 07:54 UTC, Luming Yu
Details | Diff
porting sony-acpi.c to generic hotkey solution (12.24 KB, patch)
2005-09-05 01:09 UTC, Luming Yu
Details | Diff

Description Luming Yu 2005-07-12 07:53:18 UTC
this patch transition specific sony_acpi drvier to use generic acpi hotkey 
infrastructure.
Comment 1 Luming Yu 2005-07-12 07:54:38 UTC
Created attachment 5316 [details]
scratch version
Comment 2 Andrew Morton 2005-07-12 12:40:56 UTC
It's unusual to submit a patch via bugzilla.

I suggest you email the patch to Len and myself.  See
http://www.zip.com.au/~akpm/linux/patches/stuff/tpp.txt
Comment 3 Luming Yu 2005-08-18 08:15:45 UTC
*** Bug 4193 has been marked as a duplicate of this bug. ***
Comment 4 Luming Yu 2005-09-05 01:09:42 UTC
Created attachment 5897 [details]
porting sony-acpi.c to generic hotkey solution

update patch agains linux-2.6.13
I tested it on sony Z1 with
1. get brighness supported.
	echo "10001:1:1:0" >/proc/acpi/hotkey/action
	cat /proc/acpi/hotkey/10001
2. change brightness 
min: 
	echo "10001:0:1:1" > /proc/acpi/hotkey/action  
max:
	echo "10001:0:1:8" > /proc/acpi/hotkey/action
Comment 5 Luming Yu 2005-09-06 23:54:20 UTC
mask it as resolved.  
 
To-do: 
1. hook sonpyi interrupt 
Comment 6 Luming Yu 2005-12-16 01:09:56 UTC

*** This bug has been marked as a duplicate of 5749 ***

Note You need to log in before you can comment on or make changes to this bug.