Bug 48521 - I/O space for GPIO uninitialized notification appears during boot
I/O space for GPIO uninitialized notification appears during boot
Status: RESOLVED CODE_FIX
Product: Other
Classification: Unclassified
Component: Modules
All Linux
: P1 normal
Assigned To: Peter Tyser
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 19:32 UTC by Matías de la Cruz
Modified: 2013-03-18 16:41 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.5.5-1
Tree: Mainline
Regression: No


Attachments

Description Matías de la Cruz 2012-10-06 19:32:09 UTC
1. I/O space for GPIO uninitialized notification appears during boot


2.
During boot process, at the 'Waiting for udev uevents to be processed' 
stage, the following notification (with different code each time) 
appears,

[    9.220210] lpc_ich 0000:00:1f.0: I/O space for GPIO uninitialized


3. Keywords: 

lpc_ich module

(Other users report the lpc_sch module - See https://bbs.archlinux.org/viewtopic.php?pid=1161589#p1161589)


4.  Kernel version (from /proc/version):

Linux version 3.5.5-1-ARCH (tobias@testing) (gcc version 4.7.1 20120721 (prerelease) (GCC) ) #1 SMP PREEMPT Tue Oct 2 22:33:30 CEST 2012


7.1 Software (add the output of the ver_linux script here)

http://pastebin.com/F7SUeWnX


7.2 Processor information (from /proc/cpuinfo):

http://pastebin.com/UEsHXRDM


7.3 Module information (from /proc/modules):

http://pastebin.com/4RdvQe31


7.4 Loaded driver and hardware information (/proc/ioports, /proc/iomem)

ioports: http://pastebin.com/xZss5U0A

iomem: http://pastebin.com/NbppGktC


7.5 PCI information ('lspci -vvv' as root)

http://pastebin.com/Tnc9p0fz


7.6 SCSI information (from /proc/scsi/scsi)

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: ATA      Model: IC25N030ATMR04-0 Rev: MOAO
Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi1 Channel: 00 Id: 00 Lun: 00
Vendor:          Model: DVD RW RW8160    Rev: 1.08
Type:   CD-ROM                           ANSI  SCSI revision: 05
Comment 1 Matías de la Cruz 2012-10-24 20:09:46 UTC
Still active for 3.6.3-1-ARCH kernel
Comment 2 Matías de la Cruz 2012-11-08 04:20:50 UTC
Still active for 3.6.6-1-ARCH kernel
Comment 3 Matías de la Cruz 2012-11-26 15:06:55 UTC
Still active for 3.6.7-1-ARCH kernel
Comment 4 Matías de la Cruz 2012-12-03 20:47:49 UTC
Still active for 3.6.8-1-ARCH kernel
Comment 5 Matías de la Cruz 2012-12-09 00:55:18 UTC
Still active for 3.6.9-1-ARCH kernel
Comment 6 Matías de la Cruz 2012-12-15 01:11:57 UTC
Still active for 3.6.10-1-ARCH kernel
Comment 7 Matías de la Cruz 2013-01-03 20:52:16 UTC
Still active for 3.6.11-1-ARCH kernel
Comment 8 Matías de la Cruz 2013-01-22 02:09:17 UTC
Still active for 3.7.3-1-ARCH kernel
Comment 9 Matías de la Cruz 2013-01-25 04:00:33 UTC
Still active for 3.7.4-1-ARCH kernel
Comment 10 Matías de la Cruz 2013-02-02 19:42:40 UTC
Still active for 3.7.5-1-ARCH kernel
Comment 11 Matías de la Cruz 2013-02-09 06:41:58 UTC
Still active for 3.7.6-1-ARCH kernel
Comment 12 Matías de la Cruz 2013-02-13 04:24:02 UTC
Still active for 3.7.7-1-ARCH kernel
Comment 13 Matías de la Cruz 2013-02-17 01:23:50 UTC
Still active for 3.7.8-1-ARCH kernel
Comment 14 Peter Tyser 2013-02-17 19:41:16 UTC
Thanks for the detailed bug report.

This message was changed from an error message to a notice message in the following commit:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=0c418844dce21fa7000b51190f393c7d6a7ee12d

The change should result in you not seeing this message on bootup, although it will still be in your dmesg log for informational purposes.  This commit has been merged in for the upcoming 3.8 kernel, but is not present in 3.7 or earlier versions.

The message indicates that the BIOS on your PC did not configure the Intel bridge's GPIO controller present on your hardware.  The fact that the BIOS didn't configure the GPIO controller on your PC isn't a problem, it just means you can't use the Intel bridge's GPIO pins.

Can you see if a 3.8-rc kernel resolves the message?  Alternatively you can wait until kernel 3.8 is officially released.
Comment 15 Matías de la Cruz 2013-02-19 05:14:49 UTC
I am not much into testing rc kernels honestly thus I will wait for the official release to update you on this issue.
Comment 16 Matías de la Cruz 2013-03-18 16:37:52 UTC
I just updated to 3.8.3-2-ARCH kernel and I can confirm that the error/notice message does not appear anymore during the boot process. 
In the same way I can confirm that it still appears for informational purposes not in the dmesg log but in the systemd journal as this is a systemd setup I am using.
Comment 17 Peter Tyser 2013-03-18 16:41:39 UTC
Thanks for the testing Matías.  I'll close the bug as the issue is resolved in kernel version 3.8.

Note You need to log in before you can comment on or make changes to this bug.