Bug 4837 - [2.6.13-rc1] Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424
Summary: [2.6.13-rc1] Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: other_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-03 20:36 UTC by SteveB
Modified: 2007-08-27 20:47 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.13-rc1
Tree: Mainline
Regression: ---


Attachments
config 2.6.13rc3 (59.19 KB, text/plain)
2005-07-31 08:12 UTC, tobias
Details

Description SteveB 2005-07-03 20:36:40 UTC
Distribution:   
Gentoo Linux  
   
Hardware Environment:   
0000:00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host   
bridge (rev 03)   
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-   
Stepping- SERR- FastB2B-   
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-   
<TAbort- <MAbort+ >SERR- <PERR-   
        Latency: 64   
        Region 0: Memory at e4000000 (32-bit, prefetchable)   
        Capabilities: [a0] AGP version 1.0   
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans-   
64bit- FW- AGP3- Rate=x1,x2   
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW-   
Rate=<none>   
   
0000:00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP   
bridge (rev 03) (prog-if 00 [Normal decode])   
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-   
Stepping- SERR+ FastB2B-   
        Status: Cap- 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-   
<TAbort- <MAbort- >SERR- <PERR-   
        Latency: 64   
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64   
        I/O behind bridge: 0000d000-0000dfff   
        Memory behind bridge: e0000000-e1ffffff   
        Prefetchable memory behind bridge: e2000000-e3ffffff   
        Expansion ROM at 0000d000 [disabled] [size=4K]   
        BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B+   
   
0000:00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)   
        Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr-   
Stepping- SERR- FastB2B-   
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-   
<TAbort- <MAbort- >SERR- <PERR-   
        Latency: 0   
   
0000:00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)   
(prog-if 80 [Master])   
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-   
Stepping- SERR- FastB2B-   
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-   
<TAbort- <MAbort- >SERR- <PERR-   
        Latency: 64   
        Region 4: I/O ports at f000 [size=16]   
   
0000:00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)   
(prog-if 00 [UHCI])   
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-   
Stepping- SERR- FastB2B-   
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-   
<TAbort- <MAbort- >SERR- <PERR-   
        Latency: 64   
        Interrupt: pin D routed to IRQ 10   
        Region 4: I/O ports at e000 [size=32]   
   
0000:00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)   
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-   
Stepping- SERR- FastB2B-   
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-   
<TAbort- <MAbort- >SERR- <PERR-   
        Interrupt: pin ? routed to IRQ 9   
   
0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)   
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-   
Stepping- SERR- FastB2B-   
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-   
<TAbort- <MAbort- >SERR- <PERR-   
        Interrupt: pin A routed to IRQ 10   
        Region 0: I/O ports at e400   
   
0000:01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA TNT2/TNT2   
Pro] (rev 11) (prog-if 00 [VGA])   
        Subsystem: Diamond Multimedia Systems Viper V770   
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-   
Stepping- SERR- FastB2B-   
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-   
<TAbort- <MAbort- >SERR- <PERR-   
        Latency: 64 (1250ns min, 250ns max)   
        Interrupt: pin A routed to IRQ 11   
        Region 0: Memory at e0000000 (32-bit, non-prefetchable) [size=e1000000]   
        Region 1: Memory at e2000000 (32-bit, prefetchable) [size=32M]   
        Expansion ROM at 00010000 [disabled]   
        Capabilities: [60] Power Management version 1   
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA   
PME(D0-,D1-,D2-,D3hot-,D3cold-)   
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-   
        Capabilities: [44] AGP version 2.0   
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans-   
64bit- FW- AGP3- Rate=x1,x2   
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW-   
Rate=<none>   
   
Software Environment: 
I don't know what to write here. Maybe you want my GCC version? 
Reading specs from /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/specs 
Configured with: /var/tmp/portage/gcc-3.4.4/work/gcc-3.4.4/configure 
--enable-version-specific-runtime-libs --prefix=/usr 
--bindir=/usr/i686-pc-linux-gnu/gcc-bin/3.4.4 
--includedir=/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/include 
--datadir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.4 
--mandir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.4/man 
--infodir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.4/info 
--with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/include/g++-v3 
--host=i686-pc-linux-gnu --disable-altivec --enable-nls 
--without-included-gettext --with-system-zlib --disable-checking 
--disable-werror --disable-libunwind-exceptions --disable-multilib 
--disable-libgcj --enable-languages=c,c++ --enable-shared 
--enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu 
Thread model: posix 
gcc version 3.4.4 (Gentoo Hardened 3.4.4, ssp-3.4.4-1.0, pie-8.7.8) 
  
Problem Description:   
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424  
 [<c0218a19>] blk_remove_plug+0x69/0x70  
 [<c0218a3a>] __generic_unplug_device+0x1a/0x30  
 [<c0219408>] get_request_wait+0xf8/0x120  
 [<c01306f0>] autoremove_wake_function+0x0/0x60  
 [<c0222865>] cfq_find_rq_rb+0x35/0x80  
 [<c01306f0>] autoremove_wake_function+0x0/0x60  
 [<c0219e02>] __make_request+0xb2/0x5c0  
 [<c022a799>] ide_do_request+0x219/0x3a0  
 [<c01306f0>] autoremove_wake_function+0x0/0x60  
 [<c021a612>] generic_make_request+0xb2/0x240  
 [<c01306f0>] autoremove_wake_function+0x0/0x60  
 [<c01306f0>] autoremove_wake_function+0x0/0x60  
 [<c013e223>] mempool_alloc+0x33/0xd0  
 [<c021a7fa>] submit_bio+0x5a/0x100  
 [<c015d9e0>] bio_alloc_bioset+0x120/0x1d0  
 [<c0159b80>] end_buffer_write_sync+0x0/0x70  
 [<c015dab0>] bio_alloc+0x20/0x30  
 [<c015d2aa>] submit_bh+0x13a/0x190  
 [<c015d380>] ll_rw_block+0x80/0xa0  
 [<c01ad381>] journal_commit_transaction+0x301/0xf70  
 [<c02aa84c>] schedule+0x31c/0x600  
 [<c01b0129>] kjournald+0xb9/0x1f0  
 [<c011ee91>] exit_notify+0x581/0x840  
 [<c01306f0>] autoremove_wake_function+0x0/0x60  
 [<c01306f0>] autoremove_wake_function+0x0/0x60  
 [<c0102fc2>] ret_from_fork+0x6/0x14  
 [<c01b0050>] commit_timeout+0x0/0x10  
 [<c01b0070>] kjournald+0x0/0x1f0  
 [<c010136d>] kernel_thread_helper+0x5/0x18  
  
Steps to reproduce:   
Don't know how to reproduce the error. Should I send my .config file?
Comment 1 SteveB 2005-07-09 00:10:12 UTC
Hmm... looks like a 2.6.13-rc1 specific error. Have the same issue on another 
system runing 2.6.13-rc. Following output is all over the log: 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c02404b2>] start_request+0x242/0x2f0 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0240e7e>] ide_intr+0x11e/0x180 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c02404b2>] start_request+0x242/0x2f0 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0240e7e>] ide_intr+0x11e/0x180 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c02404b2>] start_request+0x242/0x2f0 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0240e7e>] ide_intr+0x11e/0x180 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c02404b2>] start_request+0x242/0x2f0 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0240e7e>] ide_intr+0x11e/0x180 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 [<c01011e5>] kernel_thread_helper+0x5/0x10 
Badness in blk_remove_plug at drivers/block/ll_rw_blk.c:1424 
 [<c022dfda>] blk_remove_plug+0x6a/0x70 
 [<c022dffa>] __generic_unplug_device+0x1a/0x30 
 [<c022ea88>] get_request_wait+0xf8/0x130 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c02385e5>] cfq_find_rq_rb+0x35/0x80 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022f5de>] __make_request+0xae/0x590 
 [<c02404b2>] start_request+0x242/0x2f0 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c022fdf2>] generic_make_request+0xb2/0x240 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0240e7e>] ide_intr+0x11e/0x180 
 [<c0134070>] autoremove_wake_function+0x0/0x60 
 [<c0142d33>] mempool_alloc+0x33/0xf0 
 [<c022ffda>] submit_bio+0x5a/0x100 
 [<c0164f50>] bio_alloc_bioset+0x120/0x1d0 
 [<c01616b0>] end_buffer_async_write+0x0/0xf0 
 [<c0165020>] bio_alloc+0x20/0x30 
 [<c01646fb>] submit_bh+0x13b/0x190 
 [<c0162b31>] __block_write_full_page+0x211/0x380 
 [<c01644de>] block_write_full_page+0xee/0x110 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c0167bd0>] blkdev_writepage+0x20/0x30 
 [<c0167a00>] blkdev_get_block+0x0/0x90 
 [<c01862b7>] mpage_writepages+0x277/0x450 
 [<c0167bb0>] blkdev_writepage+0x0/0x30 
 [<c0168b6d>] generic_writepages+0x1d/0x30 
 [<c013ee71>] __filemap_fdatawrite_range+0xc1/0xd0 
 [<c013eeb0>] filemap_fdatawrite+0x30/0x40 
 [<c01c38ef>] flush_async_commits+0x5f/0xa0 
 [<c012f3b3>] worker_thread+0x1f3/0x280 
 [<c01c3890>] flush_async_commits+0x0/0xa0 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c0119e70>] default_wake_function+0x0/0x20 
 [<c012f1c0>] worker_thread+0x0/0x280 
 [<c0133b7c>] kthread+0xbc/0x100 
 [<c0133ac0>] kthread+0x0/0x100 
 
Comment 2 SteveB 2005-07-10 05:03:18 UTC
This bug seams to be gone in 2.6.13-rc2. Therefore I am closing this bug now. 
Comment 3 tobias 2005-07-26 14:32:30 UTC
no still in 2.6.13rc3 it is still in my system 
Comment 4 tobias 2005-07-31 08:12:25 UTC
Created attachment 5432 [details]
config 2.6.13rc3

my kernel config in 2.6.13rc3
Comment 5 SteveB 2005-07-31 19:12:25 UTC
Could you try rc4 and tell us, if you still have the error? I did not faced 
this error anymore since rc2. 
 
cheers 
 
Steve 
Comment 6 tobias 2005-08-01 03:47:31 UTC
this bug shoud be the same as:
http://bugzilla.kernel.org/show_bug.cgi?id=4438

so please mark one as dublicated 
Comment 7 Natalie Protasevich 2007-08-27 01:35:39 UTC
Any update on this problem? Is it long gone hopefully? :)
Thanks.
Comment 8 SteveB 2007-08-27 03:01:31 UTC
For me this bug is gone. So close it.

Note You need to log in before you can comment on or make changes to this bug.