Bug 4824 - Machine will not boot when using 2.6.12.2
Machine will not boot when using 2.6.12.2
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 blocking
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-30 09:30 UTC by John Doe
Modified: 2005-07-22 10:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.12.2
Tree: Mainline
Regression: ---


Attachments
Modprobe output for a 2.6.12.1 kernel (12.54 KB, text/plain)
2005-06-30 19:50 UTC, John Doe
Details
al_pavel: dmesg output when using 2.6.12.1 (12.02 KB, text/plain)
2005-07-01 08:43 UTC, Pavel Alexeev
Details

Description John Doe 2005-06-30 09:30:29 UTC
Distribution: Gentoo Linux (With kernel.org vanilla kernel )
Hardware Environment: Athlon XP-M 2100+
                      HP Pavilion Ze4400
Software Environment: Gentoo Linux
Problem Description:
When booting my machine it hangs after finding the ALI Chipset, but before it
finds the hard drive hda.

Steps to reproduce: 
Reboot Machine with 2.6.12.2 (2.6.12.1 boots fine)
Comment 1 Adrian Bunk 2005-06-30 14:30:02 UTC
Is this a vanilla ftp.kernel.org kernel or a Gentoo kernel?
In the latter case, does a vanilla ftp.kernel.org 2.6.12.2 exhibit this problem?

Which gcc version are you using?

The 2.6.12.1 -> 2.6.12.2 patch touches only 7 files (excluding the version
change in the main Makefile). Can you find the file whose change broke your booting?

Please attach dmesg output of a 2.6.12.1 boot.
Comment 2 John Doe 2005-06-30 17:53:27 UTC
it is a vanilla ftp.kernel.org kernel

gcc version 3.3.5-20050130 (Gentoo Linux 3.3.5.20050130-r1,
ssp-3.3.5.20050130-1, pie-8.7.7.1)

I dont have access to the logs right now but I will when I get home.
Comment 3 John Doe 2005-06-30 19:50:48 UTC
Created attachment 5243 [details]
Modprobe output for a 2.6.12.1 kernel
Comment 4 John Doe 2005-06-30 19:53:21 UTC
When trying to boot 2.6.12.2
it hangs at line:

170 of the attached file.
Comment 5 Pavel Alexeev 2005-07-01 08:41:31 UTC
2.6.12.2 does not boot also for me! With the same .config, 2.6.12.1 boots
succesfully.

HP Omnibook xe4500: P4-1700, chipset ALi M1671, ATI Radeon Mobility M6 LY,
ALI15X3 IDE controller.

The boot process freezes after the kernel has found my IDE controller. No log
entries because the logger is not yet started at this time.

This is the vanilla kernel from kernel.org. 

gcc version 3.3.4, slackware 10.1.
Comment 6 Pavel Alexeev 2005-07-01 08:43:40 UTC
Created attachment 5247 [details]
al_pavel: dmesg output when using 2.6.12.1
Comment 7 Pavel Alexeev 2005-07-01 09:42:31 UTC
After i have reverted the patch for drivers/pci/pci-driver.c (',' -> ';'), the
kernel 2.6.12.2 boots succesfully (i' using it currently)... 8(
Comment 8 Pavel Alexeev 2005-07-01 10:30:41 UTC
More accurately: TWO patches should NOT be applied: drivers/pci/pci-driver.c AND
(!!) drivers/acpi/pci_irq.c. The configuration "all patches but
drivers/pci/pci-driver.c" DOES NOT boot on my machine!
Comment 9 Adrian Bunk 2005-07-02 04:07:29 UTC
Thanks for this information.

I'm reassigning this bug to Greg who is both PCI maintainer and maintainer of
the stable 2.6.12.x tree.
Comment 10 Adrian Bunk 2005-07-02 04:13:03 UTC
One more question:

Is undoing the drivers/acpi/pci_irq.c patch alone enough for fixing the problem? 
Comment 11 Chris Van Humbeeck 2005-07-02 23:29:12 UTC
On a Dell PowerEdge 2850 server with raid controller, a vanilla 2.6.12.2 kernel
crashes at startup.

Some output from dmesg: 
  ICH5: IDE controller at PCI slot 0000:00:1f.1
  PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
  ACPI: PCI Interrupt 0000:00:1f.1[A]: no GSI - using IRQ 0

The crash seems to happen a little bit later in the megadriver_mbox module.

Removing the

  acpi_register_gsi(dev->irq, ACPI_LEVEL_SENSITIVE, ACPI_ACTIVE_LOW);

in pci_irq.c fixes the problem.

Another option is changing the check "dev->irq >= 0" to "dev->irq > 0"
Comment 12 Pavel Alexeev 2005-07-03 16:05:59 UTC
Yes, the solution
> changing the check "dev->irq >= 0" to "dev->irq > 0"
works for me (on 2.6.12.2, without any other changes).
Comment 13 John Doe 2005-07-03 19:03:45 UTC
Yes this patch fixed the problem for me as well...=)
Thank you
Comment 14 Jean-Damien Durand 2005-07-04 23:25:35 UTC
2.6.12.2 problem confirmed on presario 2519eu laptop, fortunately linus's 
patch at 
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=44f8e1a20cf3afe10a3744bd9317808a39a242bb 
apparently solves the problem. 
Before that, pressing any key eventually unblocked the boot, until another 
stage got blocked again, etc. Usually it happened right after hotplug was 
trying to probe usb. 
 
Comment 15 Adrian Bunk 2005-07-22 10:38:49 UTC
This problem should be fixed in both 2.6.12.3 and 2.6.13-rc3.

Note You need to log in before you can comment on or make changes to this bug.