Bug 4793 - Battery reads result in high cpu usage
Battery reads result in high cpu usage
Status: REJECTED DUPLICATE of bug 4665
Product: ACPI
Classification: Unclassified
Component: Power-Battery
i386 Linux
: P2 high
Assigned To: Luming Yu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-24 14:12 UTC by Jon Westgate
Modified: 2005-08-21 01:18 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.9 - 2.6.12.1
Tree: Mainline
Regression: ---


Attachments

Description Jon Westgate 2005-06-24 14:12:55 UTC
Distribution: Debian Sid
Hardware Environment: Asus w1000
Software Environment: Vanilla Kernel built by my own fair hand
Problem Description: when running any app that polls for battery status my
machine grinds to a halt. If run top it shows which ever battery app as using
>20% cpu.
I have mostly gotton round this by adding the line:
#define ACPI_ENABLE_OBJECT_CACHE 1
in include/acpi.h
But whatever acpi app I use still uses >3% cpu bandwidth.
This didn't happen on kernels <2.6.8
My kernel config is here http://fsck.tv/conf-2.6.12

Steps to reproduce: Build kernel as normal (use my config)
launch an acpi app such as wmacpi or wmbattery. Watch your system slow to a stop
It even does this when you cat /proc/acpi/battery/BAT0/state in fact if you were
to write a script to do this you could cripple the system
Comment 1 Luming Yu 2005-07-04 22:41:21 UTC
Please test 2.6.13-rc1-mm1
Comment 2 Jon Westgate 2005-07-10 13:44:30 UTC
when running 2.6.13-rc1-mm1 
acpi apps are unable to read the status of my battery
if I try to cat /proc/acpi/battery/BAT0/state 
I get nothing, cat just hangs I have to kill with ^C
I fact this happens if I try to cat anything inside /proc/acpi/battery/BAT0/
Comment 3 Jon Westgate 2005-07-10 13:47:26 UTC
Forgot to say that although I cant actualy use the battery status anymore there
is zero cpu useage by cat (even though it appears hung)
Comment 4 Luming Yu 2005-07-10 23:04:28 UTC
Just guess you have the similar problem like 
http://bugzilla.kernel.org/show_bug.cgi?id=4665

To debug further, could you test 
http://bugzilla.kernel.org/process_bug.cgi#c23 
Comment 5 Andrew Morton 2005-07-28 22:34:25 UTC
hm, a few people have reported this.  Is it
still happening in 2.6.13-rc4?
Comment 6 Jon Westgate 2005-07-30 05:05:41 UTC
linux-2.6.13-rc4.
acpi hangs on boot for 30 seconds.
after battery condition is not readable.
I don't know if this is due to a crash as acpi starts up etc

Basicly its more broken on 2.6.13-rc4
Comment 7 Luming Yu 2005-07-30 05:50:48 UTC
Please test ec_polling patch at http://bugzilla.kernel.org/show_bug.cgi?id=4665
Note: boot kernel with ec_polling option
Comment 8 Andrew Morton 2005-08-04 13:18:51 UTC
Lots of people have reported this problem.

Do we expect that it's now fixed with the ec revert?
Comment 9 Len Brown 2005-08-14 23:06:19 UTC
What do you see with 2.6.13-rc6 as compared to 2.6.12.1?
Comment 10 Luming Yu 2005-08-21 01:18:26 UTC
This should be fixed like bug 4665, which is ASUS L5D. Close it as duplicate.

*** This bug has been marked as a duplicate of 4665 ***

Note You need to log in before you can comment on or make changes to this bug.