Bug 47911 - Wireless key: BCM4312 not working + can't emulate rawmode for keycode 240
Summary: Wireless key: BCM4312 not working + can't emulate rawmode for keycode 240
Status: RESOLVED INVALID
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL: https://bugs.launchpad.net/ubuntu/+so...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-24 10:16 UTC by Bob Merhebi
Modified: 2014-11-29 17:05 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.2.0-31-generic
Tree: Mainline
Regression: No


Attachments

Description Bob Merhebi 2012-09-24 10:16:51 UTC
Thought the Broadcom STA driver is activated, still the Broadcom BCM4312 chip isn't working on Ubuntu 12.04 x86_64 (used to work on 10.04 i686).

Tried this: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#Identifying_Your_Card.2BAC8-Driver

There already exists 2 relevant bugs on launchpad:
https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677
https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/989610/


Moreover, I realized that pressing the wireless button on my Dell Studio XPS 1640 leads to a 
keyboard: can't emulate rawmode for keycode 240
keyboard: can't emulate rawmode for keycode 240

error, whether the wifi works or not.

This might be related to the keyboard error error: http://ubuntuforums.org/showthread.php?t=1745681

This error also seems to be submitted on RedHat's kernel Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=735516
Comment 1 Bob Merhebi 2012-12-16 11:16:27 UTC
Just a quick update: now most of the times the chip is working; on rare occasions it doesn't!

not sure about the reason!
Comment 2 Rafał Miłecki 2014-11-29 17:05:27 UTC
We don't support closed source drivers, really...

Note You need to log in before you can comment on or make changes to this bug.