Bug 47791 - AMD SB950 USB 2 regression first with kernel 2.6.37
AMD SB950 USB 2 regression first with kernel 2.6.37
Status: RESOLVED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: USB
x86-64 Linux
: P1 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2012-09-22 07:50 UTC by Jean-Dominique Frattini
Modified: 2013-01-18 07:28 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.6-rc6
Tree: Mainline
Regression: Yes


Attachments
output from various commands and log files (102.35 KB, text/plain)
2012-09-22 07:50 UTC, Jean-Dominique Frattini
Details

Description Jean-Dominique Frattini 2012-09-22 07:50:11 UTC
Created attachment 80721 [details]
output from various commands and log files

Tested with several kernels:

* 3.0
* most 3.2.x from debian wheezy
* 3.3.0
* 3.4
* 3.6RC6
* 2.6.30 - 2.6.32

USB 2 ports on the mainboard MSI 990XA-GD55 work with kernels 2.6 but stop to work with kernel 3.x.
USB 3 ports work well on both 2.6 and 3.x kernels.

Chipset on the mainboard is an AMD SB950.

I attached a file that reports outputs from: dmesg, lspci -vvv, lsusb -vvv, /var/log/syslog and /var/log/messages.

The main output error when we plug an USB device into the USB 2 port is:

"usb 4-4: device descriptor read/64, error -32"

Tested with:

MSI 990XA-GD55 mainboard, AMD FX 4170 CPU, on Debian Wheezy.
Comment 1 Greg Kroah-Hartman 2012-09-22 14:46:40 UTC
On Sat, Sep 22, 2012 at 07:50:11AM +0000, bugzilla-daemon@bugzilla.kernel.org wrote:
>            Summary: AMD SB950 USB 2 don't work on kernel 3.x but worked on
>                     2.6.x

Please post this on the linux-usb@vger.kernel.org mailing list.
Comment 2 Jean-Dominique Frattini 2012-09-22 15:08:37 UTC
I just did it as requested.
Comment 3 Jean-Dominique Frattini 2012-12-02 15:06:39 UTC
Added first version where the bug happens (2.6.37).
Renamed the bug title to reflect more the regression.
Comment 4 Jean-Dominique Frattini 2012-12-03 13:29:08 UTC
First git commit that introduced the regression: b5153163ed580e00c67bdfecb02b2e3843817b3e
Comment 5 Jonathan Nieder 2012-12-08 08:37:35 UTC
References: http://thread.gmane.org/gmane.linux.usb.general/71551
Comment 6 Jean-Dominique Frattini 2012-12-08 11:40:10 UTC
With a bisect from the root linux source tree, the commit that is the cause of the regression looks less suspicious.

Kernel version is 2.6.36-rc4

And the commit is this one:

5c80cc78de46aef6cd5e714208da05c3f7f548f8 is the first bad commit
commit 5c80cc78de46aef6cd5e714208da05c3f7f548f8

See references as written above for more information.
Comment 7 Jean-Dominique Frattini 2013-01-11 15:37:36 UTC
As said here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/859137 updated to the latest BIOS resolved the bug despite of the fact that the mainboard service explicitly said that it is impossible that the bug could come from them.

Note You need to log in before you can comment on or make changes to this bug.