Bug 47341 - Wrong/impossible cputimes for migration processes
Summary: Wrong/impossible cputimes for migration processes
Status: CLOSED CODE_FIX
Alias: None
Product: Timers
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: john stultz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-10 19:54 UTC by gunnar.eggen
Modified: 2014-10-03 22:34 UTC (History)
6 users (show)

See Also:
Kernel Version: >=3.0.7
Tree: Mainline
Regression: Yes


Attachments
kernel config (56.18 KB, application/octet-stream)
2012-09-10 19:54 UTC, gunnar.eggen
Details

Description gunnar.eggen 2012-09-10 19:54:08 UTC
Created attachment 79701 [details]
kernel config

The cputimes/load reported from top/ps etc. report extreme loads on kernel processes migration/x.   The problem isn't permanent as it takes a while to set off, but once it does it escalates and never stops.  

I am unable to locate what's triggering it, but I did a bisect and found the commit at fault: 
commit d670ec13178d0fd8680e6742a2bc6e04f28f87d8 - posix-cpu-timers: Cure SMP wobbles.

The load reported doesn't seem real, as there's no sign that the system is under heavy load or unresponsive.

Compiling with CONFIG_NO_HZ=N seems to help for some, but I've only seen a delay in the triggering of it.

Reproducible: Always

Steps to Reproduce:
1. Boot normally with kernel >= 3.0.7
2. Wait ~1 hour (unable to figure out what sets it off. Idle vs full load doesn't seem to matter)

Actual Results:  
Cpuload/cputime on some migration/x kernel processes show a constant load between 20-100%.  Cpu frequency scaling (ondemand) seems to be affected as it never scales down the cores/threads affected. 

Expected Results:  
Report normal load on migration processes. Allow ondemand to scale down.

The bug was first reported here: https://bugs.gentoo.org/show_bug.cgi?id=394487
Comment 1 john stultz 2012-09-11 17:49:17 UTC
Adding PeterZ, since he might have more context.
Comment 2 gunnar.eggen 2013-01-12 01:24:01 UTC
The issue seems to be resolved with version >=3.6.11. Changing status to resolved.

Note You need to log in before you can comment on or make changes to this bug.