Bug 4725 - KBUILD_CHECK in $(srcdir)/Makefile
Summary: KBUILD_CHECK in $(srcdir)/Makefile
Status: CLOSED CODE_FIX
Alias: None
Product: Other
Classification: Unclassified
Component: Configuration (show other bugs)
Hardware: i386 Linux
: P2 low
Assignee: Sam Ravnborg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-09 19:49 UTC by Ken Morgan
Modified: 2005-09-10 06:18 UTC (History)
0 users

See Also:
Kernel Version: 2.6.11.11
Tree: Mainline
Regression: ---


Attachments
Do not pass KBUILD_CHECK to second make invocation (1.23 KB, patch)
2005-07-27 00:12 UTC, Sam Ravnborg
Details | Diff

Description Ken Morgan 2005-06-09 19:49:55 UTC
Distribution: n/a
Hardware Environment: n/a
Software Environment: n/a
Problem Description: Line 113 in Makefile.  If O=dir is used to relocate output,
the C=1 option does not get passed to the second invocation of make in the
output directory because KBUILD_CHECK=$(KBUILD_CHECK) is passed to the second
invocation.  KBUILD_CHECKSRC=$(KBUILD_CHECKSRC) should be passed instead.

Steps to reproduce: Did not test, but it seems clear from the makefile that this
behavior would occur.
Comment 1 Sam Ravnborg 2005-07-27 00:12:52 UTC
Created attachment 5378 [details]
Do not pass KBUILD_CHECK to second make invocation
Comment 2 Sam Ravnborg 2005-09-10 06:18:05 UTC
Fixed in latest -git tree. Atached patch has been applied.

Note You need to log in before you can comment on or make changes to this bug.