Bug 47161 - No drivers for new Atheros AR8162
Summary: No drivers for new Atheros AR8162
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-07 01:27 UTC by MonetsChemist
Modified: 2012-09-07 15:34 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.2.
Tree: Mainline
Regression: No


Attachments

Description MonetsChemist 2012-09-07 01:27:16 UTC
Several new-ish laptops (eg Dell Inspiron 14Z) use the Atheros AR8162 ethernet chip for their wired networking, and it appears that there is no driver in this kernel version (at least).

There is a driver available at

http://linuxwireless.org/download/compat-wireless-2.6/

I have used compat-wireless-2012-09-01-pc.tar.bz2 with success.

which appears to work fine when compiled and loaded as per instructions.

I initially filed this problem downstream on Launchpad, as

https://bugs.launchpad.net/bugs/1046435

which is apparently a duplicate of

https://bugs.launchpad.net/bugs/927782

One of the maintainers suggested I file an upstream bug as well.
Comment 1 Alan 2012-09-07 15:34:27 UTC
Whoever said that was wrong in this case I think. It's up to Ubuntu what backports it ships in its 3.2 kernels

Note You need to log in before you can comment on or make changes to this bug.