Bug 47091 - e1000e ethernet interface loses carrier when changing MTU (disrupts dhcp)
e1000e ethernet interface loses carrier when changing MTU (disrupts dhcp)
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 high
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 08:16 UTC by Andrea Ratto
Modified: 2013-11-19 23:17 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.5.3
Tree: Mainline
Regression: No


Attachments

Description Andrea Ratto 2012-09-06 08:16:36 UTC
By changing mtu in any way the link is physically lost for a moment (it is sensed on the other end of the wire, too)

This behavior is disruptive when the mtu is changed during dhcp: dhcpcd senses that the carrier is lost and restart the configuration process, thus entering an infinite loop. 
ISC's dhclient seems tolerant of such small disconnection but changing the default dhcp client of a distro is not easy nor recommended.

All means of changing the mtu produce this effect: ifconfig, ip link and directly writing to /sys/class/net/eth0/mtu.

The distribution is Archlinux, latest stable kernel, clean installation on a Dell Latitude E6430. 
I did not save the logs, but the issue is affecting other users, like:
https://bbs.archlinux.org/viewtopic.php?id=79923
http://forums.gentoo.org/viewtopic-t-869743.html

Proper behavior requires that mtu changes do not break the link. It seems like some kind of shortcut has been taken in the code: reinitialize everything instead of just what is needed.
Comment 1 Andrea Ratto 2012-11-04 17:55:47 UTC
Is any other information required to check the validity of this bug?

Note You need to log in before you can comment on or make changes to this bug.